summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlec Warner <antarus@gentoo.org>2007-01-17 20:48:00 +0000
committerAlec Warner <antarus@gentoo.org>2007-01-17 20:48:00 +0000
commit59dedab4d514acd4cf4083c2ac61c2dad91b24a5 (patch)
tree54d8e5a960473cc81b825f772c4bff5e45488f88 /app-benchmarks
parentCorrect minimal needed kdeartwork-emoticons vesion. (diff)
downloadgentoo-2-59dedab4d514acd4cf4083c2ac61c2dad91b24a5.tar.gz
gentoo-2-59dedab4d514acd4cf4083c2ac61c2dad91b24a5.tar.bz2
gentoo-2-59dedab4d514acd4cf4083c2ac61c2dad91b24a5.zip
bump for bug # 135366
(Portage version: 2.1.1-r2)
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/stress/ChangeLog9
-rw-r--r--app-benchmarks/stress/files/digest-stress-0.18.83
-rw-r--r--app-benchmarks/stress/stress-0.18.8.ebuild29
3 files changed, 39 insertions, 2 deletions
diff --git a/app-benchmarks/stress/ChangeLog b/app-benchmarks/stress/ChangeLog
index 51597014bc97..217a2db8a421 100644
--- a/app-benchmarks/stress/ChangeLog
+++ b/app-benchmarks/stress/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-benchmarks/stress
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/stress/ChangeLog,v 1.25 2006/12/06 20:03:38 eroyf Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/stress/ChangeLog,v 1.26 2007/01/17 20:48:00 antarus Exp $
+
+*stress-0.18.8 (17 Jan 2007)
+
+ 17 Jan 2007; Alec Warner <antarus@gentoo.org> +stress-0.18.8.ebuild:
+ bump for bug # 135366
06 Dec 2006; Alexander H. Færøy <eroyf@gentoo.org> stress-0.18.6.ebuild:
Stable on MIPS.
diff --git a/app-benchmarks/stress/files/digest-stress-0.18.8 b/app-benchmarks/stress/files/digest-stress-0.18.8
new file mode 100644
index 000000000000..8df2892e77c1
--- /dev/null
+++ b/app-benchmarks/stress/files/digest-stress-0.18.8
@@ -0,0 +1,3 @@
+MD5 160d41166d98a1e88c3f95f556633b71 stress-0.18.8.tar.gz 163721
+RMD160 dfda746b2a7ea65c55594dc1054347addf582bde stress-0.18.8.tar.gz 163721
+SHA256 3f753cd91828808ecbdeffd1fe3125eccc6f71ecad7756115acc08b3e2c764dc stress-0.18.8.tar.gz 163721
diff --git a/app-benchmarks/stress/stress-0.18.8.ebuild b/app-benchmarks/stress/stress-0.18.8.ebuild
new file mode 100644
index 000000000000..68fb1a89bff2
--- /dev/null
+++ b/app-benchmarks/stress/stress-0.18.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/stress/stress-0.18.8.ebuild,v 1.1 2007/01/17 20:48:00 antarus Exp $
+
+inherit flag-o-matic
+
+MY_P="${PN}-${PV/_/}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Imposes stressful loads on different aspects of the system."
+HOMEPAGE="http://weather.ou.edu/~apw/projects/stress"
+SRC_URI="http://weather.ou.edu/~apw/projects/stress/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static"
+
+DEPEND="virtual/libc"
+
+src_compile() {
+ use static && append-ldflags -static
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog AUTHORS README
+}