summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-03-02 00:20:32 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-03-02 00:20:32 +0000
commit9099a3406644f53d93668bd98d09a29078aede8c (patch)
treef3da8005847a52afc0a0d3e58a6d7d21c7d1258d /app-benchmarks/contest
parentVersion bumped. (diff)
downloadgentoo-2-9099a3406644f53d93668bd98d09a29078aede8c.tar.gz
gentoo-2-9099a3406644f53d93668bd98d09a29078aede8c.tar.bz2
gentoo-2-9099a3406644f53d93668bd98d09a29078aede8c.zip
Fix for gcc 4.3.3 / fortify_sources. Adding ~amd64 keyword. Patch by Magnus Granberg. Closes #260451
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-benchmarks/contest')
-rw-r--r--app-benchmarks/contest/ChangeLog9
-rw-r--r--app-benchmarks/contest/contest-0.61.ebuild10
-rw-r--r--app-benchmarks/contest/files/contest-fortify_sources.patch11
3 files changed, 24 insertions, 6 deletions
diff --git a/app-benchmarks/contest/ChangeLog b/app-benchmarks/contest/ChangeLog
index ecae5aef5846..79f2e8faa2ed 100644
--- a/app-benchmarks/contest/ChangeLog
+++ b/app-benchmarks/contest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-benchmarks/contest
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/contest/ChangeLog,v 1.8 2008/12/30 17:26:47 angelos Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/contest/ChangeLog,v 1.9 2009/03/02 00:20:32 patrick Exp $
+
+ 02 Mar 2009; Patrick Lauer <patrick@gentoo.org>
+ +files/contest-fortify_sources.patch, contest-0.61.ebuild:
+ Fix for gcc 4.3.3 / fortify_sources. Adding ~amd64 keyword. Patch by
+ Magnus Granberg. Closes #260451
30 Dec 2008; Christoph Mende <angelos@gentoo.org> contest-0.61.ebuild:
QA: Use correct CC (bug #243514) and respect LDFLAGS
diff --git a/app-benchmarks/contest/contest-0.61.ebuild b/app-benchmarks/contest/contest-0.61.ebuild
index 214bd1b78a7e..e865f5aa1541 100644
--- a/app-benchmarks/contest/contest-0.61.ebuild
+++ b/app-benchmarks/contest/contest-0.61.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/contest/contest-0.61.ebuild,v 1.7 2008/12/30 17:26:47 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/contest/contest-0.61.ebuild,v 1.8 2009/03/02 00:20:32 patrick Exp $
-inherit toolchain-funcs
+inherit toolchain-funcs eutils
DESCRIPTION="Test system responsiveness to compare different kernels"
HOMEPAGE="http://members.optusnet.com.au/ckolivas/contest/"
@@ -10,7 +10,7 @@ SRC_URI="http://members.optusnet.com.au/ckolivas/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~ppc ~x86"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
RDEPEND=">=app-benchmarks/dbench-2.0"
@@ -19,6 +19,8 @@ src_unpack () {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}/contest-fortify_sources.patch"
+
#Removing -g
sed -i "s:-g::" Makefile
#Adding our cflags
diff --git a/app-benchmarks/contest/files/contest-fortify_sources.patch b/app-benchmarks/contest/files/contest-fortify_sources.patch
new file mode 100644
index 000000000000..cb2e6d6dd639
--- /dev/null
+++ b/app-benchmarks/contest/files/contest-fortify_sources.patch
@@ -0,0 +1,11 @@
+--- bmark.c 2009-02-27 23:13:44.000000000 +0000
++++ bmark.c 2009-02-27 23:12:44.000000000 +0000
+@@ -47,7 +47,7 @@
+ }
+ /* child */
+
+- if((tmpfd=open(TMP_FILE, O_RDWR|O_CREAT|O_TRUNC))==-1){
++ if((tmpfd=open(TMP_FILE, O_RDWR|O_CREAT|O_TRUNC, S_IRUSR|S_IWUSR))==-1){
+ printsys("Could not open temporary file\n");
+ }
+ if(dup2(tmpfd, TMP_FD)==-1){