summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2015-02-23 15:05:30 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2015-02-23 15:05:30 +0000
commitdb40f25cf96cf678927038de48ef600b9f840508 (patch)
tree57408331d62d94ce5d7f868318fe3e2faf3dcfd3 /app-backup
parentrevbump; convert -> distutils-r1, add python herd, agreement with jlec (diff)
downloadgentoo-2-db40f25cf96cf678927038de48ef600b9f840508.tar.gz
gentoo-2-db40f25cf96cf678927038de48ef600b9f840508.tar.bz2
gentoo-2-db40f25cf96cf678927038de48ef600b9f840508.zip
Update bundled libtools (bug 466696)
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 0x762053D5)
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/bacula/ChangeLog7
-rw-r--r--app-backup/bacula/bacula-5.0.3-r3.ebuild12
-rw-r--r--app-backup/bacula/bacula-5.0.3-r4.ebuild10
-rw-r--r--app-backup/bacula/bacula-5.2.13-r3.ebuild10
-rw-r--r--app-backup/bacula/bacula-5.2.13.ebuild12
-rw-r--r--app-backup/bacula/bacula-7.0.5-r1.ebuild10
-rw-r--r--app-backup/bacula/bacula-7.0.5.ebuild12
7 files changed, 57 insertions, 16 deletions
diff --git a/app-backup/bacula/ChangeLog b/app-backup/bacula/ChangeLog
index 0651c7cfbaec..cfbbf9094092 100644
--- a/app-backup/bacula/ChangeLog
+++ b/app-backup/bacula/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-backup/bacula
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/ChangeLog,v 1.172 2015/02/23 14:37:31 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/ChangeLog,v 1.173 2015/02/23 15:05:30 tomjbe Exp $
+
+ 23 Feb 2015; Thomas Beierlein <tomjbe@gentoo.org> bacula-5.0.3-r3.ebuild,
+ bacula-5.0.3-r4.ebuild, bacula-5.2.13.ebuild, bacula-5.2.13-r3.ebuild,
+ bacula-7.0.5.ebuild, bacula-7.0.5-r1.ebuild:
+ Update bundled libtools (bug #466696)
*bacula-5.2.13-r3 (23 Feb 2015)
*bacula-5.0.3-r4 (23 Feb 2015)
diff --git a/app-backup/bacula/bacula-5.0.3-r3.ebuild b/app-backup/bacula/bacula-5.0.3-r3.ebuild
index 6f4cba5b7103..578964b306ac 100644
--- a/app-backup/bacula/bacula-5.0.3-r3.ebuild
+++ b/app-backup/bacula/bacula-5.0.3-r3.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/bacula-5.0.3-r3.ebuild,v 1.22 2014/12/28 14:42:00 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/bacula-5.0.3-r3.ebuild,v 1.23 2015/02/23 15:05:30 tomjbe Exp $
EAPI="5"
PYTHON_DEPEND="python? 2"
PYTHON_USE_WITH="threads"
PYTHON_USE_WITH_OPT="python"
-inherit eutils multilib python qt4-r2 user
+inherit eutils multilib python qt4-r2 user libtool
MY_PV=${PV/_beta/-b}
MY_P=${PN}-${MY_PV}
@@ -142,6 +142,12 @@ src_prepare() {
# fix CVE-2012-4430
epatch "${FILESDIR}"/${PV}/${P}-cve.patch
+
+ # fix bundled libtool (bug 466696)
+ # But first move directory with M4 macros out of the way.
+ # It is only needed by i autoconf and gives errors during elibtoolize.
+ mv autoconf/libtool autoconf/libtool1 || die
+ elibtoolize
}
src_configure() {
diff --git a/app-backup/bacula/bacula-5.0.3-r4.ebuild b/app-backup/bacula/bacula-5.0.3-r4.ebuild
index 737e03dc0e18..97d898b695c2 100644
--- a/app-backup/bacula/bacula-5.0.3-r4.ebuild
+++ b/app-backup/bacula/bacula-5.0.3-r4.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/bacula-5.0.3-r4.ebuild,v 1.1 2015/02/23 14:37:31 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/bacula-5.0.3-r4.ebuild,v 1.2 2015/02/23 15:05:30 tomjbe Exp $
EAPI="5"
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"
-inherit eutils multilib python-single-r1 qt4-r2 user
+inherit eutils multilib python-single-r1 qt4-r2 user libtool
MY_PV=${PV/_beta/-b}
MY_P=${PN}-${MY_PV}
@@ -142,6 +142,12 @@ src_prepare() {
# fix CVE-2012-4430
epatch "${FILESDIR}"/${PV}/${P}-cve.patch
+
+ # fix bundled libtool (bug 466696)
+ # But first move directory with M4 macros out of the way.
+ # It is only needed by i autoconf and gives errors during elibtoolize.
+ mv autoconf/libtool autoconf/libtool1 || die
+ elibtoolize
}
src_configure() {
diff --git a/app-backup/bacula/bacula-5.2.13-r3.ebuild b/app-backup/bacula/bacula-5.2.13-r3.ebuild
index f36315b93236..c135b8e002e8 100644
--- a/app-backup/bacula/bacula-5.2.13-r3.ebuild
+++ b/app-backup/bacula/bacula-5.2.13-r3.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/bacula-5.2.13-r3.ebuild,v 1.1 2015/02/23 14:37:31 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/bacula-5.2.13-r3.ebuild,v 1.2 2015/02/23 15:05:30 tomjbe Exp $
EAPI="5"
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"
-inherit eutils multilib python-single-r1 qt4-r2 systemd user
+inherit eutils multilib python-single-r1 qt4-r2 systemd user libtool
MY_PV=${PV/_beta/-b}
MY_P=${PN}-${MY_PV}
@@ -153,6 +153,12 @@ src_prepare() {
sed -i -e '/StandardOutput/d' platforms/systemd/*.service.in || die
# bug 504370
sed -i -e '/Alias=bacula-dir/d' platforms/systemd/bacula-dir.service.in || die
+
+ # fix bundled libtool (bug 466696)
+ # But first move directory with M4 macros out of the way.
+ # It is only needed by i autoconf and gives errors during elibtoolize.
+ mv autoconf/libtool autoconf/libtool1 || die
+ elibtoolize
}
src_configure() {
diff --git a/app-backup/bacula/bacula-5.2.13.ebuild b/app-backup/bacula/bacula-5.2.13.ebuild
index 8eb74260bd00..ee6d8f8581f8 100644
--- a/app-backup/bacula/bacula-5.2.13.ebuild
+++ b/app-backup/bacula/bacula-5.2.13.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/bacula-5.2.13.ebuild,v 1.10 2014/12/28 14:42:00 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/bacula-5.2.13.ebuild,v 1.11 2015/02/23 15:05:30 tomjbe Exp $
EAPI="4"
PYTHON_DEPEND="python? 2"
PYTHON_USE_WITH="threads"
PYTHON_USE_WITH_OPT="python"
-inherit eutils multilib python qt4-r2 user
+inherit eutils multilib python qt4-r2 user libtool
MY_PV=${PV/_beta/-b}
MY_P=${PN}-${MY_PV}
@@ -146,6 +146,12 @@ src_prepare() {
# fix file not found error during make depend
epatch "${FILESDIR}"/5.2.12/${PN}-5.2.12-depend.patch
+
+ # fix bundled libtool (bug 466696)
+ # But first move directory with M4 macros out of the way.
+ # It is only needed by i autoconf and gives errors during elibtoolize.
+ mv autoconf/libtool autoconf/libtool1 || die
+ elibtoolize
}
src_configure() {
diff --git a/app-backup/bacula/bacula-7.0.5-r1.ebuild b/app-backup/bacula/bacula-7.0.5-r1.ebuild
index 4b1ad023a47e..e91861b10415 100644
--- a/app-backup/bacula/bacula-7.0.5-r1.ebuild
+++ b/app-backup/bacula/bacula-7.0.5-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/bacula-7.0.5-r1.ebuild,v 1.3 2015/01/31 14:12:00 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/bacula-7.0.5-r1.ebuild,v 1.4 2015/02/23 15:05:30 tomjbe Exp $
EAPI="5"
-inherit eutils multilib qt4-r2 systemd user
+inherit eutils multilib qt4-r2 systemd user libtool
MY_PV=${PV/_beta/-b}
MY_P=${PN}-${MY_PV}
@@ -149,6 +149,12 @@ src_prepare() {
if use bacula-clientonly; then
sed -i -e 's/bacula/root/' platforms/systemd/bacula.conf.in || die
fi
+
+ # fix bundled libtool (bug 466696)
+ # But first move directory with M4 macros out of the way.
+ # It is only needed by i autoconf and gives errors during elibtoolize.
+ mv autoconf/libtool autoconf/libtool1 || die
+ elibtoolize
}
src_configure() {
diff --git a/app-backup/bacula/bacula-7.0.5.ebuild b/app-backup/bacula/bacula-7.0.5.ebuild
index 7d36ef8b101b..d2cda4fb525c 100644
--- a/app-backup/bacula/bacula-7.0.5.ebuild
+++ b/app-backup/bacula/bacula-7.0.5.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/bacula-7.0.5.ebuild,v 1.3 2014/12/28 14:42:00 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/bacula-7.0.5.ebuild,v 1.4 2015/02/23 15:05:30 tomjbe Exp $
EAPI="5"
-inherit eutils multilib qt4-r2 systemd user
+inherit eutils multilib qt4-r2 systemd user libtool
MY_PV=${PV/_beta/-b}
MY_P=${PN}-${MY_PV}
@@ -142,6 +142,12 @@ src_prepare() {
sed -i -e '/StandardOutput/d' platforms/systemd/*.service.in || die
# bug 504370
sed -i -e '/Alias=bacula-dir/d' platforms/systemd/bacula-dir.service.in || die
+
+ # fix bundled libtool (bug 466696)
+ # But first move directory with M4 macros out of the way.
+ # It is only needed by i autoconf and gives errors during elibtoolize.
+ mv autoconf/libtool autoconf/libtool1 || die
+ elibtoolize
}
src_configure() {