summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2010-11-30 09:15:04 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2010-11-30 09:15:04 +0000
commit7bfb3a24c051d0e80462e42d61e0b08fd67ab537 (patch)
tree25921a874b44e4d8f05809782dc6171ffb17f329 /app-backup
parentinitial ebuild of dnssec root key (diff)
downloadgentoo-2-7bfb3a24c051d0e80462e42d61e0b08fd67ab537.tar.gz
gentoo-2-7bfb3a24c051d0e80462e42d61e0b08fd67ab537.tar.bz2
gentoo-2-7bfb3a24c051d0e80462e42d61e0b08fd67ab537.zip
Bump to 0.6.11. Lots of bug fixes. Tarball is now hosted on launchpad.
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/duplicity/ChangeLog8
-rw-r--r--app-backup/duplicity/duplicity-0.6.11.ebuild30
2 files changed, 37 insertions, 1 deletions
diff --git a/app-backup/duplicity/ChangeLog b/app-backup/duplicity/ChangeLog
index 5b9fbf40397c..df0d689adaf9 100644
--- a/app-backup/duplicity/ChangeLog
+++ b/app-backup/duplicity/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-backup/duplicity
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/duplicity/ChangeLog,v 1.47 2010/08/07 16:05:50 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/duplicity/ChangeLog,v 1.48 2010/11/30 09:15:03 ford_prefect Exp $
+
+*duplicity-0.6.11 (30 Nov 2010)
+
+ 30 Nov 2010; Arun Raghavan <ford_prefect@gentoo.org>
+ +duplicity-0.6.11.ebuild:
+ Bump to 0.6.11. Lots of bug fixes. Tarball is now hosted on launchpad.
*duplicity-0.6.09 (07 Aug 2010)
diff --git a/app-backup/duplicity/duplicity-0.6.11.ebuild b/app-backup/duplicity/duplicity-0.6.11.ebuild
new file mode 100644
index 000000000000..b8041d2f40f6
--- /dev/null
+++ b/app-backup/duplicity/duplicity-0.6.11.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/duplicity/duplicity-0.6.11.ebuild,v 1.1 2010/11/30 09:15:04 ford_prefect Exp $
+
+EAPI="3"
+
+inherit distutils
+
+DESCRIPTION="duplicity is a secure backup system using gnupg to encrypt data"
+HOMEPAGE="http://www.nongnu.org/duplicity/"
+SRC_URI="http://code.launchpad.net/${PN}/0.6-series/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="s3"
+
+DEPEND=">=dev-lang/python-2.4
+ >=net-libs/librsync-0.9.6
+ >=net-ftp/ncftp-3.1.9
+ app-crypt/gnupg"
+RDEPEND="${DEPEND}
+ >=dev-python/py-gnupg-0.3.2
+ >=dev-python/pexpect-2.1
+ s3? ( dev-python/boto )"
+
+src_install() {
+ distutils_src_install
+ rm "${ED}"/usr/share/doc/${P}/COPYING
+}