summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-07-04 05:16:54 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-07-04 05:16:54 +0000
commit910db7ba3081101e3bcd9ebbff66f9526e270d72 (patch)
tree6c0718c175edc50cc1b2b9d435f0517713e84a19 /app-backup/flexbackup/flexbackup-1.2.0-r1.ebuild
parentInitial ebuild, closes bug 92405. (diff)
downloadgentoo-2-910db7ba3081101e3bcd9ebbff66f9526e270d72.tar.gz
gentoo-2-910db7ba3081101e3bcd9ebbff66f9526e270d72.tar.bz2
gentoo-2-910db7ba3081101e3bcd9ebbff66f9526e270d72.zip
Moved from app-arch/flexbackup to app-backup/flexbackup.
Diffstat (limited to 'app-backup/flexbackup/flexbackup-1.2.0-r1.ebuild')
-rw-r--r--app-backup/flexbackup/flexbackup-1.2.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-backup/flexbackup/flexbackup-1.2.0-r1.ebuild b/app-backup/flexbackup/flexbackup-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..56a81a679931
--- /dev/null
+++ b/app-backup/flexbackup/flexbackup-1.2.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/flexbackup/flexbackup-1.2.0-r1.ebuild,v 1.1 2005/07/04 05:16:54 robbat2 Exp $
+
+DESCRIPTION="Flexible backup script using perl"
+HOMEPAGE="http://flexbackup.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ sys-apps/findutils
+ app-arch/tar
+ app-arch/mt-st"
+
+src_compile() {
+ emake BINPATH="/usr/bin" || die "compile problem"
+}
+
+src_install() {
+ dodir /etc /usr/bin
+ einstall CONFFILE="${D}/etc/flexbackup.conf" BINPATH="${D}/usr/bin"
+
+ dosed "/^\$type = /s:'afio':'tar':" /etc/flexbackup.conf
+ dosed "/^\$buffer = /s:'buffer':'false':" /etc/flexbackup.conf
+
+ dodoc CHANGES CREDITS INSTALL README TODO
+ dohtml faq.html
+}
+
+pkg_postinst() {
+ einfo "Please edit your /etc/flexbackup.conf file to suit your"
+ einfo "needs. If you are using devfs, the tape device should"
+ einfo "be set to /dev/tapes/tape0/mtn. If you need to use any"
+ einfo "archiver other than tar, please emerge it separately."
+}