summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-07-12 17:04:57 +0000
committerRoy Marples <uberlord@gentoo.org>2007-07-12 17:04:57 +0000
commita56b6cb45c92889ea23060df910ca644b07a0a70 (patch)
tree0fe145d2fceab740c459b8f65cf64e74f06faffd /app-arch
parentFix typo. (diff)
downloadgentoo-2-a56b6cb45c92889ea23060df910ca644b07a0a70.tar.gz
gentoo-2-a56b6cb45c92889ea23060df910ca644b07a0a70.tar.bz2
gentoo-2-a56b6cb45c92889ea23060df910ca644b07a0a70.zip
Bumpage.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/bsdtar/ChangeLog7
-rw-r--r--app-arch/bsdtar/bsdtar-2.2.4.ebuild82
-rw-r--r--app-arch/bsdtar/files/digest-bsdtar-2.2.43
3 files changed, 91 insertions, 1 deletions
diff --git a/app-arch/bsdtar/ChangeLog b/app-arch/bsdtar/ChangeLog
index 1524fef3dd59..299aa81021d6 100644
--- a/app-arch/bsdtar/ChangeLog
+++ b/app-arch/bsdtar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/bsdtar
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdtar/ChangeLog,v 1.70 2007/06/23 22:39:22 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdtar/ChangeLog,v 1.71 2007/07/12 17:04:57 uberlord Exp $
+
+*bsdtar-2.2.4 (12 Jul 2007)
+
+ 12 Jul 2007; Roy Marples <uberlord@gentoo.org> +bsdtar-2.2.4.ebuild:
+ Bumpage.
23 Jun 2007; Diego Pettenò <flameeyes@gentoo.org>
-files/libarchive-1.2.53-strict-aliasing.patch,
diff --git a/app-arch/bsdtar/bsdtar-2.2.4.ebuild b/app-arch/bsdtar/bsdtar-2.2.4.ebuild
new file mode 100644
index 000000000000..0c4e22f28676
--- /dev/null
+++ b/app-arch/bsdtar/bsdtar-2.2.4.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdtar/bsdtar-2.2.4.ebuild,v 1.1 2007/07/12 17:04:57 uberlord Exp $
+
+inherit eutils autotools toolchain-funcs flag-o-matic
+
+MY_P="libarchive-${PV/_beta/b}"
+
+DESCRIPTION="BSD tar command"
+HOMEPAGE="http://people.freebsd.org/~kientzle/libarchive/"
+SRC_URI="http://people.freebsd.org/~kientzle/libarchive/src/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="build static acl xattr"
+
+RDEPEND="!dev-libs/libarchive
+ kernel_linux? (
+ acl? ( sys-apps/acl )
+ xattr? ( sys-apps/attr )
+ )
+ !static? ( !build? (
+ app-arch/bzip2
+ sys-libs/zlib ) )"
+DEPEND="${RDEPEND}
+ kernel_linux? ( sys-fs/e2fsprogs
+ virtual/os-headers )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/libarchive-2.1.9-static.patch
+ epatch "${FILESDIR}"/libarchive-2.1.5-acl.patch
+
+ eautoreconf
+ epunt_cxx
+}
+
+src_compile() {
+ local myconf
+
+ if use static || use build ; then
+ myconf="${myconf} --enable-static-bsdtar"
+ else
+ myconf="${myconf} --disable-static-bsdtar"
+ fi
+
+ # Upstream doesn't seem to care to fix the problems
+ # and I don't want to continue running after them.
+ append-flags -fno-strict-aliasing
+
+ econf \
+ --bindir=/bin \
+ $(use_enable acl) \
+ $(use_enable xattr) \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+
+ # Create tar symlink for FreeBSD
+ if [[ ${CHOST} == *-freebsd* ]]; then
+ dosym bsdtar /bin/tar
+ dosym bsdtar.1 /usr/share/man/man1/tar.1
+ fi
+
+ if use build; then
+ rm -rf "${D}"/usr
+ rm -rf "${D}"/lib/*.so*
+ return 0
+ fi
+
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)
+ gen_usr_ldscript libarchive.so
+}
diff --git a/app-arch/bsdtar/files/digest-bsdtar-2.2.4 b/app-arch/bsdtar/files/digest-bsdtar-2.2.4
new file mode 100644
index 000000000000..a6e24a9d8f40
--- /dev/null
+++ b/app-arch/bsdtar/files/digest-bsdtar-2.2.4
@@ -0,0 +1,3 @@
+MD5 1dd9d267af446921cf93deb27d1fbe9e libarchive-2.2.4.tar.gz 636879
+RMD160 2aa2e4124c1081acfdc666335b659457dccb4fd6 libarchive-2.2.4.tar.gz 636879
+SHA256 186d3aa24817f64b12cb0ff4c8b4a76df33921446b912ca015a05b66f8755df0 libarchive-2.2.4.tar.gz 636879