summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-06-07 13:01:03 +0000
committerJeroen Roovers <jer@gentoo.org>2014-06-07 13:01:03 +0000
commit6ec49f9c3cdba1ea2db337f72693b262cfb015a2 (patch)
treef43aad9c7bd46262b742f1d7c250f1e06779716f /app-arch
parentRESTRICT=test for compile failure/downloading. (diff)
downloadgentoo-2-6ec49f9c3cdba1ea2db337f72693b262cfb015a2.tar.gz
gentoo-2-6ec49f9c3cdba1ea2db337f72693b262cfb015a2.tar.bz2
gentoo-2-6ec49f9c3cdba1ea2db337f72693b262cfb015a2.zip
Version bump (bug #512648).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/dpkg/ChangeLog7
-rw-r--r--app-arch/dpkg/dpkg-1.17.10.ebuild90
2 files changed, 96 insertions, 1 deletions
diff --git a/app-arch/dpkg/ChangeLog b/app-arch/dpkg/ChangeLog
index aded6843b63f..5789b206fbae 100644
--- a/app-arch/dpkg/ChangeLog
+++ b/app-arch/dpkg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/dpkg
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.271 2014/05/25 23:52:36 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.272 2014/06/07 13:01:03 jer Exp $
+
+*dpkg-1.17.10 (07 Jun 2014)
+
+ 07 Jun 2014; Jeroen Roovers <jer@gentoo.org> +dpkg-1.17.10.ebuild:
+ Version bump (bug #512648).
25 May 2014; Jeroen Roovers <jer@gentoo.org> -dpkg-1.16.12-r1.ebuild,
-dpkg-1.17.4.ebuild, -dpkg-1.17.5.ebuild, -dpkg-1.17.6.ebuild,
diff --git a/app-arch/dpkg/dpkg-1.17.10.ebuild b/app-arch/dpkg/dpkg-1.17.10.ebuild
new file mode 100644
index 000000000000..6d3a41fec4ef
--- /dev/null
+++ b/app-arch/dpkg/dpkg-1.17.10.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.17.10.ebuild,v 1.1 2014/06/07 13:01:03 jer Exp $
+
+EAPI=5
+inherit eutils multilib autotools toolchain-funcs
+
+DESCRIPTION="Package maintenance system for Debian"
+HOMEPAGE="http://packages.qa.debian.org/dpkg"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
+IUSE="+bzip2 dselect +lzma nls test unicode +update-alternatives +zlib"
+REQUIRED_USE="dselect? ( nls )"
+
+RDEPEND="
+ >=dev-lang/perl-5.6.0
+ dev-perl/TimeDate
+ >=sys-libs/ncurses-5.2-r7
+ lzma? ( app-arch/xz-utils )
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+ bzip2? ( app-arch/bzip2 )
+"
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+ sys-devel/flex
+ virtual/pkgconfig
+ nls? (
+ app-text/po4a
+ >=sys-devel/gettext-0.18.2
+ )
+ test? (
+ dev-perl/DateTime-Format-DateParse
+ dev-perl/IO-String
+ dev-perl/Test-Pod
+ virtual/perl-Test-Harness
+ )
+"
+
+DOCS=( ChangeLog THANKS TODO )
+
+src_prepare() {
+ # do not expect Debian's gzip --rsyncable extension
+ epatch "${FILESDIR}"/${PN}-1.17.0-gzip-rsyncable.patch
+
+ epatch "${FILESDIR}"/${PN}-1.17.1-flags.patch
+
+ # Force the use of the running bash for get-version (this file is never
+ # installed, so no need to worry about hardcoding a temporary bash)
+ sed -i -e '1c\#!'"${BASH}" get-version || die
+
+ # test fails (bug #414095)
+ sed -i utils/Makefile.am \
+ -e '/^test_cases/d;/100_update_alternatives/d' || die
+
+ use nls && strip-linguas -i po
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ econf \
+ $(use_enable dselect) \
+ $(use_enable nls) \
+ $(use_enable unicode) \
+ $(use_enable update-alternatives) \
+ $(use_with bzip2 bz2) \
+ $(use_with zlib) \
+ $(use_with lzma liblzma) \
+ --disable-compiler-warnings \
+ --disable-silent-rules \
+ --disable-start-stop-daemon \
+ --localstatedir="${EPREFIX}"/var \
+ --without-selinux
+}
+
+src_compile() {
+ emake AR=$(tc-getAR)
+}
+
+src_install() {
+ default
+
+ keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
+ keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
+}