summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-12-17 23:17:14 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-12-17 23:17:14 +0000
commit503164b358297a34a75cafc5182b14c765c2be33 (patch)
tree7a40ecebac5ca3e26b83327e1b08bc4b11dd8474 /app-arch
parentVersion bump. Clean up old revisions. (diff)
downloadgentoo-2-503164b358297a34a75cafc5182b14c765c2be33.tar.gz
gentoo-2-503164b358297a34a75cafc5182b14c765c2be33.tar.bz2
gentoo-2-503164b358297a34a75cafc5182b14c765c2be33.zip
Version bump. Fix possible use of uninitialized memory. Translation updates.
(Portage version: 2.2_rc60/cvs/Linux x86_64)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/file-roller/ChangeLog9
-rw-r--r--app-arch/file-roller/file-roller-2.28.2.ebuild74
2 files changed, 82 insertions, 1 deletions
diff --git a/app-arch/file-roller/ChangeLog b/app-arch/file-roller/ChangeLog
index e5379a8390ee..025b3284a255 100644
--- a/app-arch/file-roller/ChangeLog
+++ b/app-arch/file-roller/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-arch/file-roller
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/file-roller/ChangeLog,v 1.265 2009/12/13 23:06:29 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/file-roller/ChangeLog,v 1.266 2009/12/17 23:17:14 eva Exp $
+
+*file-roller-2.28.2 (17 Dec 2009)
+
+ 17 Dec 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +file-roller-2.28.2.ebuild:
+ Version bump. Fix possible use of uninitialized memory. Translation
+ updates.
13 Dec 2009; Gilles Dartiguelongue <eva@gentoo.org>
file-roller-2.28.1.ebuild:
diff --git a/app-arch/file-roller/file-roller-2.28.2.ebuild b/app-arch/file-roller/file-roller-2.28.2.ebuild
new file mode 100644
index 000000000000..29f8dd7daad3
--- /dev/null
+++ b/app-arch/file-roller/file-roller-2.28.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/file-roller/file-roller-2.28.2.ebuild,v 1.1 2009/12/17 23:17:14 eva Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2
+
+DESCRIPTION="archive manager for GNOME"
+HOMEPAGE="http://fileroller.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="nautilus"
+
+RDEPEND=">=dev-libs/glib-2.16.0
+ >=x11-libs/gtk+-2.16
+ gnome-base/gconf
+ nautilus? ( gnome-base/nautilus )"
+DEPEND="${RDEPEND}
+ gnome-base/gnome-common
+ sys-devel/gettext
+ dev-util/intltool
+ dev-util/pkgconfig
+ app-text/gnome-doc-utils"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-dependency-tracking
+ --disable-scrollkeeper
+ --disable-run-in-place
+ --disable-static"
+
+ if ! use nautilus ; then
+ G2CONF="${G2CONF} --disable-nautilus-actions"
+ fi
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Use absolute path to GNU tar since star doesn't have the same
+ # options. On Gentoo, star is /usr/bin/tar, GNU tar is /bin/tar
+ epatch "${FILESDIR}"/${PN}-2.10.3-use_bin_tar.patch
+
+ # Fix intltoolize broken file, see upstream #577133 and #579464
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in \
+ || die "sed failed"
+}
+
+pkg_postinst() {
+ elog "${PN} is a frontend for several archiving utilities. If you want a"
+ elog "particular achive format support, see ${HOMEPAGE}"
+ elog "and install the relevant package."
+ elog
+ elog "for example:"
+ elog " 7-zip - app-arch/p7zip"
+ elog " ace - app-arch/unace"
+ elog " arj - app-arch/arj"
+ elog " lzma - app-arch/lzma"
+ elog " lzop - app-arch/lzop"
+ elog " cpio - app-arch/cpio"
+ elog " iso - app-cdr/cdrtools"
+ elog " jar,zip - app-arch/zip and app-arch/unzip"
+ elog " lha - app-arch/lha"
+ elog " rar - app-arch/unrar"
+ elog " rpm - app-arch/rpm"
+ elog " unstuff - app-arch/stuffit"
+ elog " zoo - app-arch/zoo"
+}