summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-07 10:52:16 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-07 10:52:16 +0000
commit978898d7abe56e4fe0b34c1df1a5f40cdab620c0 (patch)
treec8dfc773d969938551080457fe5d68bea2f4fee1 /app-arch/unzip
parentsmall but important fix to pkgname (diff)
downloadgentoo-2-978898d7abe56e4fe0b34c1df1a5f40cdab620c0.tar.gz
gentoo-2-978898d7abe56e4fe0b34c1df1a5f40cdab620c0.tar.bz2
gentoo-2-978898d7abe56e4fe0b34c1df1a5f40cdab620c0.zip
*** empty log message ***
Diffstat (limited to 'app-arch/unzip')
-rw-r--r--app-arch/unzip/files/digest1
-rw-r--r--app-arch/unzip/unzip-5.41-r1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-arch/unzip/files/digest b/app-arch/unzip/files/digest
new file mode 100644
index 000000000000..4b17b6c9dd99
--- /dev/null
+++ b/app-arch/unzip/files/digest
@@ -0,0 +1 @@
+MD5 d5fb7ca068da949765abb8c6bc71666e unzip541.tar.gz
diff --git a/app-arch/unzip/unzip-5.41-r1.ebuild b/app-arch/unzip/unzip-5.41-r1.ebuild
new file mode 100644
index 000000000000..8064a5d16f7a
--- /dev/null
+++ b/app-arch/unzip/unzip-5.41-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.41-r1.ebuild,v 1.1 2000/08/07 10:51:35 achim Exp $
+
+P=unzip-5.41
+A=unzip541.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="app-arch"
+DESCRIPTION="Unzipper for pkzip-compressed files"
+SRC_URI="ftp://ftp.freesoftware.com/pub/infozip/src/${A}"
+HOMEPAGE="ftp://ftp.info-zip.org/pub/infozip/UnZip.html"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ cp unix/Makefile unix/Makefile.orig
+ sed -e "s:-O3:${CFLAGS}:" unix/Makefile.orig > unix/Makefile
+ make -f unix/Makefile linux
+}
+
+src_install() {
+ cd ${S}
+ into /usr
+ dobin unzip funzip unzipsfx unix/zipgrep
+ dodoc BUGS COPYING History* LICENSE README ToDo WHERE
+}
+
+
+