summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2011-10-16 19:22:48 +0000
committerHanno Böck <hanno@gentoo.org>2011-10-16 19:22:48 +0000
commit918361de448d4b103176948a9967bf819f682ae4 (patch)
treea904aa876f78a7fc1cec843e629416f05870d720 /app-arch/unp
parentppc/ppc64 stable (diff)
downloadgentoo-2-918361de448d4b103176948a9967bf819f682ae4.tar.gz
gentoo-2-918361de448d4b103176948a9967bf819f682ae4.tar.bz2
gentoo-2-918361de448d4b103176948a9967bf819f682ae4.zip
unp version bump
(Portage version: 2.1.10.27/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/unp')
-rw-r--r--app-arch/unp/ChangeLog9
-rw-r--r--app-arch/unp/unp-2.0_pre7.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/app-arch/unp/ChangeLog b/app-arch/unp/ChangeLog
index b5cfd16c7455..84bf3caec801 100644
--- a/app-arch/unp/ChangeLog
+++ b/app-arch/unp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/unp
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unp/ChangeLog,v 1.28 2010/10/21 19:55:35 hanno Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unp/ChangeLog,v 1.29 2011/10/16 19:22:48 hanno Exp $
+
+*unp-2.0_pre7 (16 Oct 2011)
+
+ 16 Oct 2011; Hanno Boeck <hanno@gentoo.org> +unp-2.0_pre7.ebuild:
+ Version bump, port to bash-completion-r1, add ~arm keyword.
*unp-2.0_pre5 (21 Oct 2010)
diff --git a/app-arch/unp/unp-2.0_pre7.ebuild b/app-arch/unp/unp-2.0_pre7.ebuild
new file mode 100644
index 000000000000..81bbd89a3b15
--- /dev/null
+++ b/app-arch/unp/unp-2.0_pre7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unp/unp-2.0_pre7.ebuild,v 1.1 2011/10/16 19:22:48 hanno Exp $
+
+EAPI=2
+
+inherit eutils bash-completion-r1
+
+DESCRIPTION="Script for unpacking various file formats"
+HOMEPAGE="http://packages.qa.debian.org/u/unp.html"
+SRC_URI="mirror://debian/pool/main/u/unp/${PN}_${PV/_/~}.tar.bz2"
+S="${WORKDIR}/${PN}-${PV/_/~}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="nls"
+
+DEPEND="nls? ( sys-devel/gettext )"
+
+RDEPEND="${DEPEND}
+ dev-lang/perl"
+
+src_compile() {
+ if use nls; then
+ cd po
+ emake
+ fi
+}
+
+src_install() {
+ dobin unp || die "dobin failed"
+ dosym /usr/bin/unp /usr/bin/ucat
+ doman debian/unp.1 || die "doman failed"
+ dodoc debian/changelog debian/README.Debian
+ dobashcomp bash_completion.d/unp
+
+ if use nls; then
+ cd po
+ emake DESTDIR="${D}" install
+ fi
+}