summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2010-10-21 19:55:35 +0000
committerHanno Böck <hanno@gentoo.org>2010-10-21 19:55:35 +0000
commit900e8a20378f434fa323ad0f217840d89aa45229 (patch)
tree82bf1fb9b067e16ac6e1fc1b62192716a144084d /app-arch/unp
parentStable for HPPA (bug #340011). (diff)
downloadgentoo-2-900e8a20378f434fa323ad0f217840d89aa45229.tar.gz
gentoo-2-900e8a20378f434fa323ad0f217840d89aa45229.tar.bz2
gentoo-2-900e8a20378f434fa323ad0f217840d89aa45229.zip
unp version bump
(Portage version: 2.1.9.20/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/unp')
-rw-r--r--app-arch/unp/ChangeLog7
-rw-r--r--app-arch/unp/unp-2.0_pre5.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/app-arch/unp/ChangeLog b/app-arch/unp/ChangeLog
index 966f15a1e94a..b5cfd16c7455 100644
--- a/app-arch/unp/ChangeLog
+++ b/app-arch/unp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/unp
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unp/ChangeLog,v 1.27 2010/01/01 19:44:42 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unp/ChangeLog,v 1.28 2010/10/21 19:55:35 hanno Exp $
+
+*unp-2.0_pre5 (21 Oct 2010)
+
+ 21 Oct 2010; Hanno Boeck <hanno@gentoo.org> +unp-2.0_pre5.ebuild:
+ Version bump, nls and bash-completion support, no more patches needed.
01 Jan 2010; Christian Faulhammer <fauli@gentoo.org> unp-1.0.15-r2.ebuild:
Transfer Prefix keywords
diff --git a/app-arch/unp/unp-2.0_pre5.ebuild b/app-arch/unp/unp-2.0_pre5.ebuild
new file mode 100644
index 000000000000..4d6e2d71a63c
--- /dev/null
+++ b/app-arch/unp/unp-2.0_pre5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unp/unp-2.0_pre5.ebuild,v 1.1 2010/10/21 19:55:35 hanno Exp $
+
+EAPI=2
+
+inherit eutils bash-completion
+
+DESCRIPTION="Script for unpacking various file formats"
+HOMEPAGE="http://packages.qa.debian.org/u/unp.html"
+SRC_URI="mirror://debian/pool/main/u/unp/${PN}_${PV/_/~}.tar.gz"
+S="${WORKDIR}/${PN}-${PV/_/~}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="nls"
+
+DEPEND="nls? ( sys-devel/gettext )"
+
+RDEPEND="${DEPEND}
+ dev-lang/perl"
+
+src_compile() {
+ if use nls; then
+ cd po
+ emake
+ fi
+}
+
+src_install() {
+ dobin unp || die "dobin failed"
+ dosym /usr/bin/unp /usr/bin/ucat
+ doman debian/unp.1 || die "doman failed"
+ dodoc debian/changelog debian/README.Debian
+ dobashcompletion bash_completion.d/unp
+
+ if use nls; then
+ cd po
+ emake DESTDIR="${D}" install
+ fi
+}