summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephanie J. Lockwood-Childs <wormo@gentoo.org>2005-04-27 00:55:35 +0000
committerStephanie J. Lockwood-Childs <wormo@gentoo.org>2005-04-27 00:55:35 +0000
commitbe478057996154535beadd70fd4f40c09c723c29 (patch)
treebab576af4de71086b0c7755082a100fde1d1ab13 /app-arch/pdv
parentversion bump, fix bug #64831 (diff)
downloadgentoo-2-be478057996154535beadd70fd4f40c09c723c29.tar.gz
gentoo-2-be478057996154535beadd70fd4f40c09c723c29.tar.bz2
gentoo-2-be478057996154535beadd70fd4f40c09c723c29.zip
made some fixes until it works on ppc
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-arch/pdv')
-rw-r--r--app-arch/pdv/ChangeLog8
-rw-r--r--app-arch/pdv/Manifest6
-rw-r--r--app-arch/pdv/files/digest-pdv-1.5.1-r11
-rw-r--r--app-arch/pdv/files/pdv-1.5.1-early-free.patch21
-rw-r--r--app-arch/pdv/files/pdv-1.5.1-opt.patch24
-rw-r--r--app-arch/pdv/pdv-1.5.1-r1.ebuild43
6 files changed, 101 insertions, 2 deletions
diff --git a/app-arch/pdv/ChangeLog b/app-arch/pdv/ChangeLog
index 4d20db7b6cb3..884f0fd8c742 100644
--- a/app-arch/pdv/ChangeLog
+++ b/app-arch/pdv/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/pdv
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/pdv/ChangeLog,v 1.6 2005/01/01 11:53:56 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pdv/ChangeLog,v 1.7 2005/04/27 00:55:35 wormo Exp $
+
+ 26 Apr 2005; Stephanie Lockwood-Childs <wormo@gentoo.org>
+ +files/pdv-1.5.1-early-free.patch, +files/pdv-1.5.1-opt.patch:
+ Fixed a bug in command line parsing: end of args overlooked due to type
+ mismatch in the loop comparison
+ Fixed a bug in locating the pvm stub: re-use of a ptr after it was freed
01 Jun 2004; Aron Griffis <agriffis@gentoo.org> pdv-1.5.1.ebuild:
Fix use invocation
diff --git a/app-arch/pdv/Manifest b/app-arch/pdv/Manifest
index 2ed1f4d5ce85..11e3ec173366 100644
--- a/app-arch/pdv/Manifest
+++ b/app-arch/pdv/Manifest
@@ -1,3 +1,7 @@
-MD5 d25711a66c792b841a9f2bbe3dae99b3 ChangeLog 506
+MD5 4542911ae04960de0fba2482e6969473 ChangeLog 816
+MD5 c3b71d340fc883a488412c5fc0c1ad3f pdv-1.5.1-r1.ebuild 1005
MD5 f7f51579b36c961562c86d1b34eedf03 pdv-1.5.1.ebuild 806
MD5 090b9bbcdafe60f821e963d2884f13ee files/digest-pdv-1.5.1 60
+MD5 34c1a74136e9d702d3645eff4ad1cf1d files/pdv-1.5.1-opt.patch 696
+MD5 eafc2d8347b9e03e7a27bbbbbeee750f files/pdv-1.5.1-early-free.patch 512
+MD5 090b9bbcdafe60f821e963d2884f13ee files/digest-pdv-1.5.1-r1 60
diff --git a/app-arch/pdv/files/digest-pdv-1.5.1-r1 b/app-arch/pdv/files/digest-pdv-1.5.1-r1
new file mode 100644
index 000000000000..c879cb585b81
--- /dev/null
+++ b/app-arch/pdv/files/digest-pdv-1.5.1-r1
@@ -0,0 +1 @@
+MD5 4dbfa3dd2a766a2d253728b80bb94838 pdv-1.5.1.tar.gz 87858
diff --git a/app-arch/pdv/files/pdv-1.5.1-early-free.patch b/app-arch/pdv/files/pdv-1.5.1-early-free.patch
new file mode 100644
index 000000000000..6896d9437f47
--- /dev/null
+++ b/app-arch/pdv/files/pdv-1.5.1-early-free.patch
@@ -0,0 +1,21 @@
+diff -ur pdv-1.5.1-orig/mkpkgutils.c pdv-1.5.1/mkpkgutils.c
+--- pdv-1.5.1-orig/mkpkgutils.c 2005-04-26 15:01:30.525131384 -0700
++++ pdv-1.5.1/mkpkgutils.c 2005-04-26 15:55:19.004327944 -0700
+@@ -114,8 +114,6 @@
+ if(access(fn_tst, R_OK) == 0)
+ fn = strdup(fn_tst);
+
+- free(fn_tst);
+-
+ /* if we could not find it then try the search path
+ including the current directory as a last resort */
+
+@@ -144,6 +142,8 @@
+ free(path);
+ } /* if(fn == NULL) */
+
++ free(fn_tst);
++
+ return fn;
+ } /* findpdv */
+
diff --git a/app-arch/pdv/files/pdv-1.5.1-opt.patch b/app-arch/pdv/files/pdv-1.5.1-opt.patch
new file mode 100644
index 000000000000..df3ebb1b6699
--- /dev/null
+++ b/app-arch/pdv/files/pdv-1.5.1-opt.patch
@@ -0,0 +1,24 @@
+diff -ur pdv-1.5.1-orig/pdv.c pdv-1.5.1/pdv.c
+--- pdv-1.5.1-orig/pdv.c 2005-04-24 19:27:15.705946000 -0700
++++ pdv-1.5.1/pdv.c 2005-04-24 19:17:27.042436456 -0700
+@@ -79,7 +79,7 @@
+ int
+ main(int argc, char *argv[])
+ {
+- char opt;
++ int opt;
+ int retval = 0;
+ int showhelp = 0;
+ struct payload_st pld_data;
+diff -ur pdv-1.5.1-orig/pdvmkpkg.c pdv-1.5.1/pdvmkpkg.c
+--- pdv-1.5.1-orig/pdvmkpkg.c 2005-04-24 19:27:28.680973496 -0700
++++ pdv-1.5.1/pdvmkpkg.c 2005-04-24 19:21:49.992461976 -0700
+@@ -94,7 +94,7 @@
+ int promptusr = 0;
+ int nopts = 0;
+ int result;
+- char opt;
++ int opt;
+ struct stat payldstat;
+ struct payload_st pld_data;
+ struct pdvspec_st spec;
diff --git a/app-arch/pdv/pdv-1.5.1-r1.ebuild b/app-arch/pdv/pdv-1.5.1-r1.ebuild
new file mode 100644
index 000000000000..8b847ae355db
--- /dev/null
+++ b/app-arch/pdv/pdv-1.5.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pdv/pdv-1.5.1-r1.ebuild,v 1.3 2005/04/27 00:55:35 wormo Exp $
+
+inherit eutils
+
+DESCRIPTION="build a self-extracting and self-installing binary package"
+HOMEPAGE="http://pdv.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pdv/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="X"
+
+DEPEND="X? ( virtual/x11 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # fix a size-of-variable bug
+ epatch ${FILESDIR}/${P}-opt.patch
+ # fix a free-before-use bug
+ epatch ${FILESDIR}/${P}-early-free.patch
+}
+
+src_compile() {
+ local myconf=""
+ use X || myconf="--without-x" # configure script is broken, cant use use_with
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ dobin pdv pdvmkpkg || die
+ doman pdv.1 pdvmkpkg.1
+ if use X; then
+ dobin X11/xmpdvmkpkg || die
+ doman xmpdvmkpkg.1 || die
+ fi
+ dodoc AUTHORS ChangeLog INSTALL NEWS README pdv.lsm
+}