summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-09-07 03:37:04 +0000
committerMike Frysinger <vapier@gentoo.org>2007-09-07 03:37:04 +0000
commit2908c02623e536f4acfc3b033521160e1b4ad271 (patch)
treef7847b73cf57b18bd82d00d4b2e067a8535f12fe /app-arch/ncompress/ncompress-4.2.4.2.ebuild
parentversion bump from upstream (diff)
downloadgentoo-2-2908c02623e536f4acfc3b033521160e1b4ad271.tar.gz
gentoo-2-2908c02623e536f4acfc3b033521160e1b4ad271.tar.bz2
gentoo-2-2908c02623e536f4acfc3b033521160e1b4ad271.zip
Version bump.
(Portage version: 2.1.3.7)
Diffstat (limited to 'app-arch/ncompress/ncompress-4.2.4.2.ebuild')
-rw-r--r--app-arch/ncompress/ncompress-4.2.4.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-arch/ncompress/ncompress-4.2.4.2.ebuild b/app-arch/ncompress/ncompress-4.2.4.2.ebuild
new file mode 100644
index 000000000000..feece448d1e7
--- /dev/null
+++ b/app-arch/ncompress/ncompress-4.2.4.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/ncompress/ncompress-4.2.4.2.ebuild,v 1.1 2007/09/07 03:37:03 vapier Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Another uncompressor for compatibility"
+HOMEPAGE="http://ncompress.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ncompress/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed \
+ -e 's:options= :options= $(CFLAGS) -DNOFUNCDEF -DUTIME_H $(LDFLAGS) :' \
+ -e "s:CC=cc:CC=$(tc-getCC):" \
+ Makefile.def > Makefile
+}
+
+src_install() {
+ dobin compress || die
+ dosym compress /usr/bin/uncompress
+ doman compress.1
+ echo '.so compress.1' > "${D}"/usr/share/man/man1/uncompress.1
+ dodoc Acknowleds Changes LZW.INFO README
+}