summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Harring <ferringb@gentoo.org>2011-02-14 13:29:07 +0000
committerBrian Harring <ferringb@gentoo.org>2011-02-14 13:29:07 +0000
commitba0b83b4940e222227879769478fd1d8d7bee815 (patch)
tree0aca7d95bc176c6a6699228d5976d4dfbee6c276 /app-arch/libarchive
parentppc stable wrt #344827, #354237 (diff)
downloadgentoo-2-ba0b83b4940e222227879769478fd1d8d7bee815.tar.gz
gentoo-2-ba0b83b4940e222227879769478fd1d8d7bee815.tar.bz2
gentoo-2-ba0b83b4940e222227879769478fd1d8d7bee815.zip
revisit 352464; add IUSE=expat to enforce expat linkage, else libxml2 (match the configure's preference).
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/libarchive')
-rw-r--r--app-arch/libarchive/ChangeLog10
-rw-r--r--app-arch/libarchive/libarchive-2.8.3-r1.ebuild95
-rw-r--r--app-arch/libarchive/libarchive-2.8.4-r1.ebuild95
3 files changed, 199 insertions, 1 deletions
diff --git a/app-arch/libarchive/ChangeLog b/app-arch/libarchive/ChangeLog
index b8abfa1531d3..db536b810b3a 100644
--- a/app-arch/libarchive/ChangeLog
+++ b/app-arch/libarchive/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-arch/libarchive
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/ChangeLog,v 1.86 2011/02/14 00:41:04 ferringb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/ChangeLog,v 1.87 2011/02/14 13:29:07 ferringb Exp $
+
+*libarchive-2.8.4-r1 (14 Feb 2011)
+*libarchive-2.8.3-r1 (14 Feb 2011)
+
+ 14 Feb 2011; Brian Harring <ferringb@gentoo.org> +libarchive-2.8.3-r1.ebuild,
+ +libarchive-2.8.4-r1.ebuild:
+ revisit 352464; revbump (missed in the last round), add IUSE=expat to
+ enforce linkage via expat, else libxml2 is used.
14 Feb 2011; Brian Harring <ferringb@gentoo.org> libarchive-2.8.3.ebuild,
libarchive-2.8.4.ebuild:
diff --git a/app-arch/libarchive/libarchive-2.8.3-r1.ebuild b/app-arch/libarchive/libarchive-2.8.3-r1.ebuild
new file mode 100644
index 000000000000..c0b6384bca65
--- /dev/null
+++ b/app-arch/libarchive/libarchive-2.8.3-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/libarchive-2.8.3-r1.ebuild,v 1.1 2011/02/14 13:29:07 ferringb Exp $
+
+EAPI="2"
+
+inherit eutils libtool toolchain-funcs flag-o-matic
+
+DESCRIPTION="BSD tar command"
+HOMEPAGE="http://code.google.com/p/libarchive/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz
+ http://people.freebsd.org/~kientzle/libarchive/src/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="static static-libs acl xattr kernel_linux +bzip2 +lzma +zlib expat"
+
+COMPRESS_LIBS_DEPEND="lzma? ( app-arch/xz-utils )
+ bzip2? ( app-arch/bzip2 )
+ zlib? ( sys-libs/zlib )"
+
+RDEPEND="!dev-libs/libarchive
+ dev-libs/openssl
+ !expat? ( dev-libs/libxml2 )
+ expat? ( dev-libs/expat )
+ acl? ( virtual/acl )
+ xattr? ( kernel_linux? ( sys-apps/attr ) )
+ !static? ( ${COMPRESS_LIBS_DEPEND} )"
+DEPEND="${RDEPEND}
+ ${COMPRESS_LIBS_DEPEND}
+ kernel_linux? ( sys-fs/e2fsprogs
+ virtual/os-headers )"
+
+src_prepare() {
+ epatch "$FILESDIR"/libarchive-disable-lzma-size-test.patch
+ elibtoolize
+ epunt_cxx
+}
+
+src_configure() {
+ local myconf
+
+ if ! use static ; then
+ myconf="--enable-bsdtar=shared --enable-bsdcpio=shared"
+ fi
+
+ # force static libs for static binaries
+ if use static && ! use static-libs; then
+ myconf="${myconf} --enable-static"
+ fi
+
+ # Check for need of this in 2.7.1 and later, on 2.7.0, -Werror was
+ # added to the final release, but since it's done in the
+ # Makefile.am we can just work it around this way.
+ append-flags -Wno-error
+
+ # We disable lzmadec because we support the newer liblzma from xz-utils
+ # and not liblzmadec with this version.
+ econf --bindir=/bin \
+ --enable-bsdtar --enable-bsdcpio \
+ $(use_enable acl) $(use_enable xattr) \
+ $(use_with zlib) \
+ $(use_with bzip2 bz2lib) $(use_with lzma) \
+ $(use_enable static-libs static) \
+ $(use_with expat expat) \
+ $(use_with !expat xml2)
+ --without-lzmadec \
+ ${myconf} \
+ --disable-dependency-tracking
+}
+
+src_test() {
+ # Replace the default src_test so that it builds tests in parallel
+ emake check || die "tests failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+
+ # remove useless .a and .la files (only for non static compilation)
+ use static-libs || find "${D}" \( -name '*.a' -or -name '*.la' \) -delete
+
+ # Create tar symlink for FreeBSD
+ if [[ ${CHOST} == *-freebsd* ]]; then
+ dosym bsdtar /bin/tar
+ dosym bsdtar.1 /usr/share/man/man1/tar.1
+ # We may wish to switch to symlink bsdcpio to cpio too one day
+ fi
+
+ dodoc NEWS README
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)
+ gen_usr_ldscript libarchive.so
+}
diff --git a/app-arch/libarchive/libarchive-2.8.4-r1.ebuild b/app-arch/libarchive/libarchive-2.8.4-r1.ebuild
new file mode 100644
index 000000000000..b410182d35d4
--- /dev/null
+++ b/app-arch/libarchive/libarchive-2.8.4-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/libarchive-2.8.4-r1.ebuild,v 1.1 2011/02/14 13:29:07 ferringb Exp $
+
+EAPI="2"
+
+inherit eutils libtool toolchain-funcs flag-o-matic
+
+DESCRIPTION="BSD tar command"
+HOMEPAGE="http://code.google.com/p/libarchive/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz
+ http://people.freebsd.org/~kientzle/libarchive/src/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="static static-libs acl xattr kernel_linux +bzip2 +lzma +zlib expat"
+
+COMPRESS_LIBS_DEPEND="lzma? ( app-arch/xz-utils )
+ bzip2? ( app-arch/bzip2 )
+ zlib? ( sys-libs/zlib )"
+
+RDEPEND="!dev-libs/libarchive
+ dev-libs/openssl
+ !expat? ( dev-libs/libxml2 )
+ expat? ( dev-libs/expat )
+ acl? ( virtual/acl )
+ xattr? ( kernel_linux? ( sys-apps/attr ) )
+ !static? ( ${COMPRESS_LIBS_DEPEND} )"
+DEPEND="${RDEPEND}
+ ${COMPRESS_LIBS_DEPEND}
+ kernel_linux? ( sys-fs/e2fsprogs
+ virtual/os-headers )"
+
+src_prepare() {
+ epatch "$FILESDIR"/libarchive-disable-lzma-size-test.patch
+ elibtoolize
+ epunt_cxx
+}
+
+src_configure() {
+ local myconf
+
+ if ! use static ; then
+ myconf="--enable-bsdtar=shared --enable-bsdcpio=shared"
+ fi
+
+ # force static libs for static binaries
+ if use static && ! use static-libs; then
+ myconf="${myconf} --enable-static"
+ fi
+
+ # Check for need of this in 2.7.1 and later, on 2.7.0, -Werror was
+ # added to the final release, but since it's done in the
+ # Makefile.am we can just work it around this way.
+ append-flags -Wno-error
+
+ # We disable lzmadec because we support the newer liblzma from xz-utils
+ # and not liblzmadec with this version.
+ econf --bindir=/bin \
+ --enable-bsdtar --enable-bsdcpio \
+ $(use_enable acl) $(use_enable xattr) \
+ $(use_with zlib) \
+ $(use_with bzip2 bz2lib) $(use_with lzma) \
+ $(use_enable static-libs static) \
+ $(use_with expat expat) \
+ $(use_with !expat xml2) \
+ --without-lzmadec \
+ ${myconf} \
+ --disable-dependency-tracking
+}
+
+src_test() {
+ # Replace the default src_test so that it builds tests in parallel
+ emake check || die "tests failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+
+ # remove useless .a and .la files (only for non static compilation)
+ use static-libs || find "${D}" \( -name '*.a' -or -name '*.la' \) -delete
+
+ # Create tar symlink for FreeBSD
+ if [[ ${CHOST} == *-freebsd* ]]; then
+ dosym bsdtar /bin/tar
+ dosym bsdtar.1 /usr/share/man/man1/tar.1
+ # We may wish to switch to symlink bsdcpio to cpio too one day
+ fi
+
+ dodoc NEWS README
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)
+ gen_usr_ldscript libarchive.so
+}