summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-04-05 14:49:32 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-04-05 14:49:32 +0000
commit0f15663ce5b6c045302b83e7401b96d905ad6986 (patch)
tree1d5eeb7788750f6265a0414dd2a11697e053e0d2 /app-arch/libarchive
parentVersion bump for both stable and beta series. (diff)
downloadgentoo-2-0f15663ce5b6c045302b83e7401b96d905ad6986.tar.gz
gentoo-2-0f15663ce5b6c045302b83e7401b96d905ad6986.tar.bz2
gentoo-2-0f15663ce5b6c045302b83e7401b96d905ad6986.zip
Version bump for both stable and beta branches.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-arch/libarchive')
-rw-r--r--app-arch/libarchive/ChangeLog9
-rw-r--r--app-arch/libarchive/libarchive-2.4.17.ebuild72
-rw-r--r--app-arch/libarchive/libarchive-2.5.1_beta.ebuild75
3 files changed, 155 insertions, 1 deletions
diff --git a/app-arch/libarchive/ChangeLog b/app-arch/libarchive/ChangeLog
index 06f5c0ed96da..87a18160c4c7 100644
--- a/app-arch/libarchive/ChangeLog
+++ b/app-arch/libarchive/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-arch/libarchive
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/ChangeLog,v 1.23 2008/03/16 15:55:21 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/ChangeLog,v 1.24 2008/04/05 14:49:32 flameeyes Exp $
+
+*libarchive-2.5.1_beta (05 Apr 2008)
+*libarchive-2.4.17 (05 Apr 2008)
+
+ 05 Apr 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +libarchive-2.4.17.ebuild, +libarchive-2.5.1_beta.ebuild:
+ Version bump for both stable and beta branches.
16 Mar 2008; Raúl Porcel <armin76@gentoo.org>
libarchive-2.5.0_beta.ebuild:
diff --git a/app-arch/libarchive/libarchive-2.4.17.ebuild b/app-arch/libarchive/libarchive-2.4.17.ebuild
new file mode 100644
index 000000000000..15cf1c366e93
--- /dev/null
+++ b/app-arch/libarchive/libarchive-2.4.17.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/libarchive-2.4.17.ebuild,v 1.1 2008/04/05 14:49:32 flameeyes Exp $
+
+inherit eutils libtool toolchain-funcs
+
+DESCRIPTION="BSD tar command"
+HOMEPAGE="http://people.freebsd.org/~kientzle/libarchive"
+SRC_URI="http://people.freebsd.org/~kientzle/libarchive/src/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="build static acl xattr kernel_linux"
+
+RDEPEND="!dev-libs/libarchive
+ kernel_linux? (
+ acl? ( sys-apps/acl )
+ xattr? ( sys-apps/attr )
+ )
+ !static? ( !build? (
+ app-arch/bzip2
+ sys-libs/zlib ) )"
+DEPEND="${RDEPEND}
+ || ( app-arch/sharutils sys-freebsd/freebsd-ubin )
+ kernel_linux? ( sys-fs/e2fsprogs
+ virtual/os-headers )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ elibtoolize
+ epunt_cxx
+}
+
+src_compile() {
+ local myconf
+
+ if ! use static && ! use build ; then
+ myconf="--enable-bsdtar=shared --enable-bsdcpio=shared"
+ fi
+
+ econf --bindir=/bin --enable-bsdcpio \
+ $(use_enable acl) $(use_enable xattr) \
+ ${myconf} \
+ --disable-dependency-tracking || die "econf failed."
+
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed."
+
+ # Create tar symlink for FreeBSD
+ if [[ ${CHOST} == *-freebsd* ]]; then
+ dosym bsdtar /bin/tar
+ dosym bsdtar.1 /usr/share/man/man1/tar.1
+ # We may wish to switch to symlink bsdcpio to cpio too one day
+ fi
+
+ dodoc NEWS README
+
+ if use build; then
+ rm -rf "${D}"/usr
+ rm -rf "${D}"/lib/*.so*
+ return 0
+ fi
+
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)
+ gen_usr_ldscript libarchive.so
+}
diff --git a/app-arch/libarchive/libarchive-2.5.1_beta.ebuild b/app-arch/libarchive/libarchive-2.5.1_beta.ebuild
new file mode 100644
index 000000000000..4286a4c2aa7c
--- /dev/null
+++ b/app-arch/libarchive/libarchive-2.5.1_beta.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/libarchive-2.5.1_beta.ebuild,v 1.1 2008/04/05 14:49:32 flameeyes Exp $
+
+MY_P="${P/_beta/b}"
+
+inherit eutils libtool toolchain-funcs
+
+DESCRIPTION="BSD tar command"
+HOMEPAGE="http://people.freebsd.org/~kientzle/libarchive"
+SRC_URI="http://people.freebsd.org/~kientzle/libarchive/src/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="build static acl xattr kernel_linux"
+
+RDEPEND="!dev-libs/libarchive
+ kernel_linux? (
+ acl? ( sys-apps/acl )
+ xattr? ( sys-apps/attr )
+ )
+ !static? ( !build? (
+ app-arch/bzip2
+ sys-libs/zlib ) )"
+DEPEND="${RDEPEND}
+ kernel_linux? ( sys-fs/e2fsprogs
+ virtual/os-headers )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ elibtoolize
+ epunt_cxx
+}
+
+src_compile() {
+ local myconf
+
+ if ! use static && ! use build ; then
+ myconf="--enable-bsdtar=shared --enable-bsdcpio=shared"
+ fi
+
+ econf --bindir=/bin --enable-bsdcpio \
+ $(use_enable acl) $(use_enable xattr) \
+ ${myconf} \
+ --disable-dependency-tracking || die "econf failed."
+
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed."
+
+ # Create tar symlink for FreeBSD
+ if [[ ${CHOST} == *-freebsd* ]]; then
+ dosym bsdtar /bin/tar
+ dosym bsdtar.1 /usr/share/man/man1/tar.1
+ # We may wish to switch to symlink bsdcpio to cpio too one day
+ fi
+
+ dodoc NEWS README
+
+ if use build; then
+ rm -rf "${D}"/usr
+ rm -rf "${D}"/lib/*.so*
+ return 0
+ fi
+
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)
+ gen_usr_ldscript libarchive.so
+}