summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-07-06 22:12:00 +0000
committerMike Frysinger <vapier@gentoo.org>2007-07-06 22:12:00 +0000
commite9dc5ddf3d2b4de05ec886adefe5d972b280af28 (patch)
treedd2670bd7960848bcae098e449537af21893429b /app-arch/gzip
parentold (diff)
downloadgentoo-2-e9dc5ddf3d2b4de05ec886adefe5d972b280af28.tar.gz
gentoo-2-e9dc5ddf3d2b4de05ec886adefe5d972b280af28.tar.bz2
gentoo-2-e9dc5ddf3d2b4de05ec886adefe5d972b280af28.zip
Fix from upstream gnulib for futimens handling with newer glibc #180764.
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'app-arch/gzip')
-rw-r--r--app-arch/gzip/ChangeLog6
-rw-r--r--app-arch/gzip/files/gnulib-futimens-rename.patch39
-rw-r--r--app-arch/gzip/gzip-1.3.12.ebuild4
3 files changed, 47 insertions, 2 deletions
diff --git a/app-arch/gzip/ChangeLog b/app-arch/gzip/ChangeLog
index 1da06c891187..c9962fc03e27 100644
--- a/app-arch/gzip/ChangeLog
+++ b/app-arch/gzip/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/gzip
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/ChangeLog,v 1.92 2007/07/03 19:09:42 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/ChangeLog,v 1.93 2007/07/06 22:12:00 vapier Exp $
+
+ 06 Jul 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/gnulib-futimens-rename.patch, gzip-1.3.12.ebuild:
+ Fix from upstream gnulib for futimens handling with newer glibc #180764.
03 Jul 2007; Tom Gall <tgall@gentoo.org> gzip-1.3.12.ebuild:
stable on ppc64, bug #183829
diff --git a/app-arch/gzip/files/gnulib-futimens-rename.patch b/app-arch/gzip/files/gnulib-futimens-rename.patch
new file mode 100644
index 000000000000..dfb5023b4b3c
--- /dev/null
+++ b/app-arch/gzip/files/gnulib-futimens-rename.patch
@@ -0,0 +1,39 @@
+http://lists.gnu.org/archive/html/bug-gnulib/2007-05/msg00089.html
+
+2007-05-19 Jim Meyering <jim@meyering.net>
+
+ * lib/utimens.c (gl_futimens): Rename from futimens,
+ now that glibc-2.6 declares futimens.
+ * lib/utimens.h: Likewise.
+
+diff --git a/lib/utimens.c b/lib/utimens.c
+index 71bc510..7e3175a 100644
+--- a/lib/utimens.c
++++ b/lib/utimens.c
+@@ -75,8 +75,8 @@ struct utimbuf
+ Return 0 on success, -1 (setting errno) on failure. */
+
+ int
+-futimens (int fd ATTRIBUTE_UNUSED,
+- char const *file, struct timespec const timespec[2])
++gl_futimens (int fd ATTRIBUTE_UNUSED,
++ char const *file, struct timespec const timespec[2])
+ {
+ /* Some Linux-based NFS clients are buggy, and mishandle time stamps
+ of files in NFS file systems in some cases. We have no
+@@ -185,5 +185,5 @@ futimens (int fd ATTRIBUTE_UNUSED,
+ int
+ utimens (char const *file, struct timespec const timespec[2])
+ {
+- return futimens (-1, file, timespec);
++ return gl_futimens (-1, file, timespec);
+ }
+diff --git a/lib/utimens.h b/lib/utimens.h
+index 0097aaa..169521d 100644
+--- a/lib/utimens.h
++++ b/lib/utimens.h
+@@ -1,3 +1,3 @@
+ #include <time.h>
+-int futimens (int, char const *, struct timespec const [2]);
++int gl_futimens (int, char const *, struct timespec const [2]);
+ int utimens (char const *, struct timespec const [2]);
diff --git a/app-arch/gzip/gzip-1.3.12.ebuild b/app-arch/gzip/gzip-1.3.12.ebuild
index e20d6fe35f1c..b3013f16f090 100644
--- a/app-arch/gzip/gzip-1.3.12.ebuild
+++ b/app-arch/gzip/gzip-1.3.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/gzip-1.3.12.ebuild,v 1.10 2007/07/03 19:09:42 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/gzip-1.3.12.ebuild,v 1.11 2007/07/06 22:12:00 vapier Exp $
inherit eutils flag-o-matic
@@ -24,7 +24,9 @@ src_unpack() {
unpack ${A}
cd "${S}"
#epatch "${FILESDIR}"/${PN}-1.3.5-rsync.patch
+ epatch "${FILESDIR}"/gnulib-futimens-rename.patch
epatch "${FILESDIR}"/${PN}-1.3.8-install-symlinks.patch
+ sed -i 's:\<futimens\>:gl_futimens:' gzip.c
}
src_compile() {