summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-12-09 08:05:17 +0000
committerMike Frysinger <vapier@gentoo.org>2006-12-09 08:05:17 +0000
commit2136275a53b7b4522ad5be4a24cc431f467e8c01 (patch)
tree6daac6b1914a841a2065c8dac4efa13989809e96 /app-arch/gzip/gzip-1.3.8.ebuild
parentold (diff)
downloadgentoo-2-2136275a53b7b4522ad5be4a24cc431f467e8c01.tar.gz
gentoo-2-2136275a53b7b4522ad5be4a24cc431f467e8c01.tar.bz2
gentoo-2-2136275a53b7b4522ad5be4a24cc431f467e8c01.zip
Version bump.
(Portage version: 2.1.2_rc3)
Diffstat (limited to 'app-arch/gzip/gzip-1.3.8.ebuild')
-rw-r--r--app-arch/gzip/gzip-1.3.8.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-arch/gzip/gzip-1.3.8.ebuild b/app-arch/gzip/gzip-1.3.8.ebuild
new file mode 100644
index 000000000000..15d6d7f047a7
--- /dev/null
+++ b/app-arch/gzip/gzip-1.3.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/gzip-1.3.8.ebuild,v 1.1 2006/12/09 08:05:17 vapier Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Standard GNU compressor"
+HOMEPAGE="http://www.gnu.org/software/gzip/"
+SRC_URI="ftp://alpha.gnu.org/gnu/gzip/${P}.tar.gz
+ mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls static pic"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+PROVIDE="virtual/gzip"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ #epatch "${FILESDIR}"/${PN}-1.3.5-rsync.patch
+ epatch "${FILESDIR}"/${PN}-1.3.8-install-symlinks.patch
+}
+
+src_compile() {
+ use static && append-flags -static
+ # avoid text relocation in gzip
+ use pic && export DEFS="NO_ASM"
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc ChangeLog NEWS README THANKS TODO
+ docinto txt
+ dodoc algorithm.doc gzip.doc
+
+ # keep most things in /usr, just the fun stuff in /
+ dodir /bin
+ mv "${D}"/usr/bin/{gunzip,gzip,zcat} "${D}"/bin/ || die
+ dosym /bin/gunzip /usr/bin/gunzip || die
+}