summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-17 19:38:39 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-17 19:38:39 +0000
commit1fd77cfdc9f18e922ba49c246ebb0d60e62561c0 (patch)
tree9424ff35b0626617bb1bf348307b1aa61cf9e256 /app-arch/cpio
parentadd alpha.gnu.org to the gnu mirror list (diff)
downloadgentoo-2-1fd77cfdc9f18e922ba49c246ebb0d60e62561c0.tar.gz
gentoo-2-1fd77cfdc9f18e922ba49c246ebb0d60e62561c0.tar.bz2
gentoo-2-1fd77cfdc9f18e922ba49c246ebb0d60e62561c0.zip
Version bump. Also include large file support #68520.
Diffstat (limited to 'app-arch/cpio')
-rw-r--r--app-arch/cpio/ChangeLog9
-rw-r--r--app-arch/cpio/cpio-2.5.90.ebuild39
-rw-r--r--app-arch/cpio/files/2.5.90-gnulib.patch99
-rw-r--r--app-arch/cpio/files/2.5.90-makepath.patch17
-rw-r--r--app-arch/cpio/files/2.5.90-rili-big-files.patch77
-rw-r--r--app-arch/cpio/files/digest-cpio-2.5.901
6 files changed, 241 insertions, 1 deletions
diff --git a/app-arch/cpio/ChangeLog b/app-arch/cpio/ChangeLog
index 436b7d950612..c8b9be55f0d3 100644
--- a/app-arch/cpio/ChangeLog
+++ b/app-arch/cpio/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-arch/cpio
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/ChangeLog,v 1.5 2004/10/17 02:52:45 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/ChangeLog,v 1.6 2004/12/17 19:38:39 vapier Exp $
+
+*cpio-2.5.90 (17 Dec 2004)
+
+ 17 Dec 2004; Mike Frysinger <vapier@gentoo.org>
+ +files/2.5.90-gnulib.patch, +files/2.5.90-makepath.patch,
+ +files/2.5.90-rili-big-files.patch, +cpio-2.5.90.ebuild:
+ Version bump. Also include large file support #68520.
17 Oct 2004; Mamoru KOMACHI <usata@gentoo.org> cpio-2.5.ebuild:
Added to ~ppc-macos.
diff --git a/app-arch/cpio/cpio-2.5.90.ebuild b/app-arch/cpio/cpio-2.5.90.ebuild
new file mode 100644
index 000000000000..16f7b046eab0
--- /dev/null
+++ b/app-arch/cpio/cpio-2.5.90.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/cpio-2.5.90.ebuild,v 1.1 2004/12/17 19:38:39 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="A file archival tool which can also read and write tar files"
+HOMEPAGE="http://www.gnu.org/software/cpio/cpio.html"
+SRC_URI="mirror://gnu/cpio/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~ppc-macos ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-gnulib.patch
+ epatch ${FILESDIR}/${PV}-makepath.patch
+ epatch ${FILESDIR}/${PV}-rili-big-files.patch
+}
+
+src_compile() {
+ econf \
+ --bindir=/bin \
+ --with-rmt=/usr/sbin/rmt \
+ || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc ChangeLog NEWS README INSTALL
+ rm -f "${D}"/usr/share/man/man1/mt.1
+ rmdir "${D}"/usr/libexec
+}
diff --git a/app-arch/cpio/files/2.5.90-gnulib.patch b/app-arch/cpio/files/2.5.90-gnulib.patch
new file mode 100644
index 000000000000..44cce2704f35
--- /dev/null
+++ b/app-arch/cpio/files/2.5.90-gnulib.patch
@@ -0,0 +1,99 @@
+Index: argp.h
+===================================================================
+RCS file: /cvsroot/gnulib/gnulib/lib/argp.h,v
+retrieving revision 1.5
+retrieving revision 1.8
+diff -u -b -B -r1.5 -r1.8
+--- lib/argp.h 4 Oct 2003 12:28:07 -0000 1.5
++++ lib/argp.h 30 Sep 2004 16:41:57 -0000 1.8
+@@ -1,5 +1,5 @@
+ /* Hierarchial argument parsing, layered over getopt.
+- Copyright (C) 1995,1996,1997,1998,1999,2003 Free Software Foundation, Inc.
++ Copyright (C) 1995-1999,2003,2004 Free Software Foundation, Inc.
+ This file is part of the GNU C Library.
+ Written by Miles Bader <miles@gnu.ai.mit.edu>.
+
+@@ -34,6 +34,9 @@
+ #ifndef __THROW
+ # define __THROW
+ #endif
++#ifndef __NTH
++# define __NTH(fct) fct __THROW
++#endif
+
+ #ifndef __attribute__
+ /* This feature is available in gcc versions 2.5 and later. */
+@@ -48,6 +51,18 @@
+ # endif
+ #endif
+
++/* GCC 2.95 and later have "__restrict"; C99 compilers have
++ "restrict", and "configure" may have defined "restrict". */
++#ifndef __restrict
++# if ! (2 < __GNUC__ || (2 == __GNUC__ && 95 <= __GNUC_MINOR__))
++# if defined restrict || 199901L <= __STDC_VERSION__
++# define __restrict restrict
++# else
++# define __restrict
++# endif
++# endif
++#endif
++
+ #ifndef __error_t_defined
+ typedef int error_t;
+ # define __error_t_defined
+@@ -111,11 +126,12 @@
+ should be displayed in much the same manner as the options. If this flag
+ is set, then the option NAME field is displayed unmodified (e.g., no `--'
+ prefix is added) at the left-margin (where a *short* option would normally
+- be displayed), and the documentation string in the normal place. For
+- purposes of sorting, any leading whitespace and punctuation is ignored,
+- except that if the first non-whitespace character is not `-', this entry
+- is displayed after all options (and OPTION_DOC entries with a leading `-')
+- in the same group. */
++ be displayed), and the documentation string in the normal place. The NAME
++ field will be translated using gettext, unless OPTION_NO_TRANS is set (see
++ below). For purposes of sorting, any leading whitespace and punctuation is
++ ignored, except that if the first non-whitespace character is not `-', this
++ entry is displayed after all options (and OPTION_DOC entries with a leading
++ `-') in the same group. */
+ #define OPTION_DOC 0x8
+
+ /* This option shouldn't be included in `long' usage messages (but is still
+@@ -127,6 +143,11 @@
+ OPTION_NO_USAGE. */
+ #define OPTION_NO_USAGE 0x10
+
++/* Valid only in conjunction with OPTION_DOC. This option disables translation
++ of option name. */
++#define OPTION_NO_TRANS 0x20
++
++
+ struct argp; /* fwd declare this type */
+ struct argp_state; /* " */
+ struct argp_child; /* " */
+@@ -545,13 +566,13 @@
+ # endif
+
+ ARGP_EI void
+-__argp_usage (__const struct argp_state *__state) __THROW
++__NTH (__argp_usage (__const struct argp_state *__state))
+ {
+ __argp_state_help (__state, stderr, ARGP_HELP_STD_USAGE);
+ }
+
+ ARGP_EI int
+-__option_is_short (__const struct argp_option *__opt) __THROW
++__NTH (__option_is_short (__const struct argp_option *__opt))
+ {
+ if (__opt->flags & OPTION_DOC)
+ return 0;
+@@ -563,7 +584,7 @@
+ }
+
+ ARGP_EI int
+-__option_is_end (__const struct argp_option *__opt) __THROW
++__NTH (__option_is_end (__const struct argp_option *__opt))
+ {
+ return !__opt->key && !__opt->name && !__opt->doc && !__opt->group;
+ }
diff --git a/app-arch/cpio/files/2.5.90-makepath.patch b/app-arch/cpio/files/2.5.90-makepath.patch
new file mode 100644
index 000000000000..525264e4cbd3
--- /dev/null
+++ b/app-arch/cpio/files/2.5.90-makepath.patch
@@ -0,0 +1,17 @@
+Index: src/makepath.c
+===================================================================
+RCS file: /cvsroot/cpio/cpio/src/makepath.c,v
+retrieving revision 1.3
+retrieving revision 1.4
+diff -u -r1.3 -r1.4
+--- src/makepath.c 6 Sep 2004 14:04:53 -0000 1.3
++++ src/makepath.c 14 Oct 2004 09:41:17 -0000 1.4
+@@ -64,8 +64,6 @@
+ #include <strings.h>
+ #endif
+
+-void error ();
+-
+ /* Ensure that the directory ARGPATH exists.
+ Remove any trailing slashes from ARGPATH before calling this function.
+
diff --git a/app-arch/cpio/files/2.5.90-rili-big-files.patch b/app-arch/cpio/files/2.5.90-rili-big-files.patch
new file mode 100644
index 000000000000..d6d3a4c5128b
--- /dev/null
+++ b/app-arch/cpio/files/2.5.90-rili-big-files.patch
@@ -0,0 +1,77 @@
+? big-gigs.patch
+Index: src/extern.h
+===================================================================
+RCS file: /cvsroot/cpio/cpio/src/extern.h,v
+retrieving revision 1.3
+diff -u -r1.3 extern.h
+--- src/extern.h 8 Sep 2004 11:41:40 -0000 1.3
++++ src/extern.h 17 Dec 2004 19:34:41 -0000
+@@ -165,9 +165,9 @@
+ void tape_buffered_read P_((char *in_buf, int in_des, long num_bytes));
+ int tape_buffered_peek P_((char *peek_buf, int in_des, int num_bytes));
+ void tape_toss_input P_((int in_des, long num_bytes));
+-void copy_files_tape_to_disk P_((int in_des, int out_des, long num_bytes));
+-void copy_files_disk_to_tape P_((int in_des, int out_des, long num_bytes, char *filename));
+-void copy_files_disk_to_disk P_((int in_des, int out_des, long num_bytes, char *filename));
++void copy_files_tape_to_disk P_((int in_des, int out_des, off_t num_bytes));
++void copy_files_disk_to_tape P_((int in_des, int out_des, off_t num_bytes, char *filename));
++void copy_files_disk_to_disk P_((int in_des, int out_des, off_t num_bytes, char *filename));
+ void warn_if_file_changed P_((char *file_name, unsigned long old_file_size,
+ unsigned long old_file_mtime));
+ void create_all_directories P_((char *name));
+Index: src/util.c
+===================================================================
+RCS file: /cvsroot/cpio/cpio/src/util.c,v
+retrieving revision 1.6
+diff -u -r1.6 util.c
+--- src/util.c 8 Sep 2004 11:45:38 -0000 1.6
++++ src/util.c 17 Dec 2004 19:34:42 -0000
+@@ -428,10 +428,10 @@
+ NUM_BYTES is the number of bytes to copy. */
+
+ void
+-copy_files_tape_to_disk (int in_des, int out_des, long num_bytes)
++copy_files_tape_to_disk (int in_des, int out_des, off_t num_bytes)
+ {
+- long size;
+- long k;
++ off_t size;
++ off_t k;
+
+ while (num_bytes > 0)
+ {
+@@ -458,13 +458,13 @@
+ NUM_BYTES is the number of bytes to copy. */
+
+ void
+-copy_files_disk_to_tape (int in_des, int out_des, long num_bytes,
++copy_files_disk_to_tape (int in_des, int out_des, off_t num_bytes,
+ char *filename)
+ {
+- long size;
+- long k;
++ off_t size;
++ off_t k;
+ int rc;
+- long original_num_bytes;
++ off_t original_num_bytes;
+
+ original_num_bytes = num_bytes;
+
+@@ -505,12 +505,12 @@
+ NUM_BYTES is the number of bytes to copy. */
+
+ void
+-copy_files_disk_to_disk (int in_des, int out_des, long num_bytes,
++copy_files_disk_to_disk (int in_des, int out_des, off_t num_bytes,
+ char *filename)
+ {
+- long size;
+- long k;
+- long original_num_bytes;
++ off_t size;
++ off_t k;
++ off_t original_num_bytes;
+ int rc;
+
+ original_num_bytes = num_bytes;
diff --git a/app-arch/cpio/files/digest-cpio-2.5.90 b/app-arch/cpio/files/digest-cpio-2.5.90
new file mode 100644
index 000000000000..8d5afee0a3c4
--- /dev/null
+++ b/app-arch/cpio/files/digest-cpio-2.5.90
@@ -0,0 +1 @@
+MD5 26fac3e733171c5ab20928151f582fee cpio-2.5.90.tar.bz2 444639