summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-02-22 16:04:43 +0000
committerTim Harder <radhermit@gentoo.org>2011-02-22 16:04:43 +0000
commit10e23ecc2c203e8fca3abee3d8026d6121ee1524 (patch)
treeef4fd855d401dc2987007e0ae3d3db14bff2b0f0 /app-antivirus
parentversion bump, by Massimo Burcheri <massimo.burcheri@gmx.de>, bug #355183 (diff)
downloadgentoo-2-10e23ecc2c203e8fca3abee3d8026d6121ee1524.tar.gz
gentoo-2-10e23ecc2c203e8fca3abee3d8026d6121ee1524.tar.bz2
gentoo-2-10e23ecc2c203e8fca3abee3d8026d6121ee1524.zip
Revert back to EAPI 2 for stabilization.
(Portage version: 2.2.0_alpha24/cvs/Linux x86_64)
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/clamav/ChangeLog5
-rw-r--r--app-antivirus/clamav/clamav-0.97.ebuild16
2 files changed, 12 insertions, 9 deletions
diff --git a/app-antivirus/clamav/ChangeLog b/app-antivirus/clamav/ChangeLog
index 3d702ff5674c..83887661d9b2 100644
--- a/app-antivirus/clamav/ChangeLog
+++ b/app-antivirus/clamav/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-antivirus/clamav
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.376 2011/02/22 10:23:14 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.377 2011/02/22 16:04:43 radhermit Exp $
+
+ 22 Feb 2011; Tim Harder <radhermit@gentoo.org> clamav-0.97.ebuild:
+ Revert back to EAPI 2 for stabilization.
*clamav-0.97 (22 Feb 2011)
diff --git a/app-antivirus/clamav/clamav-0.97.ebuild b/app-antivirus/clamav/clamav-0.97.ebuild
index 1512fc6f648b..a1c772676975 100644
--- a/app-antivirus/clamav/clamav-0.97.ebuild
+++ b/app-antivirus/clamav/clamav-0.97.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.97.ebuild,v 1.1 2011/02/22 10:23:14 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.97.ebuild,v 1.2 2011/02/22 16:04:43 radhermit Exp $
-EAPI=4
+EAPI=2
inherit eutils flag-o-matic
@@ -52,8 +52,8 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${ED}" install
- rm -rf "${ED}"/var/lib/clamav
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rm -rf "${D}"/var/lib/clamav
dodoc AUTHORS BUGS ChangeLog FAQ INSTALL NEWS README UPGRADE
newinitd "${FILESDIR}"/clamd.rc clamd
newconfd "${FILESDIR}"/clamd.conf clamd
@@ -77,7 +77,7 @@ src_install() {
-e "s:^\#\(LogFile\) .*:\1 /var/log/clamav/clamd.log:" \
-e "s:^\#\(LogTime\).*:\1 yes:" \
-e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
- "${ED}"/etc/clamd.conf
+ "${D}"/etc/clamd.conf
sed -i -e "s:^\(Example\):\# \1:" \
-e "s:.*\(PidFile\) .*:\1 /var/run/clamav/freshclam.pid:" \
-e "s:.*\(DatabaseOwner\) .*:\1 clamav:" \
@@ -85,7 +85,7 @@ src_install() {
-e "s:^\#\(NotifyClamd\).*:\1 /etc/clamd.conf:" \
-e "s:^\#\(ScriptedUpdates\).*:\1 yes:" \
-e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
- "${ED}"/etc/freshclam.conf
+ "${D}"/etc/freshclam.conf
if use milter ; then
# MilterSocket one to include ' /' because there is a 2nd line for
@@ -98,8 +98,8 @@ src_install() {
-e "s+^\#\(MilterSocket\) /.*+\1 unix:/var/run/clamav/clamav-milter.sock+" \
-e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
-e "s:^\#\(LogFile\) .*:\1 /var/log/clamav/clamav-milter.log:" \
- "${ED}"/etc/clamav-milter.conf
- cat << EOF >> "${ED}"/etc/conf.d/clamd
+ "${D}"/etc/clamav-milter.conf
+ cat << EOF >> "${D}"/etc/conf.d/clamd
MILTER_NICELEVEL=19
START_MILTER=no
EOF