summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-12-05 20:03:52 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-12-05 20:03:52 +0000
commiteb3fa569b2b45a1573d6f786b46f62eaeccd7788 (patch)
tree3a77790c09e2e82e1c540ca1d7440979e6abe3ff /app-admin
parentVersion bump. (diff)
downloadgentoo-2-eb3fa569b2b45a1573d6f786b46f62eaeccd7788.tar.gz
gentoo-2-eb3fa569b2b45a1573d6f786b46f62eaeccd7788.tar.bz2
gentoo-2-eb3fa569b2b45a1573d6f786b46f62eaeccd7788.zip
Bug #249891 - Add support for just calling another binary with the identical syntax to the package manager. Infra-requested feature, commit acked by hawking@gentoo.org.
(Portage version: 2.2_rc16/cvs/Linux 2.6.28-rc5-00117-g7f0f598 x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/python-updater/ChangeLog11
-rw-r--r--app-admin/python-updater/files/python-updater-r133-custom-package-manager-command.patch51
-rw-r--r--app-admin/python-updater/python-updater-0.6-r1.ebuild31
3 files changed, 92 insertions, 1 deletions
diff --git a/app-admin/python-updater/ChangeLog b/app-admin/python-updater/ChangeLog
index bb3862f967bd..812a8b972a39 100644
--- a/app-admin/python-updater/ChangeLog
+++ b/app-admin/python-updater/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-admin/python-updater
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/python-updater/ChangeLog,v 1.32 2008/08/25 09:56:28 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/python-updater/ChangeLog,v 1.33 2008/12/05 20:03:52 robbat2 Exp $
+
+*python-updater-0.6-r1 (05 Dec 2008)
+
+ 05 Dec 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +files/python-updater-r133-custom-package-manager-command.patch,
+ +python-updater-0.6-r1.ebuild:
+ Bug #249891 - Add support for just calling another binary with the
+ identical syntax to the package manager. Infra-requested feature, commit
+ acked by hawking@gentoo.org.
*python-updater-0.6 (25 Aug 2008)
diff --git a/app-admin/python-updater/files/python-updater-r133-custom-package-manager-command.patch b/app-admin/python-updater/files/python-updater-r133-custom-package-manager-command.patch
new file mode 100644
index 000000000000..6569614f74a3
--- /dev/null
+++ b/app-admin/python-updater/files/python-updater-r133-custom-package-manager-command.patch
@@ -0,0 +1,51 @@
+------------------------------------------------------------------------
+r134 | robbat2 | 2008-12-05 11:58:43 -0800 (Fri, 05 Dec 2008) | 1 line
+
+Bug #249891 - Add support for just calling another binary with the identical
+syntax to the package manager. Infra-requested feature, commit acked by
+hawking@gentoo.org.
+------------------------------------------------------------------------
+Index: python-updater
+===================================================================
+--- python-updater (revision 133)
++++ python-updater (revision 134)
+@@ -39,6 +39,7 @@
+ SUPPORTED_PMS="portage pkgcore paludis"
+ PMS_COMMAND=( "emerge" "pmerge" "paludis" )
+ PMS_OPTIONS=( "-vD1" "-Do" "-i1" )
++CUSTOM_PMS_COMMAND=""
+
+ # Checks
+ CHECK_ECLASS=0
+@@ -86,6 +87,9 @@
+ -c CMD, --command CMD
+ Pipe found packages to command CMD instead of invoking package
+ manager. Only for debug and script use.
++ --package-manager-command CMD
++ Call CMD instead of the default command for the specified
++ package manager.
+ -eCHECK --enable-CHECK
+ Enable CHECK where CHECK can be one of:
+ * eclass (Disabled by default)
+@@ -220,6 +224,10 @@
+ PMS_INDEX=$((${PMS_INDEX} + 1))
+ done
+ ;;
++ --package-manager-command)
++ shift
++ CUSTOM_PMS_COMMAND="$1"
++ ;;
+ -c|--command)
+ shift
+ PIPE_COMMAND="$1"
+@@ -429,7 +437,9 @@
+
+ # (Pretend to) remerge packages
+ if [[ -n "${PKGS_TO_REMERGE}" ]]; then
+- cmd="${PMS_COMMAND[${PMS_INDEX}]} ${PMS_OPTIONS[${PMS_INDEX}]} ${PKGS_TO_REMERGE}"
++ pmscmd="${CUSTOM_PMS_COMMAND}"
++ [ -z "${pmscmd}" ] && pmscmd="${PMS_COMMAND[${PMS_INDEX}]}"
++ cmd="${pmscmd} ${PMS_OPTIONS[${PMS_INDEX}]} ${PKGS_TO_REMERGE}"
+ einfo ${cmd}
+ ${cmd}
+ else
diff --git a/app-admin/python-updater/python-updater-0.6-r1.ebuild b/app-admin/python-updater/python-updater-0.6-r1.ebuild
new file mode 100644
index 000000000000..7f5d9f9e3a42
--- /dev/null
+++ b/app-admin/python-updater/python-updater-0.6-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/python-updater/python-updater-0.6-r1.ebuild,v 1.1 2008/12/05 20:03:52 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Script used to remerge python packages when changing Python version."
+HOMEPAGE="http://www.gentoo.org/proj/en/Python"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!<dev-lang/python-2.3.6-r2
+ || ( >=sys-apps/portage-2.1.2 sys-apps/pkgcore sys-apps/paludis )"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-r133-custom-package-manager-command.patch
+}
+
+src_install()
+{
+ dosbin ${PN} || die "dosbin failed"
+ doman ${PN}.1 || die "doman failed"
+ dodoc AUTHORS ChangeLog || die "dodoc failed"
+}