summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2011-05-26 22:53:12 +0000
committerLance Albertson <ramereth@gentoo.org>2011-05-26 22:53:12 +0000
commite112670acddbf8a3968c8024693f8e0428986129 (patch)
tree652915d4ccc8bdec81b3009548deec2e87a54a8c /app-admin
parentRemoved .la files, bug #299018. Respect LDFLAGS, bug #311989. Added python US... (diff)
downloadgentoo-2-e112670acddbf8a3968c8024693f8e0428986129.tar.gz
gentoo-2-e112670acddbf8a3968c8024693f8e0428986129.tar.bz2
gentoo-2-e112670acddbf8a3968c8024693f8e0428986129.zip
Version bump
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/mcollective/ChangeLog9
-rw-r--r--app-admin/mcollective/mcollective-1.1.4.ebuild60
-rw-r--r--app-admin/mcollective/mcollective-1.2.0.ebuild60
3 files changed, 128 insertions, 1 deletions
diff --git a/app-admin/mcollective/ChangeLog b/app-admin/mcollective/ChangeLog
index 75c2cddfe697..10e300e7d64e 100644
--- a/app-admin/mcollective/ChangeLog
+++ b/app-admin/mcollective/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/mcollective
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/ChangeLog,v 1.3 2011/04/19 21:59:59 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/ChangeLog,v 1.4 2011/05/26 22:53:12 ramereth Exp $
+
+*mcollective-1.2.0 (26 May 2011)
+*mcollective-1.1.4 (26 May 2011)
+
+ 26 May 2011; Lance Albertson <ramereth@gentoo.org> +mcollective-1.1.4.ebuild,
+ +mcollective-1.2.0.ebuild:
+ Version bump
19 Apr 2011; Tim Harder <radhermit@gentoo.org> metadata.xml:
Use no-herd
diff --git a/app-admin/mcollective/mcollective-1.1.4.ebuild b/app-admin/mcollective/mcollective-1.1.4.ebuild
new file mode 100644
index 000000000000..b346e0f7b09e
--- /dev/null
+++ b/app-admin/mcollective/mcollective-1.1.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/mcollective-1.1.4.ebuild,v 1.1 2011/05/26 22:53:12 ramereth Exp $
+
+EAPI="4"
+
+USE_RUBY="ruby18 ree18"
+
+inherit ruby-ng
+
+DESCRIPTION="Framework to build server orchestration or parallel job execution
+systems"
+HOMEPAGE="http://marionette-collective.org/"
+SRC_URI="http://puppetlabs.com/downloads/mcollective/${P}.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc +client"
+
+DEPEND=""
+RDEPEND="dev-ruby/stomp"
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+each_ruby_install() {
+ doruby -r lib/*
+ insinto /usr/share/mcollective
+ doins -r plugins
+ use client && dosbin mc-* mco
+ newsbin mcollectived.rb mcollectived
+ if use doc ; then
+ dohtml -r doc/*
+ insinto /usr/share/doc/${P}/ext
+ doins -r ext/*
+ fi
+ newinitd "${FILESDIR}"/mcollectived.initd mcollectived
+ insinto /etc/mcollective
+ cd etc
+ for cfg in *.dist ; do
+ newins "${cfg}" "${cfg%%.dist}"
+ sed -i -e "s:^libdir.*:libdir = /usr/share/mcollective/plugins:" \
+ "${D}"/etc/mcollective/${cfg%%.dist}
+ done
+ insinto /etc/mcollective/plugin.d
+}
+
+pkg_postinst() {
+ einfo "Mcollective requires a stomp server installed and functioning before"
+ einfo "you can use it. The recommended server to use is ActiveMQ [1] but"
+ einfo "any other stomp compatible server should work."
+ einfo
+ einfo "It is recommended you read the \'getting started\' guide [2] if this"
+ einfo "is a new installation"
+ einfo
+ einfo "[1] http://activemq.apache.org/"
+ einfo "[2] http://code.google.com/p/mcollective/wiki/GettingStarted"
+}
diff --git a/app-admin/mcollective/mcollective-1.2.0.ebuild b/app-admin/mcollective/mcollective-1.2.0.ebuild
new file mode 100644
index 000000000000..6c3078c04327
--- /dev/null
+++ b/app-admin/mcollective/mcollective-1.2.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/mcollective-1.2.0.ebuild,v 1.1 2011/05/26 22:53:12 ramereth Exp $
+
+EAPI="4"
+
+USE_RUBY="ruby18 ree18"
+
+inherit ruby-ng
+
+DESCRIPTION="Framework to build server orchestration or parallel job execution
+systems"
+HOMEPAGE="http://marionette-collective.org/"
+SRC_URI="http://puppetlabs.com/downloads/mcollective/${P}.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc +client"
+
+DEPEND=""
+RDEPEND="dev-ruby/stomp"
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+each_ruby_install() {
+ doruby -r lib/*
+ insinto /usr/share/mcollective
+ doins -r plugins
+ use client && dosbin mc-* mco
+ newsbin mcollectived.rb mcollectived
+ if use doc ; then
+ dohtml -r doc/*
+ insinto /usr/share/doc/${P}/ext
+ doins -r ext/*
+ fi
+ newinitd "${FILESDIR}"/mcollectived.initd mcollectived
+ insinto /etc/mcollective
+ cd etc
+ for cfg in *.dist ; do
+ newins "${cfg}" "${cfg%%.dist}"
+ sed -i -e "s:^libdir.*:libdir = /usr/share/mcollective/plugins:" \
+ "${D}"/etc/mcollective/${cfg%%.dist}
+ done
+ insinto /etc/mcollective/plugin.d
+}
+
+pkg_postinst() {
+ einfo "Mcollective requires a stomp server installed and functioning before"
+ einfo "you can use it. The recommended server to use is ActiveMQ [1] but"
+ einfo "any other stomp compatible server should work."
+ einfo
+ einfo "It is recommended you read the \'getting started\' guide [2] if this"
+ einfo "is a new installation"
+ einfo
+ einfo "[1] http://activemq.apache.org/"
+ einfo "[2] http://code.google.com/p/mcollective/wiki/GettingStarted"
+}