summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-07-08 10:08:16 +0000
committerAli Polatel <hawking@gentoo.org>2007-07-08 10:08:16 +0000
commitc255531fcbcbb1614c5f9ae94754deea57681b53 (patch)
tree1c08514baf9d733495f200dc51338d6a0b842fcc /app-admin
parentAsk for a newer pygame to fix bug #164128 (diff)
downloadgentoo-2-c255531fcbcbb1614c5f9ae94754deea57681b53.tar.gz
gentoo-2-c255531fcbcbb1614c5f9ae94754deea57681b53.tar.bz2
gentoo-2-c255531fcbcbb1614c5f9ae94754deea57681b53.zip
Added support for g/fbsd
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/sshguard/ChangeLog5
-rw-r--r--app-admin/sshguard/sshguard-1.0.ebuild27
2 files changed, 22 insertions, 10 deletions
diff --git a/app-admin/sshguard/ChangeLog b/app-admin/sshguard/ChangeLog
index 84b6bbd296c5..b032e066e958 100644
--- a/app-admin/sshguard/ChangeLog
+++ b/app-admin/sshguard/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-admin/sshguard
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sshguard/ChangeLog,v 1.2 2007/06/22 08:58:33 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sshguard/ChangeLog,v 1.3 2007/07/08 10:08:16 hawking Exp $
+
+ 08 Jul 2007; Ali Polatel <hawking@gentoo.org> sshguard-1.0.ebuild:
+ Added support for g/fbsd (bug #182926 thanks to Pierre Guinoiseau)
22 Jun 2007; Ali Polatel <hawking@gentoo.org> sshguard-1.0.ebuild:
Added virtual/logger to RDEPEND
diff --git a/app-admin/sshguard/sshguard-1.0.ebuild b/app-admin/sshguard/sshguard-1.0.ebuild
index caf232acb663..7ac3e9da8193 100644
--- a/app-admin/sshguard/sshguard-1.0.ebuild
+++ b/app-admin/sshguard/sshguard-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sshguard/sshguard-1.0.ebuild,v 1.2 2007/06/22 08:58:33 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sshguard/sshguard-1.0.ebuild,v 1.3 2007/07/08 10:08:16 hawking Exp $
DESCRIPTION="protects hosts from brute force attacks against ssh"
HOMEPAGE="http://sshguard.sourceforge.net/"
@@ -8,20 +8,29 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
+KEYWORDS="~x86 ~x86-fbsd"
+IUSE="ipfilter kernel_FreeBSD kernel_linux"
-DEPEND=""
-RDEPEND="net-firewall/iptables
+DEPEND="kernel_linux? ( net-firewall/iptables )
+ kernel_FreeBSD? ( !ipfilter? ( sys-freebsd/freebsd-pf ) )"
+RDEPEND="${DEPEND}
virtual/logger"
src_compile() {
- econf --with-firewall=iptables
- emake CFLAGS="${CFLAGS}" || die "emake failed"
+ local myconf
+ if use kernel_linux; then
+ myconf="--with-firewall=iptables"
+ elif use kernel_FreeBSD; then
+ use ipfilter && myconf="--with-firewall=ipfw" \
+ || myconf="--with-firewall=pf"
+ fi
+
+ econf ${myconf}
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
- dodoc README Changes || die "dodoc failed"
- dodoc -r examples || die "dodoc failed"
+ dodoc README Changes || die "dodoc failed"
+ dodoc examples/* || die "dodoc failed"
}