summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2012-06-27 17:52:14 +0000
committerJim Ramsay <lack@gentoo.org>2012-06-27 17:52:14 +0000
commit97ee2f1bb269934882034c1d51ed73722b4ba75f (patch)
tree2a5a144347a889690db7b6a5cbecb76705c983af /app-admin
parentarm stable, bug #419473 (diff)
downloadgentoo-2-97ee2f1bb269934882034c1d51ed73722b4ba75f.tar.gz
gentoo-2-97ee2f1bb269934882034c1d51ed73722b4ba75f.tar.bz2
gentoo-2-97ee2f1bb269934882034c1d51ed73722b4ba75f.zip
Bug #416141: User-supplied patch to respect autofs and cifs (patches also sent upstream, expected to land in 2.3.6)
(Portage version: 2.1.11.2/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/gkrellm/ChangeLog10
-rw-r--r--app-admin/gkrellm/files/gkrellm-2.3.5-autofs.patch10
-rw-r--r--app-admin/gkrellm/files/gkrellm-2.3.5-cifs.patch24
-rw-r--r--app-admin/gkrellm/gkrellm-2.3.5-r1.ebuild119
4 files changed, 162 insertions, 1 deletions
diff --git a/app-admin/gkrellm/ChangeLog b/app-admin/gkrellm/ChangeLog
index ed7aaca068d4..c73316d28200 100644
--- a/app-admin/gkrellm/ChangeLog
+++ b/app-admin/gkrellm/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-admin/gkrellm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/gkrellm/ChangeLog,v 1.189 2012/05/31 02:30:55 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gkrellm/ChangeLog,v 1.190 2012/06/27 17:52:13 lack Exp $
+
+*gkrellm-2.3.5-r1 (27 Jun 2012)
+
+ 27 Jun 2012; Jim Ramsay <jim_ramsay@gentoo.org>
+ +files/gkrellm-2.3.5-autofs.patch, +files/gkrellm-2.3.5-cifs.patch,
+ +gkrellm-2.3.5-r1.ebuild, gkrellm-2.3.5.ebuild:
+ Bug #416141: User-supplied patch to respect autofs and cifs (patches also sent
+ upstream, expected to land in 2.3.6)
31 May 2012; Zac Medico <zmedico@gentoo.org> gkrellm-2.3.2-r1.ebuild,
gkrellm-2.3.2.ebuild, gkrellm-2.3.4.ebuild, gkrellm-2.3.5.ebuild:
diff --git a/app-admin/gkrellm/files/gkrellm-2.3.5-autofs.patch b/app-admin/gkrellm/files/gkrellm-2.3.5-autofs.patch
new file mode 100644
index 000000000000..cf36a9817110
--- /dev/null
+++ b/app-admin/gkrellm/files/gkrellm-2.3.5-autofs.patch
@@ -0,0 +1,10 @@
+--- gkrellm-2.3.5.old/src/sysdeps/linux.c 2010-10-06 03:27:33.000000000 +1100
++++ gkrellm-2.3.5/src/sysdeps/linux.c 2011-11-24 02:07:30.926450485 +1100
+@@ -1439,6 +1439,7 @@
+ || !strcmp(type, "usbdevfs")
+ || !strcmp(type, "usbfs")
+ || !strcmp(type, "sysfs")
++ || !strcmp(type, "autofs")
+ )
+ continue;
+ /* Strip trailing / from the directory.
diff --git a/app-admin/gkrellm/files/gkrellm-2.3.5-cifs.patch b/app-admin/gkrellm/files/gkrellm-2.3.5-cifs.patch
new file mode 100644
index 000000000000..fa35ef672798
--- /dev/null
+++ b/app-admin/gkrellm/files/gkrellm-2.3.5-cifs.patch
@@ -0,0 +1,24 @@
+--- gkrellm-2.3.5.old/server/monitor.c 2010-10-06 03:46:59.000000000 +1100
++++ gkrellm-2.3.5/server/monitor.c 2011-11-24 02:01:30.871402778 +1100
+@@ -1329,7 +1329,8 @@
+ static gchar *remote_fs_types[] =
+ {
+ "nfs",
+- "smbfs"
++ "smbfs",
++ "cifs"
+ };
+
+ void
+--- gkrellm-2.3.5.old/src/fs.c 2010-09-15 02:25:51.000000000 +1000
++++ gkrellm-2.3.5/src/fs.c 2011-11-24 02:00:17.347088370 +1100
+@@ -163,7 +163,8 @@
+ static gchar *remote_fs_types[] =
+ {
+ "nfs",
+- "smbfs"
++ "smbfs",
++ "cifs"
+ };
+
+
diff --git a/app-admin/gkrellm/gkrellm-2.3.5-r1.ebuild b/app-admin/gkrellm/gkrellm-2.3.5-r1.ebuild
new file mode 100644
index 000000000000..500ddfc64df5
--- /dev/null
+++ b/app-admin/gkrellm/gkrellm-2.3.5-r1.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gkrellm/gkrellm-2.3.5-r1.ebuild,v 1.1 2012/06/27 17:52:13 lack Exp $
+
+EAPI=4
+
+inherit eutils multilib toolchain-funcs user
+
+DESCRIPTION="Single process stack of various system monitors"
+HOMEPAGE="http://www.gkrellm.net/"
+SRC_URI="http://members.dslextreme.com/users/billw/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="hddtemp gnutls lm_sensors nls ssl ntlm X kernel_FreeBSD"
+
+RDEPEND="dev-libs/glib:2
+ hddtemp? ( app-admin/hddtemp )
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( ssl? ( dev-libs/openssl ) )
+ lm_sensors? ( sys-apps/lm_sensors )
+ nls? ( virtual/libintl )
+ ntlm? ( net-libs/libntlm )
+ X? ( x11-libs/gtk+:2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ enewgroup gkrellmd
+ enewuser gkrellmd -1 -1 -1 gkrellmd
+ TARGET=
+ use kernel_FreeBSD && TARGET="freebsd"
+}
+
+src_prepare() {
+ sed -e 's:-O2 ::' \
+ -e 's:override CC:CFLAGS:' \
+ -i */Makefile || die "sed Makefile(s) failed"
+
+ sed -e 's:#user\tnobody:user\tgkrellmd:' \
+ -e 's:#group\tproc:group\tgkrellmd:' \
+ -i server/gkrellmd.conf || die "sed gkrellmd.conf failed"
+
+ sed -e "s:/usr/lib:/usr/$(get_libdir):" \
+ -e "s:/usr/local/lib:/usr/local/$(get_libdir):" \
+ -i src/${PN}.h || die "sed ${PN}.h failed"
+
+ epatch "${FILESDIR}/${P}-autofs.patch"
+ epatch "${FILESDIR}/${P}-cifs.patch"
+}
+
+src_compile() {
+ if use X ; then
+ local sslopt=""
+ if use gnutls; then
+ sslopt="without-ssl=yes"
+ elif use ssl; then
+ sslopt="without-gnutls=yes"
+ else
+ sslopt="without-ssl=yes without-gnutls=yes"
+ fi
+
+ emake ${TARGET} \
+ CC="$(tc-getCC)" \
+ STRIP="" \
+ INSTALLROOT="/usr" \
+ INCLUDEDIR="/usr/include/gkrellm2" \
+ LOCALEDIR="/usr/share/locale" \
+ $(use nls || echo enable_nls=0) \
+ $(use lm_sensors || echo without-libsensors=yes) \
+ $(use ntlm || echo without-ntlm=yes) \
+ ${sslopt} \
+ || die "emake failed"
+ else
+ cd server
+ emake ${TARGET} \
+ CC="$(tc-getCC)" \
+ LINK_FLAGS="$LDFLAGS -Wl,-E" \
+ STRIP="" \
+ $(use nls || echo enable_nls=0) \
+ $(use lm_sensors || echo without-libsensors=yes) \
+ || die "emake failed"
+ fi
+}
+
+src_install() {
+ if use X ; then
+ emake install${TARGET:+_}${TARGET} \
+ $(use nls || echo enable_nls=0) \
+ STRIP="" \
+ INSTALLDIR="${D}/usr/bin" \
+ INCLUDEDIR="${D}/usr/include" \
+ LOCALEDIR="${D}/usr/share/locale" \
+ PKGCONFIGDIR="${D}/usr/$(get_libdir)/pkgconfig" \
+ MANDIR="${D}/usr/share/man/man1" \
+ || die "emake install failed"
+
+ dohtml *.html
+
+ newicon src/icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} GKrellM ${PN}
+ else
+ dobin server/gkrellmd || die "dobin failed"
+
+ insinto /usr/include/gkrellm2
+ doins server/gkrellmd.h || die "doins failed"
+ doins shared/log.h || die "doins failed"
+ fi
+
+ doinitd "${FILESDIR}"/gkrellmd || die "doinitd failed"
+ newconfd "${FILESDIR}"/gkrellmd.conf gkrellmd || die "newconfd failed"
+
+ insinto /etc
+ doins server/gkrellmd.conf || die "doins failed"
+
+ dodoc Changelog CREDITS README
+}