summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlec Warner <antarus@gentoo.org>2007-01-27 18:46:29 +0000
committerAlec Warner <antarus@gentoo.org>2007-01-27 18:46:29 +0000
commit94cac0f7222907365354b64068156e966ee85762 (patch)
tree721265c25859599851986a16f3426b7eeee086c4 /app-admin
parentMarked ppc stable for bug #161851. (diff)
downloadgentoo-2-94cac0f7222907365354b64068156e966ee85762.tar.gz
gentoo-2-94cac0f7222907365354b64068156e966ee85762.tar.bz2
gentoo-2-94cac0f7222907365354b64068156e966ee85762.zip
bump to version 1.320 for bug # 157198, thanks to ConiKost for reporting
(Portage version: 2.1.1-r2)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/webmin/ChangeLog7
-rw-r--r--app-admin/webmin/files/digest-webmin-1.3209
-rw-r--r--app-admin/webmin/webmin-1.320.ebuild135
3 files changed, 150 insertions, 1 deletions
diff --git a/app-admin/webmin/ChangeLog b/app-admin/webmin/ChangeLog
index da65db7306a6..44247cb83d99 100644
--- a/app-admin/webmin/ChangeLog
+++ b/app-admin/webmin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/webmin
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/ChangeLog,v 1.136 2007/01/24 15:09:51 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/ChangeLog,v 1.137 2007/01/27 18:46:29 antarus Exp $
+
+*webmin-1.320 (27 Jan 2007)
+
+ 27 Jan 2007; Alec Warner <antarus@gentoo.org> +webmin-1.320.ebuild:
+ bump to version 1.320 for bug # 157198, thanks to ConiKost for reporting
24 Jan 2007; Marius Mauch <genone@gentoo.org> webmin-1.290.ebuild,
webmin-1.290-r1.ebuild, webmin-1.300.ebuild, webmin-1.300-r1.ebuild:
diff --git a/app-admin/webmin/files/digest-webmin-1.320 b/app-admin/webmin/files/digest-webmin-1.320
new file mode 100644
index 000000000000..04a0a8e09b8e
--- /dev/null
+++ b/app-admin/webmin/files/digest-webmin-1.320
@@ -0,0 +1,9 @@
+MD5 f74d252d7fa9c736895fb3a257dd3edc virtual-server-3.23.gpl.wbm.gz 379417
+RMD160 912ba4ff66b7644f05e7e5b52286b5a41cf7163d virtual-server-3.23.gpl.wbm.gz 379417
+SHA256 c5631f73921058df40a08b0d248bad1acf1dd5b7ded451c7c6f9fff1d923a360 virtual-server-3.23.gpl.wbm.gz 379417
+MD5 5fe11a43e02e3a04bb6f5f0a4e756e41 webmin-1.320-minimal.tar.gz 1436590
+RMD160 dd9294f2b59caf028beda03940b16bd0a79635ff webmin-1.320-minimal.tar.gz 1436590
+SHA256 0aaec93f46255d9b114f2854f6a13ad499596d8d015e7806b0283a6674f476b5 webmin-1.320-minimal.tar.gz 1436590
+MD5 36dd2fa62a99ef91ef866b6b3ebfd980 webmin-1.320.tar.gz 10756996
+RMD160 7e1eae27c1656742630a24d99c1eb5e7f8adbe62 webmin-1.320.tar.gz 10756996
+SHA256 2a4ec408d1644a00276809cb9468f9459e04e77452b46cf341068daa2facf392 webmin-1.320.tar.gz 10756996
diff --git a/app-admin/webmin/webmin-1.320.ebuild b/app-admin/webmin/webmin-1.320.ebuild
new file mode 100644
index 000000000000..48557d8fb624
--- /dev/null
+++ b/app-admin/webmin/webmin-1.320.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/webmin-1.320.ebuild,v 1.1 2007/01/27 18:46:29 antarus Exp $
+
+inherit eutils pam
+
+VM_V="3.23"
+
+DESCRIPTION="Webmin, a web-based system administration interface"
+HOMEPAGE="http://www.webmin.com/"
+SRC_URI="webmin-minimal? ( mirror://sourceforge/webadmin/${P}-minimal.tar.gz )
+ !webmin-minimal? ( mirror://sourceforge/webadmin/${P}.tar.gz
+ http://www.webmin.com/download/virtualmin/virtual-server-${VM_V}.gpl.wbm.gz )"
+
+LICENSE="BSD"
+SLOT="0"
+# ~mips removed because of broken deps. Bug #86085
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="apache2 pam postgres ssl webmin-minimal"
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ ssl? ( dev-perl/Net-SSLeay )
+ postgres? ( dev-perl/DBD-Pg )
+ pam? ( dev-perl/Authen-PAM )
+ dev-perl/XML-Generator"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ # in webmin-minimal apache2 are not present
+ if ! use webmin-minimal ; then
+ # Bug #50810, #51943
+ if use apache2; then
+ epatch "${FILESDIR}"/${PN}-1.140-apache2.patch
+ fi
+
+ # Correct ldapness
+ epatch "${FILESDIR}"/${PN}-1.270-ldap-useradmin.patch
+
+ # Postfix should modify the last entry of the maps file
+ epatch "${FILESDIR}"/${PN}-1.300-postfix.patch
+
+ mv ${WORKDIR}/virtual-server-${VM_V}.gpl.wbm ${T}/vs.tar
+ tar -xf ${T}/vs.tar
+
+ # Don't create ${HOME}/cgi-bin on new accounts
+ epatch "${FILESDIR}"/virtual-server-3.23-nocgibin.patch
+
+ # Verify Postgres usernames
+ epatch "${FILESDIR}"/virtual-server-3.23-pgsql.patch
+ fi
+
+ epatch "${FILESDIR}"/${PN}-1.170-setup-nocheck.patch
+}
+
+src_install() {
+ # Bug #97212
+ addpredict /var/lib/rpm
+
+ rm -f mount/freebsd-mounts*
+ rm -f mount/openbsd-mounts*
+ rm -f mount/macos-mounts*
+
+ (find . -name '*.cgi' ; find . -name '*.pl') | perl perlpath.pl /usr/bin/perl -
+ dodir /usr/libexec/webmin
+ dodir /var
+
+ cp -rp * ${D}/usr/libexec/webmin
+
+ # in webmin-minimal openslp is not present
+ if [ ! -f "${D}/usr/libexec/webmin/openslp/config-gentoo-linux" ] ; then
+ cp ${D}/usr/libexec/webmin/openslp/config \
+ ${D}/usr/libexec/webmin/openslp/config-gentoo-linux
+ fi
+
+ newinitd "${FILESDIR}"/init.d.webmin webmin
+
+ newpamd "${FILESDIR}"/webmin-pam webmin
+ echo gentoo > ${D}/usr/libexec/webmin/install-type
+
+ # Fix ownership
+ chown -R root:0 ${D}
+
+ dodir /etc/webmin
+ dodir /var/log/webmin
+
+ config_dir=${D}/etc/webmin
+ var_dir=${D}/var/log/webmin
+ perl=${ROOT}/usr/bin/perl
+ autoos=1
+ port=10000
+ login=root
+ crypt="XXX"
+ host=`hostname`
+ use ssl && ssl=1 || ssl=0
+ atboot=0
+ nostart=1
+ nochown=1
+ autothird=1
+ nouninstall=1
+ noperlpath=1
+ tempdir="${T}"
+ export config_dir var_dir perl autoos port login crypt host ssl atboot nostart nochown autothird nouninstall noperlpath tempdir
+ ${D}/usr/libexec/webmin/setup.sh > ${T}/webmin-setup.out 2>&1 || die "Failed to create initial webmin configuration."
+
+ # Fixup the config files to use their real locations
+ sed -i -e "s:^pidfile=.*$:pidfile=${ROOT}/var/run/webmin.pid:" ${D}/etc/webmin/miniserv.conf
+ find ${D}/etc/webmin -type f | xargs sed -i -e "s:${D}:${ROOT}:g"
+
+ # Cleanup from the config script
+ rm -rf ${D}/var/log/webmin
+ keepdir /var/log/webmin/
+
+ # Get rid of this crap...
+ rm -rf ${D}/usr/libexec/webmin/acl/Authen-SolarisRBAC-0.1
+ rm -f ${D}/usr/libexec/webmin/acl/Authen-SolarisRBAC-0.1.tar.gz
+}
+
+pkg_postinst() {
+ local crypt=$(grep "^root:" ${ROOT}/etc/shadow | cut -f 2 -d :)
+ crypt=${crypt//\\/\\\\}
+ crypt=${crypt//\//\\\/}
+ sed -i -e "s/root:XXX/root:${crypt}/" /etc/webmin/miniserv.users
+
+ einfo "To make webmin start at boot time, run: 'rc-update add webmin default'."
+ use ssl && einfo "Point your web browser to https://localhost:10000 to use webmin."
+ use ssl || einfo "Point your web browser to http://localhost:10000 to use webmin."
+}
+
+pkg_prerm() {
+ "${ROOT}"/etc/init.d/webmin stop >& /dev/null
+}