summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2002-09-18 17:52:51 +0000
committerMichael Imhof <tantive@gentoo.org>2002-09-18 17:52:51 +0000
commit5449da79afbde37dc536d28f4a388134bf8c3613 (patch)
treeb67d115848f479f94416ab42e63126b6737b1830 /app-admin
parentMasked openmosixview-1.2 for testing. (diff)
downloadgentoo-2-5449da79afbde37dc536d28f4a388134bf8c3613.tar.gz
gentoo-2-5449da79afbde37dc536d28f4a388134bf8c3613.tar.bz2
gentoo-2-5449da79afbde37dc536d28f4a388134bf8c3613.zip
Initial release.
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/openmosixview/ChangeLog8
-rw-r--r--app-admin/openmosixview/files/digest-openmosixview-1.21
-rw-r--r--app-admin/openmosixview/openmosixview-1.2.ebuild89
3 files changed, 98 insertions, 0 deletions
diff --git a/app-admin/openmosixview/ChangeLog b/app-admin/openmosixview/ChangeLog
new file mode 100644
index 000000000000..69427d8b8824
--- /dev/null
+++ b/app-admin/openmosixview/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-admin/chkrootkit
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/openmosixview/ChangeLog,v 1.1 2002/09/18 17:52:51 tantive Exp $
+
+*openmosixview-1.2 (18 Sep 2002)
+
+ 18 Sep 2002; Michael Imhof <tantive@gentoo.org>:
+ Initial release. \ No newline at end of file
diff --git a/app-admin/openmosixview/files/digest-openmosixview-1.2 b/app-admin/openmosixview/files/digest-openmosixview-1.2
new file mode 100644
index 000000000000..0836d3a0650d
--- /dev/null
+++ b/app-admin/openmosixview/files/digest-openmosixview-1.2
@@ -0,0 +1 @@
+MD5 81261639c4ce7afe54d48d10ade6a1c2 openmosixview-1.2.tar.gz 2286379
diff --git a/app-admin/openmosixview/openmosixview-1.2.ebuild b/app-admin/openmosixview/openmosixview-1.2.ebuild
new file mode 100644
index 000000000000..46924f384c8d
--- /dev/null
+++ b/app-admin/openmosixview/openmosixview-1.2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/openmosixview/openmosixview-1.2.ebuild,v 1.1 2002/09/18 17:52:51 tantive Exp $
+
+
+S=${WORKDIR}/openmosixview
+DESCRIPTION="cluster-management GUI for OpenMosix"
+SRC_URI="www.openmosixview.com/download/openmosixview-${PV}.tar.gz"
+HOMEPAGE="http://www.openmosixview.com"
+
+DEPEND=">=x11-libs/qt-2.3.0
+ >=sys-apps/openmosix-user-0.2.4
+ >=sys-kernel/openmosix-sources-2.4.18"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+
+src_unpack() {
+ unpack ${A}
+ cat > configuration << EOF
+
+ # test which version of qt is installed
+ if [ -d /usr/qt/3 ]; then
+ QTDIR=/usr/qt/3; else
+ QTDIR=/usr/qt/2;
+ fi
+
+ CC=gcc
+EOF
+}
+
+src_compile() {
+ cd ${S}
+ ./configure || die
+ make || die
+
+ cd ${S}/openmosixcollector
+ ./configure || die
+ make || die
+
+ cd ${S}/openmosixanalyzer
+ ./configure || die
+ make || die
+
+ cd ${S}/openmosixhistory
+ ./configure || die
+ make || die
+
+ cd ${S}/openmosixprocs
+ ./configure || die
+ make || die
+}
+
+src_install () {
+ dodir /usr/sbin
+ dodir /usr/local/bin
+
+ make INSTALLBASEDIR=${D}usr INSTALLMANDIR=${D}usr/share/man DESTDIR=${D} INSTALLDIR=${D}usr install || die
+ cd ${S}/openmosixcollector
+ make INSTALLBASEDIR=${D}usr INSTALLMANDIR=${D}usr/share/man DESTDIR=${D} INSTALLDIR=${D}usr install || die
+ cd ${S}/openmosixanalyzer
+ make INSTALLBASEDIR=${D}usr INSTALLMANDIR=${D}usr/share/man DESTDIR=${D} INSTALLDIR=${D}usr install || die
+ cd ${S}/openmosixhistory
+ make INSTALLBASEDIR=${D}usr INSTALLMANDIR=${D}usr/share/man DESTDIR=${D} INSTALLDIR=${D}usr install || die
+ cd ${S}/openmosixprocs
+ make INSTALLBASEDIR=${D}usr INSTALLMANDIR=${D}usr/share/man DESTDIR=${D} INSTALLDIR=${D}usr install || die
+
+ dodoc COPYING README
+
+ exeinto /etc/init.d
+ newexe ${S}/openmosixcollector/openmosixcollector.init openmosixcollector
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Openmosixview will allow you to monitor all nodes in your cluster."
+ einfo
+ einfo "You will need ssh to all cluster-nodes without password."
+ einfo
+ einfo "To setup your other nodes you will have to copy the openmosixprocs binary to them:"
+ einfo "scp /usr/local/bin/openmosixprocs your_node:/usr/local/bin/openmosixprocs"
+ einfo
+ einfo "Start openmosixcollector manually (/etc/init.d/openmosixcollector start) or"
+ einfo "automatically using rc-update (rc-update add /etc/init.d/openmosixcollector default)."
+ einfo
+ einfo "Start openmosixview by simply typing openmosixview"
+ einfo
+}