summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-05-26 18:14:10 +0000
committerChristian Heim <phreak@gentoo.org>2007-05-26 18:14:10 +0000
commit53eb634288742fc14c12206e6f747c49e1911c73 (patch)
treee0ed668956ca077e49fd58079a715c3a10c3aea2 /app-admin
parentFix the Manifest/digest. (diff)
downloadgentoo-2-53eb634288742fc14c12206e6f747c49e1911c73.tar.gz
gentoo-2-53eb634288742fc14c12206e6f747c49e1911c73.tar.bz2
gentoo-2-53eb634288742fc14c12206e6f747c49e1911c73.zip
Revision bump, including all those tools and scripts from support/ (excluding suexec, which is being packaged w/ net-www/apache.
(Portage version: 2.1.2.7)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/apache-tools/ChangeLog11
-rw-r--r--app-admin/apache-tools/apache-tools-2.2.4-r1.ebuild43
-rw-r--r--app-admin/apache-tools/apache-tools-2.2.4-r2.ebuild91
-rw-r--r--app-admin/apache-tools/apache-tools-2.2.4.ebuild38
-rw-r--r--app-admin/apache-tools/files/apache-tools-Makefile.patch39
-rw-r--r--app-admin/apache-tools/files/apache-tools-ab-ssl.patch11
-rw-r--r--app-admin/apache-tools/files/digest-apache-tools-2.2.4-r13
-rw-r--r--app-admin/apache-tools/files/digest-apache-tools-2.2.4-r2 (renamed from app-admin/apache-tools/files/digest-apache-tools-2.2.4)0
8 files changed, 151 insertions, 85 deletions
diff --git a/app-admin/apache-tools/ChangeLog b/app-admin/apache-tools/ChangeLog
index 22d409ba33a8..2f809b071a60 100644
--- a/app-admin/apache-tools/ChangeLog
+++ b/app-admin/apache-tools/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-admin/apache-tools
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/ChangeLog,v 1.3 2007/05/09 12:54:18 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/ChangeLog,v 1.4 2007/05/26 18:14:10 phreak Exp $
+
+*apache-tools-2.2.4-r2 (26 May 2007)
+
+ 26 May 2007; Christian Heim <phreak@gentoo.org>
+ +files/apache-tools-Makefile.patch, +files/apache-tools-ab-ssl.patch,
+ -apache-tools-2.2.4.ebuild, -apache-tools-2.2.4-r1.ebuild,
+ +apache-tools-2.2.4-r2.ebuild:
+ Revision bump, including all those tools and scripts from support/
+ (excluding suexec, which is being packaged w/ net-www/apache.
*apache-tools-2.2.4-r1 (09 May 2007)
diff --git a/app-admin/apache-tools/apache-tools-2.2.4-r1.ebuild b/app-admin/apache-tools/apache-tools-2.2.4-r1.ebuild
deleted file mode 100644
index d6f3b643367a..000000000000
--- a/app-admin/apache-tools/apache-tools-2.2.4-r1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/apache-tools-2.2.4-r1.ebuild,v 1.1 2007/05/09 12:54:18 kloeri Exp $
-
-DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
-HOMEPAGE="http://httpd.apache.org/"
-SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE=""
-RESTRICT="test"
-
-RDEPEND="=dev-libs/apr-1*
- =dev-libs/apr-util-1*
- dev-libs/libpcre
- !<net-www/apache-2.2.4"
-
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/httpd-${PV}"
-
-src_compile() {
- cd "${S}"
- econf \
- --with-pcre=/usr || die "econf failed!"
-
- cd support
- emake htpasswd htdigest ab htdbm
-}
-
-src_install () {
- cd "${S}"
- dosbin support/{htdigest,htpasswd,ab,htdbm}
- dodoc CHANGES INSTALL
- doman docs/man/{htdigest.1,htpasswd.1,ab.8,htdbm.1}
-
- # provide symlinks for all the stuff we no longer rename, bug 177697
- for i in ab htdigest htpasswd; do
- dosym /usr/sbin/${i} /usr/sbin/${i}2
- done
-}
diff --git a/app-admin/apache-tools/apache-tools-2.2.4-r2.ebuild b/app-admin/apache-tools/apache-tools-2.2.4-r2.ebuild
new file mode 100644
index 000000000000..c6e1c07df251
--- /dev/null
+++ b/app-admin/apache-tools/apache-tools-2.2.4-r2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/apache-tools-2.2.4-r2.ebuild,v 1.1 2007/05/26 18:14:10 phreak Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
+HOMEPAGE="http://httpd.apache.org/"
+SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl"
+RESTRICT="test"
+
+RDEPEND="=dev-libs/apr-1*
+ =dev-libs/apr-util-1*
+ dev-libs/libpcre
+ ssl? ( dev-libs/openssl )
+ !<net-www/apache-2.2.4"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/httpd-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Apply these patches:
+ # (1) apache-tools-Makefile.patch:
+ # - fix up the `make install' for support/
+ # - remove envvars from `make install'
+ # (2) apache-tools-ab-ssl.patch:
+ # - Add support for SSL-capable version of ab
+ epatch "${FILESDIR}"/${PN}-Makefile.patch
+ use ssl && epatch "${FILESDIR}"/${PN}-ab-ssl.patch
+}
+
+src_compile() {
+ local myconf=""
+ cd "${S}"
+
+ # Instead of filtering --as-needed (bug #128505), append --no-as-needed
+ # Thanks to Harald van Dijk
+ append-ldflags -Wl,--no-as-needed
+
+ use ssl && myconf="${myconf} --with-ssl=/usr"
+
+ # econf overwrites the stuff from config.layout, so we have to put them into
+ # our myconf line too
+
+ econf \
+ --sbindir=/usr/sbin \
+ --with-perl=/usr/bin/perl \
+ --with-expat=/usr \
+ --with-z=/usr \
+ --with-apr=/usr \
+ --with-apr-util=/usr \
+ --with-pcre=/usr \
+ ${myconf} || die "econf failed!"
+
+ cd support
+ emake || die "emake support/ failed!"
+}
+
+src_install () {
+ cd "${S}"/support
+
+ make DESTDIR="${D}" install || die "make install failed!"
+
+ # install manpages
+ doman "${S}"/docs/man/{dbmmanage,htdigest,htpasswd,htdbm}.1 \
+ "${S}"/docs/man/{ab,apxs,htcacheclean,logresolve,rotatelogs}.8
+
+ # Providing compatiblity symlinks for #177697 (which we'll stop to install
+ # at some point).
+
+ for i in $(ls "${D}"/usr/sbin 2>/dev/null); do
+ dosym /usr/sbin/${i} /usr/sbin/${i}2
+ done
+
+ # Provide a symlink for ab-ssl
+ if use ssl ; then
+ dosym /usr/sbin/ab /usr/sbin/ab-ssl
+ dosym /usr/sbin/ab /usr/sbin/ab2-ssl
+ fi
+
+ dodoc "${S}"/CHANGES
+}
diff --git a/app-admin/apache-tools/apache-tools-2.2.4.ebuild b/app-admin/apache-tools/apache-tools-2.2.4.ebuild
deleted file mode 100644
index 1ad5011cb40c..000000000000
--- a/app-admin/apache-tools/apache-tools-2.2.4.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/apache-tools-2.2.4.ebuild,v 1.2 2007/05/07 20:27:21 kloeri Exp $
-
-DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
-HOMEPAGE="http://httpd.apache.org/"
-SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE=""
-RESTRICT="test"
-
-RDEPEND="=dev-libs/apr-1*
- =dev-libs/apr-util-1*
- dev-libs/libpcre
- !<net-www/apache-2.2.4"
-
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/httpd-${PV}"
-
-src_compile() {
- cd "${S}"
- econf \
- --with-pcre=/usr || die "econf failed!"
-
- cd support
- emake htpasswd htdigest ab htdbm
-}
-
-src_install () {
- cd "${S}"
- dosbin support/{htdigest,htpasswd,ab,htdbm}
- dodoc CHANGES INSTALL
- doman docs/man/{htdigest.1,htpasswd.1,ab.8,htdbm.1}
-}
diff --git a/app-admin/apache-tools/files/apache-tools-Makefile.patch b/app-admin/apache-tools/files/apache-tools-Makefile.patch
new file mode 100644
index 000000000000..8181a16b7059
--- /dev/null
+++ b/app-admin/apache-tools/files/apache-tools-Makefile.patch
@@ -0,0 +1,39 @@
+--- a/support/Makefile.in
++++ b/support/Makefile.in
+@@ -1,9 +1,10 @@
+ DISTCLEAN_TARGETS = apxs apachectl dbmmanage log_server_status \
+- logresolve.pl phf_abuse_log.cgi split-logfile envvars-std
++ logresolve.pl phf_abuse_log.cgi split-logfile
+
+ CLEAN_TARGETS = suexec
+
+-PROGRAMS = htpasswd htdigest rotatelogs logresolve ab checkgid htdbm htcacheclean httxt2dbm
++PROGRAMS = htpasswd htdigest rotatelogs logresolve ab checkgid htdbm \
++ htcacheclean httxt2dbm log_server_status split-logfile
+ TARGETS = $(PROGRAMS)
+
+ PROGRAM_LDADD = $(UTIL_LDFLAGS) $(PROGRAM_DEPENDENCIES) $(EXTRA_LIBS) $(AP_LIBS)
+@@ -12,22 +13,13 @@ PROGRAM_DEPENDENCIES =
+ include $(top_builddir)/build/rules.mk
+
+ install:
+- @test -d $(DESTDIR)$(bindir) || $(MKINSTALLDIRS) $(DESTDIR)$(bindir)
+ @test -d $(DESTDIR)$(sbindir) || $(MKINSTALLDIRS) $(DESTDIR)$(sbindir)
+- @test -d $(DESTDIR)$(libexecdir) || $(MKINSTALLDIRS) $(DESTDIR)$(libexecdir)
+- @cp -p $(top_builddir)/server/httpd.exp $(DESTDIR)$(libexecdir)
+- @for i in apxs apachectl dbmmanage; do \
++ @for i in $(PROGRAMS) ; do \
+ if test -f "$(builddir)/$$i"; then \
+ cp -p $$i $(DESTDIR)$(sbindir); \
+ chmod 755 $(DESTDIR)$(sbindir)/$$i; \
+ fi ; \
+ done
+- @if test -f "$(builddir)/envvars-std"; then \
+- cp -p envvars-std $(DESTDIR)$(sbindir); \
+- if test ! -f $(DESTDIR)$(sbindir)/envvars; then \
+- cp -p envvars-std $(DESTDIR)$(sbindir)/envvars ; \
+- fi ; \
+- fi
+
+ htpasswd_OBJECTS = htpasswd.lo
+ htpasswd: $(htpasswd_OBJECTS)
diff --git a/app-admin/apache-tools/files/apache-tools-ab-ssl.patch b/app-admin/apache-tools/files/apache-tools-ab-ssl.patch
new file mode 100644
index 000000000000..e99ebe869350
--- /dev/null
+++ b/app-admin/apache-tools/files/apache-tools-ab-ssl.patch
@@ -0,0 +1,11 @@
+--- a/support/Makefile.in
++++ b/support/Makefile.in
+@@ -43,7 +43,7 @@ htdbm: $(htdbm_OBJECTS)
+ $(LINK) $(htdbm_LTFLAGS) $(htdbm_OBJECTS) $(PROGRAM_LDADD)
+
+ ab_OBJECTS = ab.lo
+-ab_LDADD = $(PROGRAM_LDADD) $(SSL_LIBS)
++ab_LDADD = $(PROGRAM_LDADD) $(SSL_LIBS) -DUSE_SSL -lssl -I/usr/include/openssl
+ ab: $(ab_OBJECTS)
+ $(LINK) $(ab_LTFLAGS) $(ab_OBJECTS) $(ab_LDADD)
+
diff --git a/app-admin/apache-tools/files/digest-apache-tools-2.2.4-r1 b/app-admin/apache-tools/files/digest-apache-tools-2.2.4-r1
deleted file mode 100644
index 1e007f41e88e..000000000000
--- a/app-admin/apache-tools/files/digest-apache-tools-2.2.4-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 536c86c7041515a25dd8bad3611da9a3 httpd-2.2.4.tar.bz2 4930375
-RMD160 bb6e8a7447fa8e8f629010f30b548068de518523 httpd-2.2.4.tar.bz2 4930375
-SHA256 08ab82eae6418e265d361730e7eadc7d6966dffdb66ee07bd4d9af3f2b28dfc8 httpd-2.2.4.tar.bz2 4930375
diff --git a/app-admin/apache-tools/files/digest-apache-tools-2.2.4 b/app-admin/apache-tools/files/digest-apache-tools-2.2.4-r2
index 1e007f41e88e..1e007f41e88e 100644
--- a/app-admin/apache-tools/files/digest-apache-tools-2.2.4
+++ b/app-admin/apache-tools/files/digest-apache-tools-2.2.4-r2