summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2012-10-29 23:56:50 +0000
committerNaohiro Aota <naota@gentoo.org>2012-10-29 23:56:50 +0000
commit51e65260552dd9e12436c5814de200a1f1406994 (patch)
tree96e248aa77e47b29a70c9826e1b35e06d305400a /app-admin
parentUpdates from the 1.1.x to ready for the 1.2.x series unmask. (diff)
downloadgentoo-2-51e65260552dd9e12436c5814de200a1f1406994.tar.gz
gentoo-2-51e65260552dd9e12436c5814de200a1f1406994.tar.bz2
gentoo-2-51e65260552dd9e12436c5814de200a1f1406994.zip
Add patch to allow build on FreeBSD-9.x. #439200
(Portage version: 2.2.0_alpha137/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/logrotate/ChangeLog6
-rw-r--r--app-admin/logrotate/files/logrotate-3.8.2-fbsd.patch59
-rw-r--r--app-admin/logrotate/logrotate-3.8.2.ebuild6
3 files changed, 67 insertions, 4 deletions
diff --git a/app-admin/logrotate/ChangeLog b/app-admin/logrotate/ChangeLog
index f97be997c3b4..7da96c65bd73 100644
--- a/app-admin/logrotate/ChangeLog
+++ b/app-admin/logrotate/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/logrotate
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/ChangeLog,v 1.125 2012/09/29 16:07:59 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/ChangeLog,v 1.126 2012/10/29 23:56:50 naota Exp $
+
+ 29 Oct 2012; <naota@gentoo.org> +files/logrotate-3.8.2-fbsd.patch,
+ logrotate-3.8.2.ebuild:
+ Add patch to allow build on FreeBSD-9.x. #439200
29 Sep 2012; Raúl Porcel <armin76@gentoo.org> logrotate-3.8.2.ebuild:
alpha/ia64/s390/sh/sparc stable wrt #434348
diff --git a/app-admin/logrotate/files/logrotate-3.8.2-fbsd.patch b/app-admin/logrotate/files/logrotate-3.8.2-fbsd.patch
new file mode 100644
index 000000000000..3dc9a9c447d8
--- /dev/null
+++ b/app-admin/logrotate/files/logrotate-3.8.2-fbsd.patch
@@ -0,0 +1,59 @@
+Fix compilation on Gentoo/FreeBSD, no alloca.h here and PATH_MAX
+is defined elsewhere.
+
+See bug 254795
+
+--- logrotate-3.8.2.orig/config.c
++++ logrotate-3.8.2/config.c
+@@ -1,6 +1,6 @@
+ #include <sys/queue.h>
+ /* Alloca is defined in stdlib.h in NetBSD */
+-#ifndef __NetBSD__
++#if !defined(__NetBSD__) && !defined(__FreeBSD__)
+ #include <alloca.h>
+ #endif
+ #include <limits.h>
+@@ -21,6 +21,9 @@
+ #include <wctype.h>
+ #include <fnmatch.h>
+
++#if !defined(PATH_MAX) && defined(__FreeBSD__)
++#include <sys/param.h>
++#endif
+ #include "basenames.h"
+ #include "log.h"
+ #include "logrotate.h"
+--- logrotate-3.8.2.orig/logrotate.c
++++ logrotate-3.8.2/logrotate.c
+@@ -1,6 +1,6 @@
+ #include <sys/queue.h>
+ /* alloca() is defined in stdlib.h in NetBSD */
+-#ifndef __NetBSD__
++#if !defined(__NetBSD__) && !defined(__FreeBSD__)
+ #include <alloca.h>
+ #endif
+ #include <limits.h>
+@@ -24,6 +24,9 @@
+ int selinux_enforce = 0;
+ #endif
+
++#if !defined(PATH_MAX) && defined(__FreeBSD__)
++#include <sys/param.h>
++#endif
+ #include "basenames.h"
+ #include "log.h"
+ #include "logrotate.h"
+
+--- logrotate-3.8.2.orig/Makefile
++++ logrotate-3.8.2/Makefile
+@@ -17,8 +17,10 @@
+
+ ifeq ($(WITH_ACL),yes)
+ CFLAGS += -DWITH_ACL
++ifneq ($(OS_NAME),FreeBSD)
+ LOADLIBES += -lacl
+ endif
++endif
+
+ # HP-UX using GCC
+ ifeq ($(OS_NAME),HP-UX)
diff --git a/app-admin/logrotate/logrotate-3.8.2.ebuild b/app-admin/logrotate/logrotate-3.8.2.ebuild
index 80d6aa4f5cfb..e0b8617b22f2 100644
--- a/app-admin/logrotate/logrotate-3.8.2.ebuild
+++ b/app-admin/logrotate/logrotate-3.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/logrotate-3.8.2.ebuild,v 1.8 2012/09/29 16:07:59 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/logrotate-3.8.2.ebuild,v 1.9 2012/10/29 23:56:50 naota Exp $
EAPI="2"
@@ -12,7 +12,7 @@ SRC_URI="https://fedorahosted.org/releases/l/o/logrotate/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
IUSE="acl selinux"
RDEPEND="
@@ -30,7 +30,7 @@ src_prepare() {
epatch \
"${FILESDIR}"/${PN}-3.7.7-datehack.patch \
"${FILESDIR}"/${PN}-3.8.0-ignore-hidden.patch \
- "${FILESDIR}"/${PN}-3.8.0-fbsd.patch \
+ "${FILESDIR}"/${PN}-3.8.2-fbsd.patch \
"${FILESDIR}"/${PN}-3.8.1-noasprintf.patch \
"${FILESDIR}"/${PN}-3.8.2-atomic-create.patch
}