summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-12-28 06:33:54 +0000
committerMike Gilbert <floppym@gentoo.org>2014-12-28 06:33:54 +0000
commit315e55654482f41fdfd281a19f29ecdc2fcabe98 (patch)
tree4db2229d0a3585fe85c5b5213a0098bb59980f15 /app-admin/webapp-config
parentRemoves webapp-config-1.52-r1 from the tree (diff)
downloadgentoo-2-315e55654482f41fdfd281a19f29ecdc2fcabe98.tar.gz
gentoo-2-315e55654482f41fdfd281a19f29ecdc2fcabe98.tar.bz2
gentoo-2-315e55654482f41fdfd281a19f29ecdc2fcabe98.zip
Restore stable ebuild.
(Portage version: 2.2.15/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'app-admin/webapp-config')
-rw-r--r--app-admin/webapp-config/ChangeLog7
-rw-r--r--app-admin/webapp-config/webapp-config-1.52-r1.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/app-admin/webapp-config/ChangeLog b/app-admin/webapp-config/ChangeLog
index 2dbe49785c52..c88094f57b1d 100644
--- a/app-admin/webapp-config/ChangeLog
+++ b/app-admin/webapp-config/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/webapp-config
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/ChangeLog,v 1.118 2014/12/28 02:14:16 twitch153 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/ChangeLog,v 1.119 2014/12/28 06:33:54 floppym Exp $
+
+*webapp-config-1.52-r1 (28 Dec 2014)
+
+ 28 Dec 2014; Mike Gilbert <floppym@gentoo.org> +webapp-config-1.52-r1.ebuild:
+ Restore stable ebuild.
28 Dec 2014; Devan Franchini <twitch153@gentoo.org>
-webapp-config-1.52-r1.ebuild:
diff --git a/app-admin/webapp-config/webapp-config-1.52-r1.ebuild b/app-admin/webapp-config/webapp-config-1.52-r1.ebuild
new file mode 100644
index 000000000000..a45dd8743529
--- /dev/null
+++ b/app-admin/webapp-config/webapp-config-1.52-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-1.52-r1.ebuild,v 1.12 2014/12/28 06:33:54 floppym Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+SRC_URI="http://dev.gentoo.org/~twitch153/${PN}/${P}.tar.bz2"
+KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd"
+
+DESCRIPTION="Gentoo's installer for web-based applications"
+HOMEPAGE="http://sourceforge.net/projects/webapp-config/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+portage"
+
+DEPEND="app-text/xmlto
+ !dev-python/configparser"
+RDEPEND="portage? ( sys-apps/portage[${PYTHON_USEDEP}] )"
+
+python_prepare() {
+ epatch "${FILESDIR}/${P}-nulls-doctest.patch"
+}
+
+python_compile_all() {
+ emake -C doc/
+}
+
+python_install() {
+ # According to this discussion:
+ # http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
+ # distutils does not provide for specifying two different script install
+ # locations. Since we only install one script here the following should
+ # be ok
+ distutils-r1_python_install --install-scripts="/usr/sbin"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /etc/vhosts
+ doins config/webapp-config
+
+ keepdir /usr/share/webapps
+ keepdir /var/db/webapps
+
+ dodoc AUTHORS
+ doman doc/*.[58]
+ dohtml doc/*.[58].html
+}
+
+python_test() {
+ PYTHONPATH="." "${PYTHON}" WebappConfig/tests/dtest.py \
+ || die "Testing failed with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ elog "Now that you have upgraded webapp-config, you **must** update your"
+ elog "config files in /etc/vhosts/webapp-config before you emerge any"
+ elog "packages that use webapp-config."
+}