summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2007-09-09 21:11:41 +0000
committerBenedikt Boehm <hollow@gentoo.org>2007-09-09 21:11:41 +0000
commitb65b96cdcab478c794ad524cf640d579992d2ac3 (patch)
treee5385fffe7454ab6f64bfd45d96dfd98809be27b /app-admin/webapp-config/webapp-config-1.50.16-r2.ebuild
parentImport from sunrise for bug #156545 (diff)
downloadgentoo-2-b65b96cdcab478c794ad524cf640d579992d2ac3.tar.gz
gentoo-2-b65b96cdcab478c794ad524cf640d579992d2ac3.tar.bz2
gentoo-2-b65b96cdcab478c794ad524cf640d579992d2ac3.zip
fix functions.sh usage for baselayout-2
(Portage version: 2.1.3.7)
Diffstat (limited to 'app-admin/webapp-config/webapp-config-1.50.16-r2.ebuild')
-rw-r--r--app-admin/webapp-config/webapp-config-1.50.16-r2.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/app-admin/webapp-config/webapp-config-1.50.16-r2.ebuild b/app-admin/webapp-config/webapp-config-1.50.16-r2.ebuild
new file mode 100644
index 000000000000..4bd529fdb9f8
--- /dev/null
+++ b/app-admin/webapp-config/webapp-config-1.50.16-r2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-1.50.16-r2.ebuild,v 1.1 2007/09/09 21:11:40 hollow Exp $
+
+inherit eutils distutils
+
+DESCRIPTION="Gentoo's installer for web-based applications"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="http://build.pardus.de/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-apache-move.patch
+ epatch "${FILESDIR}"/${P}-baselayout2.patch
+}
+
+src_install() {
+
+ # According to this discussion:
+ # http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
+ # distutils does not provide for specifying two different script install
+ # locations. Since we only install one script here the following should
+ # be ok
+ distutils_src_install --install-scripts="/usr/sbin"
+
+ dodir /etc/vhosts
+ cp config/webapp-config ${D}/etc/vhosts/
+ keepdir /usr/share/webapps
+ keepdir /var/db/webapps
+ dodoc examples/phpmyadmin-2.5.4-r1.ebuild AUTHORS.txt TODO.txt CHANGES.txt examples/postinstall-en.txt
+ doman doc/webapp-config.5 doc/webapp-config.8 doc/webapp.eclass.5
+ dohtml doc/webapp-config.5.html doc/webapp-config.8.html doc/webapp.eclass.5.html
+}
+
+src_test() {
+ cd ${S}
+ distutils_python_version
+ if [[ $PYVER_MAJOR -gt 1 ]] && [[ $PYVER_MINOR -gt 3 ]] ; then
+ elog "Running webapp-config doctests..."
+ if ! PYTHONPATH="." ${python} WebappConfig/tests/dtest.py; then
+ eerror "DocTests failed - please submit a bug report"
+ die "DocTesting failed!"
+ fi
+ else
+ elog "Python version below 2.4! Disabling tests."
+ fi
+}
+
+pkg_postinst() {
+ echo
+ elog "Now that you have upgraded webapp-config, you **must** update your"
+ elog "config files in /etc/vhosts/webapp-config before you emerge any"
+ elog "packages that use webapp-config."
+ echo
+ epause 5
+}