summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-09-07 22:40:55 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-09-07 22:40:55 +0000
commit0feabf60168288d09c903efda877702e9a3f4353 (patch)
treeff712bea1fed97755cfc01875bb9d4d6fb08339a /app-admin/usermin
parentAdded support for BerkeleyDB via the USE flag berkdb. Added support for the l... (diff)
downloadgentoo-2-0feabf60168288d09c903efda877702e9a3f4353.tar.gz
gentoo-2-0feabf60168288d09c903efda877702e9a3f4353.tar.bz2
gentoo-2-0feabf60168288d09c903efda877702e9a3f4353.zip
Version bump for security release. See bug #63167.
Diffstat (limited to 'app-admin/usermin')
-rw-r--r--app-admin/usermin/ChangeLog8
-rw-r--r--app-admin/usermin/Manifest4
-rw-r--r--app-admin/usermin/files/digest-usermin-1.0901
-rw-r--r--app-admin/usermin/usermin-1.090.ebuild90
4 files changed, 101 insertions, 2 deletions
diff --git a/app-admin/usermin/ChangeLog b/app-admin/usermin/ChangeLog
index 77cb5a20a445..f06d6602b2fc 100644
--- a/app-admin/usermin/ChangeLog
+++ b/app-admin/usermin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/usermin
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/usermin/ChangeLog,v 1.35 2004/08/29 06:09:33 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/usermin/ChangeLog,v 1.36 2004/09/07 22:40:55 eradicator Exp $
+
+*usermin-1.090 (07 Sep 2004)
+
+ 07 Sep 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ +usermin-1.090.ebuild:
+ Version bump for security release. See bug #63167.
29 Aug 2004; Tom Gall <tgall@gentoo.org> usermin-1.080-r1.ebuild:
stable on ppc64, bug #60198
diff --git a/app-admin/usermin/Manifest b/app-admin/usermin/Manifest
index 7c97b73cc95d..26176b0d37ae 100644
--- a/app-admin/usermin/Manifest
+++ b/app-admin/usermin/Manifest
@@ -1,7 +1,9 @@
MD5 9946bb505de5ad750c01ccbe1f499ef4 ChangeLog 5158
MD5 3923b6ae9bc25fc124e24e7747c8a802 metadata.xml 226
MD5 72b3da5f3e255f83a909b3eb2abf240b usermin-1.080-r1.ebuild 2210
+MD5 f1018e314ddde42c24d4f2609ed78508 usermin-1.090.ebuild 2213
MD5 e6e25dc89f0ccd9ce1af4b508d27a5d6 files/digest-usermin-1.080-r1 66
-MD5 9e90c17c1e63a8027bbb4e7aa18f8b20 files/init.d.usermin 821
MD5 bd4b2cc177b4fb7b0f96edc60008a6b5 files/usermin-1.080-safestop.patch 620
+MD5 4a8c93084becc5ae5beb4488282df537 files/digest-usermin-1.090 66
+MD5 9e90c17c1e63a8027bbb4e7aa18f8b20 files/init.d.usermin 821
MD5 a5311bbc9c1fc378a6b0bfb3ca1b2394 files/usermin.pam 431
diff --git a/app-admin/usermin/files/digest-usermin-1.090 b/app-admin/usermin/files/digest-usermin-1.090
new file mode 100644
index 000000000000..a090e7ee577c
--- /dev/null
+++ b/app-admin/usermin/files/digest-usermin-1.090
@@ -0,0 +1 @@
+MD5 bc9da023865a98a3dfbe5bb4e421ad5c usermin-1.090.tar.gz 2140461
diff --git a/app-admin/usermin/usermin-1.090.ebuild b/app-admin/usermin/usermin-1.090.ebuild
new file mode 100644
index 000000000000..48f886210894
--- /dev/null
+++ b/app-admin/usermin/usermin-1.090.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/usermin/usermin-1.090.ebuild,v 1.1 2004/09/07 22:40:55 eradicator Exp $
+
+inherit eutils
+
+DESCRIPTION="a web-based user administration interface"
+HOMEPAGE="http://www.webmin.com/index6.html"
+SRC_URI="mirror://sourceforge/webadmin/${P}.tar.gz"
+RESTRICT="nomirror"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86 sparc ~alpha ~ppc amd64 ~ppc64"
+IUSE="ssl"
+
+RDEPEND="dev-lang/perl
+ sys-apps/lsof
+ >=sys-apps/sed-4
+ dev-perl/Authen-PAM
+ ssl? ( dev-perl/Net-SSLeay )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ # Point to the correct mysql location
+ sed -i "s:/usr/local/mysql:/usr:g" mysql/config
+
+ # Bug #46273... missing config for gentoo
+ cp quota/generic-linux-lib.pl quota/gentoo-linux-lib.p
+
+ epatch ${FILESDIR}/${PN}-1.080-safestop.patch
+}
+
+src_install() {
+ dodir /usr/libexec/usermin
+ cp -a * ${D}/usr/libexec/usermin
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/init.d.usermin usermin
+
+ insinto /etc/pam.d
+ newins ${FILESDIR}/${PN}.pam ${PN}
+
+ dosym ../usr/libexec/usermin /etc/usermin
+
+ # Change /usr/local/bin/perl references
+ find ${D} -type f | xargs sed -i 's:^#!.*/usr/local/bin/perl:#!/usr/bin/perl:'
+}
+
+pkg_postinst() {
+ /etc/init.d/usermin stop >& /dev/null
+ stopstatus=$?
+
+ cd /usr/libexec/usermin
+ config_dir=/etc/usermin
+ var_dir=/var/log/usermin
+ perl=/usr/bin/perl
+ autoos=1
+ port=20000
+ login=root
+ crypt=`grep "^root:" /etc/shadow | cut -f 2 -d :`
+ host=`hostname`
+ use ssl && ssl=1 || ssl=0
+ atboot=0
+ nostart=1
+ nochown=1
+ autothird=1
+ nouninstall=1
+ noperlpath=1
+ export config_dir var_dir perl autoos port login crypt host ssl nochown autothird nouninstall nostart noperlpath
+ perl /usr/libexec/usermin/maketemp.pl
+ ./setup.sh > /tmp/.webmin/usermin-setup.out 2>&1
+
+ if [ "$stopstatus" = "0" ]; then
+ # Start if it was running before
+ /etc/init.d/usermin start
+ fi
+
+ sed -i 's:^pidfile=.*$:pidfile=/var/run/usermin.pid:' /etc/usermin/miniserv.conf
+
+ einfo "Add usermin to your boot-time services with 'rc-update add usermin'."
+ einfo "Point your web browser to http://localhost:20000 to use usermin."
+}
+
+pkg_prerm() {
+ /etc/init.d/usermin stop >& /dev/null
+}