summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-03-15 16:55:57 +0000
committerJeroen Roovers <jer@gentoo.org>2011-03-15 16:55:57 +0000
commit633297aa1d9f8af925d8390c9ba102217c7571ed (patch)
treeb0867741d1265cbfe98094d29aa51600b2a77d0c /app-admin/sysstat/sysstat-9.1.3.ebuild
parentremove old (diff)
downloadgentoo-2-633297aa1d9f8af925d8390c9ba102217c7571ed.tar.gz
gentoo-2-633297aa1d9f8af925d8390c9ba102217c7571ed.tar.bz2
gentoo-2-633297aa1d9f8af925d8390c9ba102217c7571ed.zip
Version bump. Redo LINGUAS patch. Add patch to respect LDFLAGS/CFLAGS.
(Portage version: 2.2.0_alpha27/cvs/Linux i686)
Diffstat (limited to 'app-admin/sysstat/sysstat-9.1.3.ebuild')
-rw-r--r--app-admin/sysstat/sysstat-9.1.3.ebuild79
1 files changed, 0 insertions, 79 deletions
diff --git a/app-admin/sysstat/sysstat-9.1.3.ebuild b/app-admin/sysstat/sysstat-9.1.3.ebuild
deleted file mode 100644
index 78849c80025f..000000000000
--- a/app-admin/sysstat/sysstat-9.1.3.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sysstat/sysstat-9.1.3.ebuild,v 1.2 2010/09/14 05:24:17 jer Exp $
-
-EAPI="2"
-
-inherit eutils multilib
-
-DESCRIPTION="System performance tools for Linux"
-HOMEPAGE="http://pagesperso-orange.fr/sebastien.godard/"
-SRC_URI="${HOMEPAGE}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE="cron +doc isag nls"
-
-SYSSTAT_LINGUAS="af da de es eu fi fr id it ja ky lv mt nb nl nn pl pt_BR pt ro ru sk sv vi zh_CN zh_TW"
-
-for SYSSTAT_LINGUA in ${SYSSTAT_LINGUAS}; do
- IUSE="${IUSE} linguas_${SYSSTAT_LINGUA}"
-done
-
-RDEPEND="
- cron? ( sys-process/cronbase )
- isag? (
- dev-lang/tk
- dev-vcs/rcs
- sci-visualization/gnuplot
- )
- nls? ( virtual/libintl )
-"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-9.1.2-nls.patch"
-
- local lingua NLSDIR="${S}/nls"
- einfo "Keeping these locales: ${LINGUAS}."
- for lingua in ${SYSSTAT_LINGUAS}; do
- if ! use linguas_${lingua}; then
- rm -f "${NLSDIR}/${lingua}.po"
- fi
- done
-}
-
-src_configure() {
- local myconf=""
- use doc || myconf="--disable-documentation"
- sa_lib_dir=/usr/$(get_libdir)/sa \
- econf ${myconf} \
- rcdir="Gentoo-does-not-use-rc.d" \
- $(use_enable cron install-cron) \
- $(use_enable isag install-isag) \
- $(use_enable nls) \
- conf_dir=/etc || die "econf failed"
-}
-
-src_compile() {
- emake LFLAGS="${LDFLAGS}" || die "emake failed"
-}
-
-src_install() {
- keepdir /var/log/sa
-
- use cron && dodir /etc/cron.{daily,hourly}
-
- emake \
- DESTDIR="${D}" \
- DOC_DIR=/usr/share/doc/${PF} \
- install || die "make install failed"
-
- dodoc contrib/sargraph/sargraph
-
- newinitd "${FILESDIR}"/sysstat.init.d sysstat
-
- use doc && rm -f "${D}"usr/share/doc/${PF}/COPYING
-}