summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2015-03-06 12:28:58 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2015-03-06 12:28:58 +0000
commit6e419ab21ccea6a623300f13662745ac54e4f57a (patch)
tree0ac53c8576b454caee6070b7d179781d72f3b4bf /app-admin/stow
parentdrop unnecessary use dep on libfm[gtk] (diff)
downloadgentoo-2-6e419ab21ccea6a623300f13662745ac54e4f57a.tar.gz
gentoo-2-6e419ab21ccea6a623300f13662745ac54e4f57a.tar.bz2
gentoo-2-6e419ab21ccea6a623300f13662745ac54e4f57a.zip
Add upstream patch to fix bug #539702. Thanks to Erik Falor.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'app-admin/stow')
-rw-r--r--app-admin/stow/ChangeLog10
-rw-r--r--app-admin/stow/files/stow-2.2.0-avoid-precedence-warning.patch13
-rw-r--r--app-admin/stow/stow-2.2.0-r2.ebuild46
3 files changed, 67 insertions, 2 deletions
diff --git a/app-admin/stow/ChangeLog b/app-admin/stow/ChangeLog
index ca916b657224..9118547eff59 100644
--- a/app-admin/stow/ChangeLog
+++ b/app-admin/stow/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/stow
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/stow/ChangeLog,v 1.22 2014/03/26 16:03:19 maksbotan Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/stow/ChangeLog,v 1.23 2015/03/06 12:28:58 maksbotan Exp $
+
+*stow-2.2.0-r2 (06 Mar 2015)
+
+ 06 Mar 2015; Maxim Koltsov <maksbotan@gentoo.org>
+ +files/stow-2.2.0-avoid-precedence-warning.patch, +stow-2.2.0-r2.ebuild:
+ Add upstream patch to fix bug #539702. Thanks to Erik Falor.
*stow-2.2.0-r1 (26 Mar 2014)
diff --git a/app-admin/stow/files/stow-2.2.0-avoid-precedence-warning.patch b/app-admin/stow/files/stow-2.2.0-avoid-precedence-warning.patch
new file mode 100644
index 000000000000..75838e3a7c62
--- /dev/null
+++ b/app-admin/stow/files/stow-2.2.0-avoid-precedence-warning.patch
@@ -0,0 +1,13 @@
+--- lib/Stow.pm.in
++++ lib/Stow.pm.in
+@@ -1734,8 +1734,8 @@ sub read_a_link {
+ }
+ elsif (-l $path) {
+ debug(4, " read_a_link($path): real link");
+- return readlink $path
+- or error("Could not read link: $path");
++ my $target = readlink $path or error("Could not read link: $path ($!)");
++ return $target;
+ }
+ internal_error("read_a_link() passed a non link path: $path\n");
+ }
diff --git a/app-admin/stow/stow-2.2.0-r2.ebuild b/app-admin/stow/stow-2.2.0-r2.ebuild
new file mode 100644
index 000000000000..602a51ebd96b
--- /dev/null
+++ b/app-admin/stow/stow-2.2.0-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/stow/stow-2.2.0-r2.ebuild,v 1.1 2015/03/06 12:28:58 maksbotan Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="Manage installation of software in /var/lib/"
+HOMEPAGE="http://www.gnu.org/software/stow/"
+SRC_URI="mirror://gnu/stow/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="test"
+
+DEPEND="dev-lang/perl
+ test? (
+ virtual/perl-Test-Harness
+ dev-perl/Test-Output
+ )"
+RDEPEND="dev-lang/perl"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-avoid-precedence-warning.patch"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+
+ # create new STOWDIR
+ dodir /var/lib/stow
+
+ # install env.d file to add STOWDIR to PATH and LDPATH
+ doenvd "${FILESDIR}"/99stow || die "doenvd failed"
+}
+
+pkg_postinst() {
+ elog "We now recommend that you use /var/lib/stow as your STOWDIR"
+ elog "instead of /usr/local in order to avoid conflicts with the"
+ elog "symlink from /usr/lib64 -> /usr/lib. See Bug 246264 for"
+ elog "more details on this change."
+ elog "For your convenience, PATH has been updated to include"
+ elog "/var/lib/stow/bin."
+}