summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-09-12 19:38:59 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-09-12 19:38:59 +0000
commit831ba1f43823e4cf74008296d15ccca276007d9e (patch)
tree0cb068711708ec3006c718a971b6062afc69f913 /app-admin/profiler/profiler-1-r1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-831ba1f43823e4cf74008296d15ccca276007d9e.tar.gz
gentoo-2-831ba1f43823e4cf74008296d15ccca276007d9e.tar.bz2
gentoo-2-831ba1f43823e4cf74008296d15ccca276007d9e.zip
Migrated to new Java build system.
(Portage version: 2.1.1)
Diffstat (limited to 'app-admin/profiler/profiler-1-r1.ebuild')
-rw-r--r--app-admin/profiler/profiler-1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-admin/profiler/profiler-1-r1.ebuild b/app-admin/profiler/profiler-1-r1.ebuild
new file mode 100644
index 000000000000..b5459ed5e04d
--- /dev/null
+++ b/app-admin/profiler/profiler-1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/profiler/profiler-1-r1.ebuild,v 1.1 2006/09/12 19:38:59 nelchael Exp $
+
+inherit java-pkg-2
+
+DESCRIPTION="Provides 3D visual representation of file system statistics"
+HOMEPAGE="http://visualversion.com/profiler/"
+SRC_URI="http://visualversion.com/profiler/profiler.jar"
+
+LICENSE="as-is"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND=">=virtual/jre-1.4"
+
+S=${WORKDIR}
+
+src_unpack() {
+
+ cp ${DISTDIR}/${A} ${S}/
+
+}
+
+src_install() {
+
+ dobin ${FILESDIR}/profiler
+ java-pkg_dojar ${A}
+
+}