summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2007-05-25 10:59:23 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2007-05-25 10:59:23 +0000
commitf57eac7b6a3307ae906ad8cbaa613b91c11656ef (patch)
tree5eaf05338bc3353b91e38bb4e1365de0720fabcb /app-admin/lsat/lsat-0.9.6.ebuild
parentAdd java-pkg_register-environment-variable function. Needs new java-config re... (diff)
downloadgentoo-2-f57eac7b6a3307ae906ad8cbaa613b91c11656ef.tar.gz
gentoo-2-f57eac7b6a3307ae906ad8cbaa613b91c11656ef.tar.bz2
gentoo-2-f57eac7b6a3307ae906ad8cbaa613b91c11656ef.zip
Version bumped. Added minimal USE flag.
(Portage version: 2.1.2.7)
Diffstat (limited to 'app-admin/lsat/lsat-0.9.6.ebuild')
-rw-r--r--app-admin/lsat/lsat-0.9.6.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-admin/lsat/lsat-0.9.6.ebuild b/app-admin/lsat/lsat-0.9.6.ebuild
new file mode 100644
index 000000000000..e51a415ecbdc
--- /dev/null
+++ b/app-admin/lsat/lsat-0.9.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/lsat/lsat-0.9.6.ebuild,v 1.1 2007/05/25 10:59:23 matsuu Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="The Linux Security Auditing Tool"
+HOMEPAGE="http://usat.sourceforge.net/"
+SRC_URI="http://usat.sourceforge.net/code/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="minimal"
+
+DEPEND="dev-lang/perl" # pod2man
+RDEPEND="!minimal? (
+ app-portage/portage-utils
+ net-analyzer/nmap
+ sys-apps/iproute2
+ sys-apps/which
+ sys-process/lsof
+ )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ tc-export CC
+ econf || die
+ emake CFLAGS="${CFLAGS}" all manpage || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install installman || die
+ dodoc README* *.txt
+ dohtml modules.html changelog/changelog.html
+}