summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2009-01-25 19:42:46 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2009-01-25 19:42:46 +0000
commit488190a55ddabd40a14e0851c1dea28f3516cc48 (patch)
tree42a200301a15f7bdd508e38350cb3ff7514c0a23 /app-admin/logrotate
parentImport dev-java/biojava and dependencies from Java overlay, thanks to serkan (diff)
downloadgentoo-2-488190a55ddabd40a14e0851c1dea28f3516cc48.tar.gz
gentoo-2-488190a55ddabd40a14e0851c1dea28f3516cc48.tar.bz2
gentoo-2-488190a55ddabd40a14e0851c1dea28f3516cc48.zip
Real fix this time for bug #254795; thanks Javier
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/logrotate')
-rw-r--r--app-admin/logrotate/ChangeLog6
-rw-r--r--app-admin/logrotate/files/logrotate-3.7.7-fbsd.patch35
2 files changed, 34 insertions, 7 deletions
diff --git a/app-admin/logrotate/ChangeLog b/app-admin/logrotate/ChangeLog
index 4ad65d7b318d..460a7e49a595 100644
--- a/app-admin/logrotate/ChangeLog
+++ b/app-admin/logrotate/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/logrotate
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/ChangeLog,v 1.75 2009/01/14 16:26:28 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/ChangeLog,v 1.76 2009/01/25 19:42:45 dang Exp $
+
+ 25 Jan 2009; Daniel Gryniewicz <dang@gentoo.org>
+ files/logrotate-3.7.7-fbsd.patch:
+ Real fix this time for bug #254795; thanks Javier
14 Jan 2009; Daniel Gryniewicz <dang@gentoo.org> logrotate-3.7.7.ebuild:
Try again to fix fbsd; bug #254795
diff --git a/app-admin/logrotate/files/logrotate-3.7.7-fbsd.patch b/app-admin/logrotate/files/logrotate-3.7.7-fbsd.patch
index 3d42c17e5297..6bd2e5470c4a 100644
--- a/app-admin/logrotate/files/logrotate-3.7.7-fbsd.patch
+++ b/app-admin/logrotate/files/logrotate-3.7.7-fbsd.patch
@@ -1,6 +1,10 @@
-diff --exclude-from=/home/dang/.scripts/diffrc -up -ruN logrotate-3.7.7.orig/config.c logrotate-3.7.7/config.c
---- logrotate-3.7.7.orig/config.c 2008-05-09 03:28:59.000000000 -0400
-+++ logrotate-3.7.7/config.c 2009-01-13 16:48:13.000000000 -0500
+Fix compilation on Gentoo/FreeBSD, no alloca.h here and PATH_MAX
+is defined elsewhere.
+
+See bug 254795
+
+--- logrotate-3.7.7.orig/config.c
++++ logrotate-3.7.7/config.c
@@ -1,5 +1,7 @@
#include <sys/queue.h>
+#ifndef NO_ALLOCA_H
@@ -9,9 +13,18 @@ diff --exclude-from=/home/dang/.scripts/diffrc -up -ruN logrotate-3.7.7.orig/con
#include <ctype.h>
#include <dirent.h>
#include <errno.h>
-diff --exclude-from=/home/dang/.scripts/diffrc -up -ruN logrotate-3.7.7.orig/logrotate.c logrotate-3.7.7/logrotate.c
---- logrotate-3.7.7.orig/logrotate.c 2008-05-14 06:31:35.000000000 -0400
-+++ logrotate-3.7.7/logrotate.c 2009-01-13 16:48:12.000000000 -0500
+@@ -21,6 +21,9 @@
+ #include <wctype.h>
+ #include <fnmatch.h>
+
++#if !defined(PATH_MAX) && defined(__FreeBSD__)
++#include <sys/param.h>
++#endif
+ #include "basenames.h"
+ #include "log.h"
+ #include "logrotate.h"
+--- logrotate-3.7.7.orig/logrotate.c
++++ logrotate-3.7.7/logrotate.c
@@ -1,5 +1,7 @@
#include <sys/queue.h>
+#ifndef NO_ALLOCA_H
@@ -20,3 +33,13 @@ diff --exclude-from=/home/dang/.scripts/diffrc -up -ruN logrotate-3.7.7.orig/log
#include <ctype.h>
#include <dirent.h>
#include <errno.h>
+@@ -24,6 +24,9 @@
+ int selinux_enforce = 0;
+ #endif
+
++#if !defined(PATH_MAX) && defined(__FreeBSD__)
++#include <sys/param.h>
++#endif
+ #include "basenames.h"
+ #include "log.h"
+ #include "logrotate.h"