summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2012-10-22 12:58:58 +0000
committerAgostino Sarubbo <ago@gentoo.org>2012-10-22 12:58:58 +0000
commit82d46acd3fd4a718f7aab2b369028290324fe6c5 (patch)
tree3697264fc296d0c7f81ed9939cce8fbd07be53e3 /app-admin/integrit
parentAdd unkeyworded 1.5.0 required for FIT CVUT setup. Contact petr.hodac@fit.cvu... (diff)
downloadgentoo-2-82d46acd3fd4a718f7aab2b369028290324fe6c5.tar.gz
gentoo-2-82d46acd3fd4a718f7aab2b369028290324fe6c5.tar.bz2
gentoo-2-82d46acd3fd4a718f7aab2b369028290324fe6c5.zip
New revision, EAPI4 + restrict test
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/integrit')
-rw-r--r--app-admin/integrit/ChangeLog10
-rw-r--r--app-admin/integrit/integrit-4.1-r1.ebuild63
2 files changed, 70 insertions, 3 deletions
diff --git a/app-admin/integrit/ChangeLog b/app-admin/integrit/ChangeLog
index 57a047c369f0..ef6551e002e6 100644
--- a/app-admin/integrit/ChangeLog
+++ b/app-admin/integrit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/integrit
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/integrit/ChangeLog,v 1.23 2009/01/04 23:03:27 patrick Exp $
+# Copyright 2002-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/integrit/ChangeLog,v 1.24 2012/10/22 12:58:58 ago Exp $
+
+*integrit-4.1-r1 (22 Oct 2012)
+
+ 22 Oct 2012; Agostino Sarubbo <ago@gentoo.org> +integrit-4.1-r1.ebuild:
+ New revision, EAPI4 + restrict test
*integrit-4.1 (04 Jan 2009)
@@ -69,4 +74,3 @@
23 Oct 2002; Zach Welch <zwelch@gentoo.org> :
Import from bug 9454, contributed by Danny Pansters <danny@ricin.com>
-
diff --git a/app-admin/integrit/integrit-4.1-r1.ebuild b/app-admin/integrit/integrit-4.1-r1.ebuild
new file mode 100644
index 000000000000..e51704c669a0
--- /dev/null
+++ b/app-admin/integrit/integrit-4.1-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/integrit/integrit-4.1-r1.ebuild,v 1.1 2012/10/22 12:58:58 ago Exp $
+
+EAPI=4
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="file integrity verification program"
+HOMEPAGE="http://integrit.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RESTRICT="test" # 276190
+
+src_prepare() {
+ sed -i -e "/^CC/d" configure.in hashtbl/configure.in || die
+ sed -i -e "/^AC_PROGRAM_PATH/d" configure.in hashtbl/configure.in || die
+ eautoreconf
+ tc-export AR
+}
+
+src_compile() {
+ emake
+ emake utils
+
+ cd "${S}"/doc && emake
+ cd "${S}"/hashtbl && emake hashtest
+}
+
+src_install() {
+ dosbin integrit
+ dolib libintegrit.a
+ dodoc Changes HACKING README todo.txt
+
+ cd "${S}"/utils
+ dosbin i-viewdb
+ dobin i-ls
+
+ cd "${S}"/hashtbl
+ dolib libhashtbl.a
+ insinto /usr/include
+ doins hashtbl.h
+ dobin hashtest
+ newdoc README README.hashtbl
+
+ cd "${S}"/doc
+ doman i-ls.1 i-viewdb.1 integrit.1
+ doinfo integrit.info
+
+ cd "${S}"/examples
+ docinto examples
+ dodoc *
+}
+
+pkg_postinst() {
+ elog "It is recommended that the integrit binary is copied to a secure"
+ elog "location and re-copied at runtime or run from a secure medium."
+ elog "You should also create a configuration file (see examples)."
+}