summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2011-11-29 18:37:49 +0000
committerFabian Groffen <grobian@gentoo.org>2011-11-29 18:37:49 +0000
commit38648efd99c674083b7f2ec16a9037dbc9796a9f (patch)
tree8d6a814c4225076ec5141a66d1e94e32411b4754 /app-admin/chrpath
parentFix building of helper apps respecting LDFLAGS (bug #391279) and for --as-nee... (diff)
downloadgentoo-2-38648efd99c674083b7f2ec16a9037dbc9796a9f.tar.gz
gentoo-2-38648efd99c674083b7f2ec16a9037dbc9796a9f.tar.bz2
gentoo-2-38648efd99c674083b7f2ec16a9037dbc9796a9f.zip
Cleanup static-libs code, thanks Kacper Kowalik and Agostino Sarubbo. The produced shared libraries are only dlopened by the main chrpath program to work around a duplicate names issue, it are in fact just ordinary shared libraries, so we should retain .la files for them if we want static libs.
(Portage version: 2.2.01.19572-prefix/cvs/SunOS i386)
Diffstat (limited to 'app-admin/chrpath')
-rw-r--r--app-admin/chrpath/ChangeLog8
-rw-r--r--app-admin/chrpath/chrpath-0.13-r2.ebuild9
2 files changed, 13 insertions, 4 deletions
diff --git a/app-admin/chrpath/ChangeLog b/app-admin/chrpath/ChangeLog
index 738bcbac23a9..b190249d00f4 100644
--- a/app-admin/chrpath/ChangeLog
+++ b/app-admin/chrpath/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/chrpath
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/chrpath/ChangeLog,v 1.18 2011/10/11 18:19:49 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/chrpath/ChangeLog,v 1.19 2011/11/29 18:37:49 grobian Exp $
+
+ 29 Nov 2011; Fabian Groffen <grobian@gentoo.org> chrpath-0.13-r2.ebuild:
+ Cleanup static-libs code, thanks Kacper Kowalik and Agostino Sarubbo. The
+ produced shared libraries are only dlopened by the main chrpath program to
+ work around a duplicate names issue, it are in fact just ordinary shared
+ libraries, so we should retain .la files for them if we want static libs.
11 Oct 2011; Fabian Groffen <grobian@gentoo.org> chrpath-0.13-r2.ebuild:
Fix odd double docs dir installation, remove libtool archives, install static
diff --git a/app-admin/chrpath/chrpath-0.13-r2.ebuild b/app-admin/chrpath/chrpath-0.13-r2.ebuild
index db6414fc388b..3631530e6ffe 100644
--- a/app-admin/chrpath/chrpath-0.13-r2.ebuild
+++ b/app-admin/chrpath/chrpath-0.13-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/chrpath/chrpath-0.13-r2.ebuild,v 1.4 2011/10/11 18:19:49 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/chrpath/chrpath-0.13-r2.ebuild,v 1.5 2011/11/29 18:37:49 grobian Exp $
EAPI="2"
@@ -25,9 +25,12 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ econf $(use_enable static_libs static) || die
+}
+
src_install() {
emake DESTDIR="${D}" install || die
dodoc ChangeLog AUTHORS NEWS README
- find "${D}" -name "*.la" -exec rm '{}' +
- use static-libs || find "${D}" -name "*.a" -exec rm '{}' +
+ use static-libs || find "${D}" -name "*.la" -exec rm '{}' +
}