summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-09-18 23:56:22 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-09-18 23:56:22 +0000
commit5dfb4c5862ade4ac64ad46fee7b26350d7a9e1aa (patch)
treee9b1aa67568115705448c795752b8f99681523b0 /app-admin/bastille/bastille-2.1.1-r1.ebuild
parentmoved from net-firewall (diff)
downloadgentoo-2-5dfb4c5862ade4ac64ad46fee7b26350d7a9e1aa.tar.gz
gentoo-2-5dfb4c5862ade4ac64ad46fee7b26350d7a9e1aa.tar.bz2
gentoo-2-5dfb4c5862ade4ac64ad46fee7b26350d7a9e1aa.zip
moved from net-firewall
Diffstat (limited to 'app-admin/bastille/bastille-2.1.1-r1.ebuild')
-rw-r--r--app-admin/bastille/bastille-2.1.1-r1.ebuild92
1 files changed, 92 insertions, 0 deletions
diff --git a/app-admin/bastille/bastille-2.1.1-r1.ebuild b/app-admin/bastille/bastille-2.1.1-r1.ebuild
new file mode 100644
index 000000000000..deb07cff44c7
--- /dev/null
+++ b/app-admin/bastille/bastille-2.1.1-r1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bastille/bastille-2.1.1-r1.ebuild,v 1.1 2003/09/18 23:56:21 seemant Exp $
+
+inherit perl-module
+
+IUSE="X"
+
+PATCHVER=0.1
+MY_PN=${PN/b/B}
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_PN}
+DESCRIPTION="Bastille-Linux is a security hardening tool"
+HOMEPAGE="http://bastille-linux.org/"
+SRC_URI="mirror://sourceforge/${PN}-linux/${MY_P}.tar.bz2
+ mirror://gentoo/${P}-gentoo-${PATCHVER}.patch.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa"
+
+
+RDEPEND="net-firewall/iptables
+ app-admin/logrotate
+ dev-perl/Curses
+ net-firewall/psad
+ X? ( dev-perl/perl-tk )"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${WORKDIR}/${P}-gentoo-${PATCHVER}.patch
+}
+
+src_compile() {
+ cd ${S}
+}
+
+src_install() {
+
+ keepdir /var/lock/subsys/${PN}
+ dodir /etc/Bastille
+
+ cd ${S}
+ into /usr
+ dosbin bastille AutomatedBastille InteractiveBastille \
+ BastilleBackEnd RevertBastille *.pl
+
+ dosym RevertBastille /usr/sbin/UndoBastille
+
+ insinto /usr/share/Bastille
+ doins Questions* Credits bastille-* *.xbm *.config
+
+ insinto /usr/share/Bastille
+ doins Questions.txt Credits complete.xbm incomplete.xbm \
+ ifup-local hosts.allow
+
+ exeinto /usr/share/Bastille
+ doexe bastille-firewall* bastille-tmpdir* \
+ bastille-ipchains bastille-netfilter \
+ firewall/*.sh
+
+ perlinfo
+ insinto ${SITE_LIB}
+ doins Bastille_Curses.pm
+ use X && doins Bastille_Tk.pm
+ insinto ${SITE_LIB}/Curses
+ doins Curses/Widgets.pm
+
+ doman docs/bastille.1m
+ dodoc docs/* firewall/*.txt
+
+ cd ${S}/Bastille
+
+ insinto /usr/lib/Bastille
+ doins AccountSecurity.pm Apache.pm API.pm OSX_API.pm BootSecurity.pm \
+ ConfigureMiscPAM.pm DisableUserTools.pm DNS.pm \
+ FilePermissions.pm FTP.pm Firewall.pm HP_API.pm HP_UX.pm \
+ IOLoader.pm Patches.pm Logging.pm \
+ MiscellaneousDaemons.pm PatchDownload.pm Printing.pm \
+ RemoteAccess.pm SecureInetd.pm Sendmail.pm TMPDIR.pm \
+ test_AccountSecurity.pm test_Apache.pm test_DNS.pm \
+ test_FTP.pm test_HP_UX.pm test_MiscellaneousDaemons.pm \
+ test_SecureInetd.pm test_Sendmail.pm TestAPI.pm IPFilter.pm
+
+ # Documentation
+ cd ${S}
+ dodoc *.txt COPYING BUGS Change* README*
+}
+
+pkg_postinst() {
+ use X || einfo "When not using the Tk interface you will need to start use the -c flag when calling ${PN} from command line. example ${PN} -c --os GE1.4"
+}