summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2006-05-02 00:14:31 +0000
committerMark Loeser <halcy0n@gentoo.org>2006-05-02 00:14:31 +0000
commit5c7bc1009400e191b099f1636ef64b5dbeb219da (patch)
tree4f7b215db1e4db8f9ca64cbfd68a80ec82d44ec4 /app-admin/apachetop/apachetop-0.12.6.ebuild
parentStable on sparc (diff)
downloadgentoo-2-5c7bc1009400e191b099f1636ef64b5dbeb219da.tar.gz
gentoo-2-5c7bc1009400e191b099f1636ef64b5dbeb219da.tar.bz2
gentoo-2-5c7bc1009400e191b099f1636ef64b5dbeb219da.zip
Add patch to fix compilation with gcc-4.1 by tristanheaven AT gmail DOT com; bug #130819
(Portage version: 2.1_pre10)
Diffstat (limited to 'app-admin/apachetop/apachetop-0.12.6.ebuild')
-rw-r--r--app-admin/apachetop/apachetop-0.12.6.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/app-admin/apachetop/apachetop-0.12.6.ebuild b/app-admin/apachetop/apachetop-0.12.6.ebuild
index e6432c23c1fd..eb0c23801a59 100644
--- a/app-admin/apachetop/apachetop-0.12.6.ebuild
+++ b/app-admin/apachetop/apachetop-0.12.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apachetop/apachetop-0.12.6.ebuild,v 1.1 2006/04/21 17:55:24 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apachetop/apachetop-0.12.6.ebuild,v 1.2 2006/05/02 00:14:30 halcy0n Exp $
inherit eutils
@@ -20,6 +20,13 @@ DEPEND="sys-apps/sed
pcre? ( dev-libs/libpcre )
adns? ( net-libs/adns )"
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc41.patch
+}
+
src_compile() {
useq apache2 && logfile="/var/log/apache2/access_log"
useq apache2 || logfile="/var/log/apache/access_log"