summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-05-25 07:32:28 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-05-25 07:32:28 +0000
commit2eda302a0910177060ed0d2bf5ef78f0908801e1 (patch)
treedb824f6245d716f4579ae8c5914074fc46e68855 /app-admin/ansible
parentRemove manual installation of ansible modules, wrt bug #470890. Thanks to Jan... (diff)
downloadgentoo-2-2eda302a0910177060ed0d2bf5ef78f0908801e1.tar.gz
gentoo-2-2eda302a0910177060ed0d2bf5ef78f0908801e1.tar.bz2
gentoo-2-2eda302a0910177060ed0d2bf5ef78f0908801e1.zip
Change maintainer, drop old version and deprecated USE flags descriptions
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'app-admin/ansible')
-rw-r--r--app-admin/ansible/ChangeLog6
-rw-r--r--app-admin/ansible/ansible-0.9-r1.ebuild72
-rw-r--r--app-admin/ansible/files/ansible-0.9-distribution-fix.patch23
-rw-r--r--app-admin/ansible/metadata.xml11
4 files changed, 5 insertions, 107 deletions
diff --git a/app-admin/ansible/ChangeLog b/app-admin/ansible/ChangeLog
index 063d5b7ca030..6b1b829f4d1f 100644
--- a/app-admin/ansible/ChangeLog
+++ b/app-admin/ansible/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/ansible
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ChangeLog,v 1.14 2013/05/25 07:29:35 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ChangeLog,v 1.15 2013/05/25 07:32:28 pinkbyte Exp $
+
+ 25 May 2013; Sergey Popov <pinkbyte@gentoo.org> -ansible-0.9-r1.ebuild,
+ -files/ansible-0.9-distribution-fix.patch, metadata.xml:
+ Change maintainer, drop old version and deprecated USE flags descriptions
25 May 2013; Sergey Popov <pinkbyte@gentoo.org> ansible-9999.ebuild:
Remove manual installation of ansible modules, wrt bug #470890. Thanks to Jan
diff --git a/app-admin/ansible/ansible-0.9-r1.ebuild b/app-admin/ansible/ansible-0.9-r1.ebuild
deleted file mode 100644
index 6dc58272f18e..000000000000
--- a/app-admin/ansible/ansible-0.9-r1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ansible-0.9-r1.ebuild,v 1.2 2013/01/15 15:18:28 pinkbyte Exp $
-
-EAPI="5"
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Radically simple deployment, model-driven configuration management, and command execution framework"
-HOMEPAGE="http://ansible.cc/"
-SRC_URI="https://github.com/ansible/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-KEYWORDS="~amd64 ~x86"
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="examples paramiko +sudo test"
-
-DEPEND="${PYTHON_DEPS}
- test? (
- dev-python/nose
- dev-vcs/git
- )"
-RDEPEND="
- dev-python/jinja
- dev-python/pyyaml
- paramiko? ( dev-python/paramiko )
- !paramiko? (
- virtual/ssh
- net-misc/sshpass
- )
- sudo? ( app-admin/sudo )
-"
-
-PATCHES=( "${FILESDIR}/${P}-distribution-fix.patch" )
-
-src_prepare() {
- distutils-r1_src_prepare
- # Skip tests which need ssh access
- sed -i 's:PYTHONPATH=./lib nosetests.*:\0 -e \\(TestPlayBook.py\\|TestRunner.py\\):' Makefile || die "sed failed"
-}
-
-src_test() {
- make tests
-}
-
-src_install() {
- distutils-r1_src_install
-
- insinto /usr/share/ansible
- doins library/*
-
- doman docs/man/man1/*.1
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
- # Hint: do not install example config files into /etc
- # let this choice to user
-
- newenvd "${FILESDIR}"/${PN}.env 95ansible
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- elog "You can define parameters through shell variables OR use config files"
- elog "Examples of config files installed in /usr/share/doc/${P}/examples"
- elog "You have to create ansible hosts file!"
- elog "More info on http://ansible.cc/docs/gettingstarted.html"
- fi
-}
diff --git a/app-admin/ansible/files/ansible-0.9-distribution-fix.patch b/app-admin/ansible/files/ansible-0.9-distribution-fix.patch
deleted file mode 100644
index 58841ea7bfc1..000000000000
--- a/app-admin/ansible/files/ansible-0.9-distribution-fix.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-commit e41f89d507ec92339bf8751e1f5fd72233ff299d
-Author: Sergey Popov <admin@pinkbyte.ru>
-Date: Thu Jan 10 15:08:00 2013 +0400
-
- Fix distribution detection - return string instead of functions
-
-diff --git a/lib/ansible/module_common.py b/lib/ansible/module_common.py
-index 3db8439..882e5cd 100644
---- a/lib/ansible/module_common.py
-+++ b/lib/ansible/module_common.py
-@@ -96,10 +96,10 @@ def get_distribution():
- ''' return the distribution name '''
- if platform.system() == 'Linux':
- try:
-- distribution = platform.linux_distribution()[0].capitalize
-+ distribution = platform.linux_distribution()[0].capitalize()
- except:
- # FIXME: MethodMissing, I assume?
-- distribution = platform.dist()[0].capitalize
-+ distribution = platform.dist()[0].capitalize()
- else:
- distribution = None
- return distribution
diff --git a/app-admin/ansible/metadata.xml b/app-admin/ansible/metadata.xml
index b8ecbef63a03..24d2f3898468 100644
--- a/app-admin/ansible/metadata.xml
+++ b/app-admin/ansible/metadata.xml
@@ -1,24 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>proxy-maintainers</herd>
- <maintainer>
- <email>givi-zurabovich@mail.ru</email>
- <name>Georgy Kovtunov</name>
- <description>Maintainer. Assign bugs to him</description>
- </maintainer>
<maintainer>
<email>pinkbyte@gentoo.org</email>
<name>Sergey Popov</name>
- <description>Proxy maintainer. CC him on bugs</description>
</maintainer>
<upstream>
<remote-id type="github">ansible/ansible</remote-id>
<bugs-to>https://github.com/ansible/ansible/issues</bugs-to>
</upstream>
<longdescription lang="en">Radically simple deployment, model-driven configuration management, and command execution framework.</longdescription>
- <use>
- <flag name="paramiko">Use <pkg>dev-python/paramiko</pkg> as SSH library (deprecated)</flag>
- <flag name="sudo">Use <pkg>app-admin/sudo</pkg> on client nodes (deprecated)</flag>
- </use>
</pkgmetadata>