summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2007-06-12 03:02:09 +0000
committerWilliam Hubbs <williamh@gentoo.org>2007-06-12 03:02:09 +0000
commitc00ebc74efa056f4e84f77853a19df09ea2fa26a (patch)
treef2c26ffe96481a501e49be5ce71b294af210135c /app-accessibility
parentMinor version bump, major changes. (diff)
downloadgentoo-2-c00ebc74efa056f4e84f77853a19df09ea2fa26a.tar.gz
gentoo-2-c00ebc74efa056f4e84f77853a19df09ea2fa26a.tar.bz2
gentoo-2-c00ebc74efa056f4e84f77853a19df09ea2fa26a.zip
Version bump.
(Portage version: 2.1.2.9)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/brltty/ChangeLog8
-rw-r--r--app-accessibility/brltty/brltty-3.8.ebuild54
-rw-r--r--app-accessibility/brltty/files/digest-brltty-3.83
-rw-r--r--app-accessibility/brltty/metadata.xml2
4 files changed, 65 insertions, 2 deletions
diff --git a/app-accessibility/brltty/ChangeLog b/app-accessibility/brltty/ChangeLog
index f96f3cb8c310..f17988261027 100644
--- a/app-accessibility/brltty/ChangeLog
+++ b/app-accessibility/brltty/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/brltty
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/ChangeLog,v 1.54 2007/06/01 06:54:21 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/ChangeLog,v 1.55 2007/06/12 03:02:09 williamh Exp $
+
+*brltty-3.8 (12 Jun 2007)
+
+ 12 Jun 2007; William Hubbs <williamh@gentoo.org> metadata.xml,
+ +brltty-3.8.ebuild:
+ Version bump.
01 Jun 2007; William Hubbs <williamh@gentoo.org>
+files/brltty-3.7.2-linux-compiler-h.patch, brltty-3.7.2-r1.ebuild:
diff --git a/app-accessibility/brltty/brltty-3.8.ebuild b/app-accessibility/brltty/brltty-3.8.ebuild
new file mode 100644
index 000000000000..f309c8c3377a
--- /dev/null
+++ b/app-accessibility/brltty/brltty-3.8.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/brltty-3.8.ebuild,v 1.1 2007/06/12 03:02:09 williamh Exp $
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Daemon that provides access to the Linux/Unix console for a blind person"
+HOMEPAGE="http://mielke.cc/brltty/"
+SRC_URI="http://mielke.cc/brltty/releases/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc gpm usb X"
+
+DEPEND=" gpm? ( >=sys-libs/gpm-1.20 )
+ X? ( || ( x11-libs/libXaw virtual/x11 ) )"
+
+src_compile() {
+ econf --prefix=/ \
+ `use_enable gpm` \
+ `use_with X x` \
+ `use_enable usb usb-support` \
+ --includedir=/usr/include || die
+ emake || die
+}
+
+src_install() {
+ make INSTALL_PROGRAM="\${INSTALL_SCRIPT}" INSTALL_ROOT=${D} install || die
+ TMPDIR=../../Programs scanelf -RBXr ${D} -o /dev/null
+ libdir="$(get_libdir)"
+ mkdir -p ${D}/usr/${libdir}/
+ mv ${D}/${libdir}/*.a ${D}/usr/${libdir}/
+ gen_usr_ldscript libbrlapi.so
+ cd Documents
+ rm *.made
+ dodoc ChangeLog README* Manual.* TODO brltty.conf
+ dohtml -r Manual-HTML
+ newinitd ${FILESDIR}/brltty.rc brltty
+ if use doc; then
+ dodoc BrlAPI.* BrlAPIref.doxy
+ dohtml -r BrlAPI-HTML BrlAPIref-HTML
+ fi
+}
+
+pkg_postinst() {
+ elog
+ elog There is a sample config file in /usr/share/doc/${P}/brltty.conf.
+ elog To use this file, uncompress it into /etc/brltty
+ elog
+ elog To make brltty start on boot, type this command as root:
+ elog
+ elog rc-update add brltty boot
+}
diff --git a/app-accessibility/brltty/files/digest-brltty-3.8 b/app-accessibility/brltty/files/digest-brltty-3.8
new file mode 100644
index 000000000000..99e1e2f37f23
--- /dev/null
+++ b/app-accessibility/brltty/files/digest-brltty-3.8
@@ -0,0 +1,3 @@
+MD5 542fa50d1433aa77e151432cc6abeebc brltty-3.8.tar.gz 1641781
+RMD160 c7c5447b10dee9aa4636473c133be4eba8603cae brltty-3.8.tar.gz 1641781
+SHA256 9c230a8f35486fbdecb54745c88ee1c1cb2fb5baf6b403dcc0108936349b7f8b brltty-3.8.tar.gz 1641781
diff --git a/app-accessibility/brltty/metadata.xml b/app-accessibility/brltty/metadata.xml
index b833a9c4ec19..f049738fdb2a 100644
--- a/app-accessibility/brltty/metadata.xml
+++ b/app-accessibility/brltty/metadata.xml
@@ -4,7 +4,7 @@
<herd>accessibility</herd>
<maintainer>
<email>williamh@gentoo.org</email>
- <name>Deedra Waters</name>
+ <name>William Hubbs</name>
</maintainer>
<longdescription lang="en">
BRLTTY is a background process (daemon) which provides access to the Linux/Unix