summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2007-02-06 06:27:38 +0000
committerWilliam Hubbs <williamh@gentoo.org>2007-02-06 06:27:38 +0000
commit9f1b834d358dee814f9383c04e6a060f7cd8249e (patch)
tree4a861f1260f61fc6920e06c1b716f926f61698b9 /app-accessibility
parentstable x86; bug #160569 (diff)
downloadgentoo-2-9f1b834d358dee814f9383c04e6a060f7cd8249e.tar.gz
gentoo-2-9f1b834d358dee814f9383c04e6a060f7cd8249e.tar.bz2
gentoo-2-9f1b834d358dee814f9383c04e6a060f7cd8249e.zip
Added patches to fix segfault on ppc64 and remove ARCH_BIG from the makefile.
(Portage version: 2.1.2-r7)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/espeak/espeak-1.19.ebuild6
-rw-r--r--app-accessibility/espeak/files/espeak-1.19-big-endian.patch24
-rw-r--r--app-accessibility/espeak/files/espeak-1.19-ppc64-segfault.patch13
3 files changed, 42 insertions, 1 deletions
diff --git a/app-accessibility/espeak/espeak-1.19.ebuild b/app-accessibility/espeak/espeak-1.19.ebuild
index 04f6a961efb5..ea84f4326f8d 100644
--- a/app-accessibility/espeak/espeak-1.19.ebuild
+++ b/app-accessibility/espeak/espeak-1.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/espeak-1.19.ebuild,v 1.1 2007/01/31 06:00:27 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/espeak-1.19.ebuild,v 1.2 2007/02/06 06:27:38 williamh Exp $
inherit eutils
@@ -30,6 +30,10 @@ src_unpack() {
if has_version "=media-libs/portaudio-19*" ; then
mv -f "${S}/src/portaudio19.h" "${S}/src/portaudio.h"
fi
+ # Apply patch to support big-endian processors
+ epatch ${FILESDIR}/${P}-big-endian.patch
+ # Apply patch for ppc64 segfault
+ epatch ${FILESDIR}/${P}-ppc64-segfault.patch
}
src_compile() {
diff --git a/app-accessibility/espeak/files/espeak-1.19-big-endian.patch b/app-accessibility/espeak/files/espeak-1.19-big-endian.patch
new file mode 100644
index 000000000000..bf23acacd039
--- /dev/null
+++ b/app-accessibility/espeak/files/espeak-1.19-big-endian.patch
@@ -0,0 +1,24 @@
+--- src/Makefile 2007-02-05 21:09:47.000000000 -0600
++++ src/Makefile 2007-02-05 22:10:32.000000000 -0600
+@@ -39,9 +39,6 @@
+ LIBS3=-lstdc++ ./libespeak.so
+
+ CXXFLAGS=-O2
+-ifeq ($(shell uname -m), ppc)
+- CXXFLAGS += -D ARCH_BIG
+-endif
+
+
+ all: $(BIN_NAME) $(LIB_NAME) $(BIN2_NAME)
+--- src/speech.h 2007-02-05 22:06:44.000000000 -0600
++++ src/speech.h 2007-02-05 23:15:02.000000000 -0600
+@@ -31,6 +31,9 @@
+ #define USE_ASYNC
+ #endif
+
++#if defined(BYTE_ORDER) && BYTE_ORDER == BIG_ENDIAN
++#define ARCH_BIG
++#endif
+
+ // will look for espeak_data directory here, and also in user's home directory
+ #ifndef PATH_ESPEAK_DATA
diff --git a/app-accessibility/espeak/files/espeak-1.19-ppc64-segfault.patch b/app-accessibility/espeak/files/espeak-1.19-ppc64-segfault.patch
new file mode 100644
index 000000000000..ac39760ebcf3
--- /dev/null
+++ b/app-accessibility/espeak/files/espeak-1.19-ppc64-segfault.patch
@@ -0,0 +1,13 @@
+--- src/speak_lib.cpp 2007-02-01 19:34:01.360979913
++0000
++++ src/speak_lib.cpp 2007-02-01 19:34:13.708979913
++0000
+@@ -238,7 +238,7 @@
+ char *Alloc(int size)
+ {//==================
+ char *p;
+- if((p = (char *)malloc(size)) == NULL)
++ if((p = (char *)malloc(size+1)) == NULL)
+ fprintf(stderr,"Can't allocate memory\n");
+ return(p);
+ }