summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-03-29 21:37:31 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-03-29 21:37:31 +0000
commit4bb91ae4df426b66acfe4e056436f1c2bd6cb92e (patch)
treed0c5129dbf69bdd1e0d94bae41e30594674261d0 /app-accessibility
parentamd64 stable (diff)
downloadgentoo-2-4bb91ae4df426b66acfe4e056436f1c2bd6cb92e.tar.gz
gentoo-2-4bb91ae4df426b66acfe4e056436f1c2bd6cb92e.tar.bz2
gentoo-2-4bb91ae4df426b66acfe4e056436f1c2bd6cb92e.zip
bump to 4.7.0
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/dasher/ChangeLog10
-rw-r--r--app-accessibility/dasher/dasher-4.7.0.ebuild87
-rw-r--r--app-accessibility/dasher/files/dasher-4.7.0-as-needed.patch26
3 files changed, 121 insertions, 2 deletions
diff --git a/app-accessibility/dasher/ChangeLog b/app-accessibility/dasher/ChangeLog
index 2c1d30ed9b66..d544b0e8cdab 100644
--- a/app-accessibility/dasher/ChangeLog
+++ b/app-accessibility/dasher/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/dasher
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.121 2007/11/29 05:01:46 jer Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.122 2008/03/29 21:37:30 eva Exp $
+
+*dasher-4.7.0 (29 Mar 2008)
+
+ 29 Mar 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/dasher-4.7.0-as-needed.patch, +dasher-4.7.0.ebuild:
+ bump to 4.7.0
29 Nov 2007; Jeroen Roovers <jer@gentoo.org>
+files/dasher-4.6.1-lldiv.patch, dasher-4.6.1.ebuild:
diff --git a/app-accessibility/dasher/dasher-4.7.0.ebuild b/app-accessibility/dasher/dasher-4.7.0.ebuild
new file mode 100644
index 000000000000..158af3dfbe2b
--- /dev/null
+++ b/app-accessibility/dasher/dasher-4.7.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/dasher-4.7.0.ebuild,v 1.1 2008/03/29 21:37:30 eva Exp $
+
+WANT_AUTOCONF="2.5"
+WANT_AUTOMAKE="1.8"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="A text entry interface, driven by continuous pointing gestures"
+HOMEPAGE="http://www.inference.phy.cam.ac.uk/dasher/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="accessibility cairo gnome"
+
+# The package claims to support 'qte', but it hasn't been tested.
+# Any patches from someone who can test it are welcome.
+# <leonardop@gentoo.org>
+RDEPEND=">=dev-libs/glib-2.6
+ dev-libs/expat
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/gconf-2
+ >=gnome-base/libglade-2
+ gnome? (
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-vfs-2 )
+ accessibility? (
+ app-accessibility/gnome-speech
+ >=gnome-base/libbonobo-2
+ >=gnome-base/orbit-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-extra/at-spi-1
+ dev-libs/atk )
+ cairo? ( >=x11-libs/gtk+-2.8 )
+ x11-libs/libX11
+ x11-libs/libXtst
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ gnome? (
+ >=app-text/gnome-doc-utils-0.3.2
+ app-text/scrollkeeper )
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+
+pkg_setup() {
+ # we might want to support japanese and chinese input at some point
+ # --enable-japanese
+ # --enable-chinese
+ # --enable-tilt (tilt sensor support)
+
+ G2CONF="--disable-scrollkeeper
+ $(use_enable accessibility a11y)
+ $(use_enable accessibility speech)
+ $(use_with cairo)
+ $(use_with gnome)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ sed -i -e 's:gtk-update-icon-cache:true:' ./Data/Makefile.am
+
+ # Fix build with --as-needed (upstream bug #525028)
+ epatch "${FILESDIR}/${PN}-4.7.0-as-needed.patch"
+
+ # Patches to fix compilation when USE=-gnome is used
+ # (bug #165154 and bug #189307)
+ epatch "${FILESDIR}/${PN}-4.4.0-gnome_help.patch"
+ epatch "${FILESDIR}/${PN}-4.6.1-gnome.patch"
+
+ # Fix compilation with glibc-2.5
+ epatch "${FILESDIR}/${PN}-4.6.1-lldiv.patch"
+
+ # Fix tests (upstream bug #525035)
+ echo "Data/dasher.desktop.in" >> po/POTFILES.in
+
+ eautoreconf
+ intltoolize --force || die "intltoolize failed"
+}
diff --git a/app-accessibility/dasher/files/dasher-4.7.0-as-needed.patch b/app-accessibility/dasher/files/dasher-4.7.0-as-needed.patch
new file mode 100644
index 000000000000..0487f67dc60c
--- /dev/null
+++ b/app-accessibility/dasher/files/dasher-4.7.0-as-needed.patch
@@ -0,0 +1,26 @@
+diff -Nura dasher-4.7.0.old/Src/Makefile.am dasher-4.7.0/Src/Makefile.am
+--- dasher-4.7.0.old/Src/Makefile.am 2008-03-29 22:11:18.000000000 +0100
++++ dasher-4.7.0/Src/Makefile.am 2008-03-29 22:12:27.000000000 +0100
+@@ -24,17 +24,17 @@
+ -DPACKAGE_LOCALE_DIR=\"$(datadir)/locale\"
+
+ dasher_LDADD = \
+- $(GTK2BUILD_LIBS) \
+- -lexpat \
+- $(POPT_LIBS) \
+- $(GPELIB) \
+ Common/libdashermisc.a \
+ Gtk2/libdashergtk.a \
+ Gtk2/libdashercontrol.a \
+ DasherCore/libdashercore.a \
+ DasherCore/libdasherprefs.a \
+ DasherCore/LanguageModelling/libdasherlm.a \
+- Common/libdashermisc.a
++ Common/libdashermisc.a \
++ $(GTK2BUILD_LIBS) \
++ -lexpat \
++ $(POPT_LIBS) \
++ $(GPELIB)
+ #endif
+
+ #if DOQTE