summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-25 01:36:52 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-25 01:36:52 +0000
commitfe7cbb887673d675c0444a12c702ea6599eca6e8 (patch)
tree0443b419cba9477e410bd42225f113262175fd77
parentIUSE; don't rdepend on sed; use character class in sed; error check disk io; ... (diff)
downloadgentoo-2-fe7cbb887673d675c0444a12c702ea6599eca6e8.tar.gz
gentoo-2-fe7cbb887673d675c0444a12c702ea6599eca6e8.tar.bz2
gentoo-2-fe7cbb887673d675c0444a12c702ea6599eca6e8.zip
arm KEYWORDS
-rw-r--r--net-www/lynx/lynx-2.8.5.ebuild28
-rw-r--r--sys-apps/busybox/busybox-0.60.5-r2.ebuild10
-rw-r--r--sys-apps/busybox/busybox-1.00_pre8.ebuild4
-rw-r--r--sys-apps/tinylogin/tinylogin-1.4.ebuild10
4 files changed, 20 insertions, 32 deletions
diff --git a/net-www/lynx/lynx-2.8.5.ebuild b/net-www/lynx/lynx-2.8.5.ebuild
index f424a0a87f8f..a60a9c7fd45b 100644
--- a/net-www/lynx/lynx-2.8.5.ebuild
+++ b/net-www/lynx/lynx-2.8.5.ebuild
@@ -1,36 +1,26 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/lynx/lynx-2.8.5.ebuild,v 1.7 2004/04/27 20:39:57 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/lynx/lynx-2.8.5.ebuild,v 1.8 2004/05/25 01:35:07 vapier Exp $
-inherit eutils
-
-IUSE="ssl nls ipv6"
+inherit eutils flag-o-matic
#MY_PV=${PV/.1d/rel.1}
-S=${WORKDIR}/${PN}${PV//./-}
DESCRIPTION="An excellent console-based web browser with ssl support"
HOMEPAGE="http://lynx.browser.org/"
SRC_URI="ftp://lynx.isc.org/lynx/${PN}2.8.5/${PN}${PV}.tar.bz2"
-KEYWORDS="x86 ~ppc sparc ~alpha hppa ~mips ~ia64 amd64 ppc64"
-SLOT="0"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc sparc ~mips ~alpha arm hppa amd64 ~ia64 ppc64"
+IUSE="ssl nls ipv6"
DEPEND=">=sys-libs/ncurses-5.1
>=sys-libs/zlib-1.1.3
nls? ( sys-devel/gettext )
ssl? ( >=dev-libs/openssl-0.9.6 )"
-
PROVIDE="virtual/textbrowser"
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- # GCC3.1 support -- check if it's really needed in
- # future. Some users report complete success with -r3 --
- # credit to lostlogix and carpaski. Resolves #3172
-# epatch ${FILESDIR}/${P}-gentoo.patch
-}
+S=${WORKDIR}/${PN}${PV//./-}
src_compile() {
local myconf
@@ -38,7 +28,7 @@ src_compile() {
use ssl && myconf="${myconf} --with-ssl=yes"
use ipv6 && myconf="${myconf} --enable-ipv6"
- CFLAGS="${CFLAGS} -DANSI_VARARGS"
+ append-flags -DANSI_VARARGS
econf \
--libdir=/etc/lynx \
@@ -64,7 +54,7 @@ src_install() {
dosed "s|^HELPFILE.*$|HELPFILE:file://localhost/usr/share/doc/${PF}/lynx_help/lynx_help/lynx_help_main.html|" \
/etc/lynx/lynx.cfg
- dodoc CHANGES COPYHEADER COPYING INSTALLATION PROBLEMS README
+ dodoc CHANGES COPYHEADER INSTALLATION PROBLEMS README
docinto docs
dodoc docs/*
docinto lynx_help
diff --git a/sys-apps/busybox/busybox-0.60.5-r2.ebuild b/sys-apps/busybox/busybox-0.60.5-r2.ebuild
index 41b0027e69d4..2455e5d5c17f 100644
--- a/sys-apps/busybox/busybox-0.60.5-r2.ebuild
+++ b/sys-apps/busybox/busybox-0.60.5-r2.ebuild
@@ -1,23 +1,21 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-0.60.5-r2.ebuild,v 1.5 2004/04/27 21:02:42 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-0.60.5-r2.ebuild,v 1.6 2004/05/25 01:36:52 vapier Exp $
inherit flag-o-matic eutils
-S=${WORKDIR}/${P}
DESCRIPTION="Utilities for rescue and embedded systems"
+HOMEPAGE="http://www.busybox.net/"
SRC_URI="http://www.busybox.net/downloads/${P}.tar.gz"
-HOMEPAGE="http://www.busybox.net"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~amd64 -alpha"
+SLOT="0"
+KEYWORDS="~x86 arm ~amd64 -alpha"
IUSE="static uclibc diet devfs"
DEPEND="virtual/glibc
diet? ( dev-libs/dietlibc )
>=sys-apps/sed-4"
-
RDEPEND="!static? (
!diet? ( virtual/glibc )
diet? ( dev-libs/dietlibc )
diff --git a/sys-apps/busybox/busybox-1.00_pre8.ebuild b/sys-apps/busybox/busybox-1.00_pre8.ebuild
index 2ec49d8ab2d6..64c805c5e080 100644
--- a/sys-apps/busybox/busybox-1.00_pre8.ebuild
+++ b/sys-apps/busybox/busybox-1.00_pre8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.00_pre8.ebuild,v 1.2 2004/03/05 15:20:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.00_pre8.ebuild,v 1.3 2004/05/25 01:36:52 vapier Exp $
MY_PV=${PV/_/-}
MY_P=${PN}-${MY_PV}
@@ -11,7 +11,7 @@ SRC_URI="http://www.busybox.net/downloads/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="~x86 ~ppc arm"
IUSE="debug static uclibc savedconfig make-busybox-symlinks"
DEPEND="virtual/glibc
diff --git a/sys-apps/tinylogin/tinylogin-1.4.ebuild b/sys-apps/tinylogin/tinylogin-1.4.ebuild
index 820c472cecd6..ce8da28b412a 100644
--- a/sys-apps/tinylogin/tinylogin-1.4.ebuild
+++ b/sys-apps/tinylogin/tinylogin-1.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/tinylogin/tinylogin-1.4.ebuild,v 1.2 2003/07/15 18:19:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tinylogin/tinylogin-1.4.ebuild,v 1.3 2004/05/25 01:36:50 vapier Exp $
DESCRIPTION="worlds smallest login/passwd/getty/etc"
HOMEPAGE="http://tinylogin.busybox.net/"
@@ -8,7 +8,7 @@ SRC_URI="http://tinylogin.busybox.net/downloads/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="x86 arm amd64"
IUSE="uclibc"
DEPEND="virtual/glibc"
@@ -16,7 +16,7 @@ DEPEND="virtual/glibc"
src_compile() {
local myconf=""
use static && myconf="${myconf} DOSTATIC=true"
- if [ `use uclibc` ] ; then
+ if use uclibc ; then
myconf="${myconf} \
CC=/usr/i386-linux-uclibc/bin/i386-uclibc-gcc \
USE_SYSTEM_PWD=false"
@@ -27,7 +27,7 @@ src_compile() {
src_install() {
into /
- dobin tinylogin
+ dobin tinylogin || die
into /usr
dodoc Changelog README TODO