summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2005-11-27 19:31:44 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2005-11-27 19:31:44 +0000
commite5e9e4adb529bc07363a53b3cccee901f35cb273 (patch)
treed804ef6a9f13b2c273e301409b1abc631943856a
parentMarked ppc stable for bug #113239. (diff)
downloadgentoo-2-e5e9e4adb529bc07363a53b3cccee901f35cb273.tar.gz
gentoo-2-e5e9e4adb529bc07363a53b3cccee901f35cb273.tar.bz2
gentoo-2-e5e9e4adb529bc07363a53b3cccee901f35cb273.zip
Add patch to fix issues with having ":unscaled" in font paths.
(Portage version: 2.0.53_rc7)
-rw-r--r--x11-libs/libXfont/ChangeLog8
-rw-r--r--x11-libs/libXfont/Manifest5
-rw-r--r--x11-libs/libXfont/files/digest-libXfont-0.99.2-r11
-rw-r--r--x11-libs/libXfont/files/fontpath_unscaled.patch123
-rw-r--r--x11-libs/libXfont/libXfont-0.99.2-r1.ebuild30
5 files changed, 165 insertions, 2 deletions
diff --git a/x11-libs/libXfont/ChangeLog b/x11-libs/libXfont/ChangeLog
index 2cab809f2e21..8033d7b0fcfb 100644
--- a/x11-libs/libXfont/ChangeLog
+++ b/x11-libs/libXfont/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/libXfont
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXfont/ChangeLog,v 1.12 2005/11/11 17:31:59 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXfont/ChangeLog,v 1.13 2005/11/27 19:31:44 joshuabaergen Exp $
+
+*libXfont-0.99.2-r1 (27 Nov 2005)
+
+ 27 Nov 2005; Joshua Baergen <joshuabaergen@gentoo.org>
+ +files/fontpath_unscaled.patch, +libXfont-0.99.2-r1.ebuild:
+ Add patch to fix issues with having ":unscaled" in font paths.
*libXfont-0.99.2 (11 Nov 2005)
diff --git a/x11-libs/libXfont/Manifest b/x11-libs/libXfont/Manifest
index 7556ad7a6fdf..36626bcb60b9 100644
--- a/x11-libs/libXfont/Manifest
+++ b/x11-libs/libXfont/Manifest
@@ -1,6 +1,9 @@
-MD5 0194ecbfdc8e2033e0c127a04a56ce7f ChangeLog 1929
+MD5 5dac05abe59c581642da91e3ca05eaad ChangeLog 2149
MD5 dd0c0304a6075f824a2878eea6579315 files/digest-libXfont-0.99.1 68
MD5 171ae24ee1c999cef301062401c94654 files/digest-libXfont-0.99.2 68
+MD5 171ae24ee1c999cef301062401c94654 files/digest-libXfont-0.99.2-r1 68
+MD5 3b5984d16ea4e3bd9ebbd78243c987bb files/fontpath_unscaled.patch 3430
MD5 9759ed4a026f2b1034b653c782608a2e libXfont-0.99.1.ebuild 864
+MD5 86b10919bcf2fcaea4c21822f56c1f37 libXfont-0.99.2-r1.ebuild 907
MD5 e16576a27e21d84a39b8edd318fe5402 libXfont-0.99.2.ebuild 860
MD5 a37bab73e2f24b213932c30997d3d360 metadata.xml 156
diff --git a/x11-libs/libXfont/files/digest-libXfont-0.99.2-r1 b/x11-libs/libXfont/files/digest-libXfont-0.99.2-r1
new file mode 100644
index 000000000000..c89adcf16818
--- /dev/null
+++ b/x11-libs/libXfont/files/digest-libXfont-0.99.2-r1
@@ -0,0 +1 @@
+MD5 5cf961b00af1bcb2d55146e8dfb48c3f libXfont-0.99.2.tar.bz2 540390
diff --git a/x11-libs/libXfont/files/fontpath_unscaled.patch b/x11-libs/libXfont/files/fontpath_unscaled.patch
new file mode 100644
index 000000000000..e872b5ee4870
--- /dev/null
+++ b/x11-libs/libXfont/files/fontpath_unscaled.patch
@@ -0,0 +1,123 @@
+--- src/fontfile/fontdir.c 2005/07/09 06:36:13 1.5
++++ src/fontfile/fontdir.c 2005/11/14 20:40:42 1.6
+@@ -107,12 +107,9 @@
+ FontDirectoryPtr dir;
+ int dirlen;
+ int needslash = 0;
+-#ifdef FONTDIRATTRIB
+ char *attrib;
+ int attriblen;
+-#endif
+
+-#ifdef FONTDIRATTRIB
+ #if !defined(__UNIXOS2__) && !defined(WIN32)
+ attrib = strchr(dirName, ':');
+ #else
+@@ -126,20 +123,13 @@
+ dirlen = strlen(dirName);
+ attriblen = 0;
+ }
+-#else
+- dirlen = strlen(dirName);
+-#endif
+ if (dirName[dirlen - 1] != '/')
+ #ifdef NCD
+ if (dirlen) /* leave out slash for builtins */
+ #endif
+ needslash = 1;
+-#ifdef FONTDIRATTRIB
+ dir = (FontDirectoryPtr) xalloc(sizeof *dir + dirlen + needslash + 1 +
+ (attriblen ? attriblen + 1 : 0));
+-#else
+- dir = (FontDirectoryPtr) xalloc(sizeof *dir + dirlen + needslash + 1);
+-#endif
+ if (!dir)
+ return (FontDirectoryPtr)0;
+ if (!FontFileInitTable (&dir->scalable, 0))
+@@ -156,7 +146,6 @@
+ dir->directory = (char *) (dir + 1);
+ dir->dir_mtime = 0;
+ dir->alias_mtime = 0;
+-#ifdef FONTDIRATTRIB
+ if (attriblen)
+ dir->attributes = dir->directory + dirlen + needslash + 1;
+ else
+@@ -165,9 +154,6 @@
+ dir->directory[dirlen] = '\0';
+ if (dir->attributes)
+ strcpy(dir->attributes, attrib);
+-#else
+- strcpy(dir->directory, dirName);
+-#endif
+ if (needslash)
+ strcat(dir->directory, "/");
+ return dir;
+@@ -633,9 +619,7 @@
+ FontScalableExtraPtr extra;
+ FontEntryPtr bitmap = 0, scalable;
+ Bool isscale;
+-#ifdef FONTDIRATTRIB
+ Bool scalable_xlfd;
+-#endif
+
+ renderer = FontFileMatchRenderer (fileName);
+ if (!renderer)
+@@ -661,7 +645,6 @@
+ (vals.values_supplied & PIXELSIZE_MASK) != PIXELSIZE_ARRAY &&
+ (vals.values_supplied & POINTSIZE_MASK) != POINTSIZE_ARRAY &&
+ !(vals.values_supplied & ENHANCEMENT_SPECIFY_MASK);
+-#ifdef FONTDIRATTRIB
+ #define UNSCALED_ATTRIB "unscaled"
+ scalable_xlfd = (isscale &&
+ (((vals.values_supplied & PIXELSIZE_MASK) == 0) ||
+@@ -689,7 +672,6 @@
+ ptr1 = ptr2 + 1;
+ } while (ptr2);
+ }
+-#endif
+ if (!isscale || (vals.values_supplied & SIZE_SPECIFY_MASK))
+ {
+ /*
+--- src/fontfile/dirfile.c 2005/07/09 06:36:13 1.5
++++ src/fontfile/dirfile.c 2005/11/14 20:40:42 1.6
+@@ -58,10 +58,8 @@
+ char file_name[MAXFONTFILENAMELEN];
+ char font_name[MAXFONTNAMELEN];
+ char dir_file[MAXFONTFILENAMELEN];
+-#ifdef FONTDIRATTRIB
+ char dir_path[MAXFONTFILENAMELEN];
+ char *ptr;
+-#endif
+ FILE *file;
+ int count,
+ i,
+@@ -74,7 +72,6 @@
+ if (strlen(directory) + 1 + sizeof(FontDirFile) > sizeof(dir_file))
+ return BadFontPath;
+
+-#ifdef FONTDIRATTRIB
+ /* Check for font directory attributes */
+ #if !defined(__UNIXOS2__) && !defined(WIN32)
+ if ((ptr = strchr(directory, ':'))) {
+@@ -88,9 +85,6 @@
+ strcpy(dir_path, directory);
+ }
+ strcpy(dir_file, dir_path);
+-#else
+- strcpy(dir_file, directory);
+-#endif
+ if (dir_file[strlen(dir_file) - 1] != '/')
+ strcat(dir_file, "/");
+ strcat(dir_file, FontDirFile);
+@@ -147,11 +141,7 @@
+ } else if (errno != ENOENT) {
+ return BadFontPath;
+ }
+-#ifdef FONTDIRATTRIB
+ status = ReadFontAlias(dir_path, FALSE, &dir);
+-#else
+- status = ReadFontAlias(directory, FALSE, &dir);
+-#endif
+ if (status != Successful) {
+ if (dir)
+ FontFileFreeDir (dir);
diff --git a/x11-libs/libXfont/libXfont-0.99.2-r1.ebuild b/x11-libs/libXfont/libXfont-0.99.2-r1.ebuild
new file mode 100644
index 000000000000..f28051c88bac
--- /dev/null
+++ b/x11-libs/libXfont/libXfont-0.99.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXfont/libXfont-0.99.2-r1.ebuild,v 1.1 2005/11/27 19:31:44 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org Xfont library"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~s390 ~sh ~sparc ~x86"
+IUSE="cid truetype speedo bitmap-fonts ipv6"
+RDEPEND="x11-libs/xtrans
+ x11-libs/libfontenc
+ x11-proto/xproto
+ x11-proto/fontsproto
+ truetype? ( >=media-libs/freetype-2 )"
+DEPEND="${RDEPEND}
+ x11-proto/fontcacheproto"
+
+PATCHES="${FILESDIR}/fontpath_unscaled.patch"
+
+CONFIGURE_OPTIONS="$(use_enable cid)
+ $(use_enable speedo)
+ $(use_enable truetype freetype)
+ $(use_enable bitmap-fonts pcfformat)
+ $(use_enable bitmap-fonts bdfformat)
+ $(use_enable bitmap-fonts snfformat)
+ $(use_enable ipv6)
+ --enable-type1"