summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Morey <peitolm@gentoo.org>2004-05-06 18:06:18 +0000
committerColin Morey <peitolm@gentoo.org>2004-05-06 18:06:18 +0000
commite21d6731f8ca5dbc2f7aa26a062106c7feb924e1 (patch)
tree45e3bd018d38c3cde13bb4961635649c0e333b1c
parentadded ~sparc, #50270 (Manifest recommit) (diff)
downloadgentoo-2-e21d6731f8ca5dbc2f7aa26a062106c7feb924e1.tar.gz
gentoo-2-e21d6731f8ca5dbc2f7aa26a062106c7feb924e1.tar.bz2
gentoo-2-e21d6731f8ca5dbc2f7aa26a062106c7feb924e1.zip
Version bump, now using .bz2 source
-rw-r--r--net-mail/exim/ChangeLog7
-rw-r--r--net-mail/exim/Manifest2
-rw-r--r--net-mail/exim/exim-4.33.ebuild248
-rw-r--r--net-mail/exim/files/digest-exim-4.332
4 files changed, 258 insertions, 1 deletions
diff --git a/net-mail/exim/ChangeLog b/net-mail/exim/ChangeLog
index 570c24cb6071..7699cce55257 100644
--- a/net-mail/exim/ChangeLog
+++ b/net-mail/exim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/exim
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/exim/ChangeLog,v 1.55 2004/05/02 13:42:54 peitolm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/exim/ChangeLog,v 1.56 2004/05/06 18:06:18 peitolm Exp $
+
+*exim-4.33 (06 May 2004)
+
+ 06 May 2004; Colin Morey <peitolm@gentoo.org> exim-4.33.ebuild:
+ Version bump, now using .bz2 source
02 May 2004; Colin Morey <peitolm@gentoo.org> exim-4.32-r1.ebuild:
Bumping to Stable. Latest exiscan-acl patch
diff --git a/net-mail/exim/Manifest b/net-mail/exim/Manifest
index 15ab2d788368..75fa797cfaef 100644
--- a/net-mail/exim/Manifest
+++ b/net-mail/exim/Manifest
@@ -16,6 +16,7 @@ MD5 057de12afa38ba603e09829ab1a62cd7 exim-4.24-r2.ebuild 6292
MD5 63c04234282e1e6cac60d7e5c33744eb exim-4.24-r3.ebuild 6338
MD5 482c7b79ff60dfedc0e74e209390f775 exim-4.32.ebuild 7567
MD5 5c33ac93eaeeedff608a372b506d8a32 exim-4.32-r1.ebuild 7567
+MD5 e9b42aa3945ab43767305edf44c87b28 exim-4.33.ebuild 7570
MD5 716eeb4b64c876fe0f3e1f22a7ae2a76 exim-4.30.ebuild 6310
MD5 68fc403ba2c98ccba281939085cb9052 files/auth_conf.sub 775
MD5 0cb2ffe88c81fd7ac8429b5a19d58b35 files/configure 16346
@@ -46,3 +47,4 @@ MD5 f03fc637e154f9ca79d991e71eb063bf files/exim-4.30-conf.patch 887
MD5 11bc429bd869bdc9709fabe221ac29a7 files/digest-exim-4.30 132
MD5 56085a2d36e00a6a48cacc7baeb5f451 files/digest-exim-4.30-r1 62
MD5 3aebdc3dd469414ad4c1f0219c9db79a files/digest-exim-4.32-r1 132
+MD5 904b31332322109b4d2a382d6a253412 files/digest-exim-4.33 133
diff --git a/net-mail/exim/exim-4.33.ebuild b/net-mail/exim/exim-4.33.ebuild
new file mode 100644
index 000000000000..0db32a63a309
--- /dev/null
+++ b/net-mail/exim/exim-4.33.ebuild
@@ -0,0 +1,248 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/exim/exim-4.33.ebuild,v 1.1 2004/05/06 18:06:18 peitolm Exp $
+
+inherit eutils
+
+IUSE="tcpd ssl postgres mysql ldap pam exiscan-acl maildir lmtp ipv6 sasl wildlsearch dnsdb perl mbox X"
+
+EXISCANACL_VER=${PV}-20
+
+DESCRIPTION="A highly configurable, drop-in replacement for sendmail"
+SRC_URI="ftp://ftp.exim.org/pub/exim/exim4/${P}.tar.bz2
+ exiscan-acl? ( http://duncanthrax.net/exiscan-acl/exiscan-acl-${EXISCANACL_VER}.patch )"
+HOMEPAGE="http://www.exim.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc"
+
+PROVIDE="virtual/mta"
+DEPEND=">=sys-apps/sed-4.0.5
+ dev-lang/perl
+ >=sys-libs/db-3.2
+ >=dev-libs/libpcre-3.4
+ pam? ( >=sys-libs/pam-0.75 )
+ tcpd? ( sys-apps/tcp-wrappers )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ ldap? ( >=net-nds/openldap-2.0.7 )
+ mysql? ( >=dev-db/mysql-3.23.28 )
+ postgres? ( >=dev-db/postgresql-7 )
+ sasl? ( >=dev-libs/cyrus-sasl-2.1.14 )"
+RDEPEND="${DEPEND}
+ net-mail/mailwrapper
+ >=net-mail/mailbase-0.00-r5"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ local myconf
+
+ epatch ${FILESDIR}/exim-4.14-tail.patch
+
+ if use maildir; then
+ einfo "Patching maildir support into exim.conf"
+ epatch ${FILESDIR}/exim-4.20-maildir.patch
+ fi
+
+ sed -i "/SYSTEM_ALIASES_FILE/ s'SYSTEM_ALIASES_FILE'/etc/mail/aliases'" ${S}/src/configure.default
+ cp ${S}/src/configure.default ${S}/src/configure.default.orig
+ epatch ${FILESDIR}/exim-4.30-conf.patch
+
+ if use exiscan-acl; then
+ einfo "Patching exican-acl support into exim ${PV}.."
+ epatch ${DISTDIR}/exiscan-acl-${EXISCANACL_VER}.patch
+ fi
+ # Includes Typo fix for bug 47106
+ sed -e "48i\CFLAGS=${CFLAGS}" \
+ -e "s:# AUTH_CRAM_MD5=yes:AUTH_CRAM_MD5=yes:" \
+ -e "s:# AUTH_PLAINTEXT=yes:AUTH_PLAINTEXT=yes:" \
+ -e "s:BIN_DIRECTORY=/usr/exim/bin:BIN_DIRECTORY=/usr/sbin:" \
+ -e "s:COMPRESS_COMMAND=/opt/gnu/bin/gzip:COMPRESS_COMMAND=/usr/bin/gzip:" \
+ -e "s:ZCAT_COMMAND=/opt/gnu/bin/zcat:ZCAT_COMMAND=/usr/bin/zcat:" \
+ -e "s:CONFIGURE_FILE=/usr/exim/configure:CONFIGURE_FILE=/etc/exim/exim.conf:" \
+ -e "s:EXIM_MONITOR=eximon.bin:# EXIM_MONITOR=eximon.bin:" \
+ -e "s:# INFO_DIRECTORY=/usr/local/info:INFO_DIRECTORY=/usr/share/info:" \
+ -e "s:# LOG_FILE_PATH=/var/log/exim_%slog:LOG_FILE_PATH=/var/log/exim/exim_%s.log:" \
+ -e "s:# PID_FILE_PATH=/var/lock/exim.pid:PID_FILE_PATH=/var/run/exim.pid:" \
+ -e "s:# SPOOL_DIRECTORY=/var/spool/exim:SPOOL_DIRECTORY=/var/spool/exim:" \
+ -e "s:# SUPPORT_MAILDIR=yes:SUPPORT_MAILDIR=yes:" \
+ -e "s:# SUPPORT_MAILSTORE=yes:SUPPORT_MAILSTORE=yes:" \
+ -e "s:EXIM_USER=:EXIM_USER=mail:" \
+ -e "s:# AUTH_SPA=yes:AUTH_SPA=yes:" \
+ src/EDITME > Local/Makefile
+
+ cd Local
+ # enable optional exim_monitor support via X use flag bug #46778
+ if use X; then
+ einfo "Configuring eximon"
+ cp ../exim_monitor/EDITME eximon.conf
+ sed -i "s:# EXIM_MONITOR=eximon.bin:EXIM_MONITOR=eximon.bin:" Makefile
+ fi
+ #These next two should resolve 37964
+ if use perl; then
+ sed -i "s:# EXIM_PERL=perl.o:EXIM_PERL=perl.o:" Makefile
+ fi
+ if use mbox; then
+ sed -i "s:# SUPPORT_MBX=yes:SUPPORT_MBX=yes:" Makefile
+ fi
+ if use pam; then
+ sed -i "s:# \(SUPPORT_PAM=yes\):\1:" Makefile
+ myconf="${myconf} -lpam"
+ fi
+ if use sasl; then
+ sed -i "s:# CYRUS_SASLAUTHD_SOCKET=/var/state/saslauthd/mux:CYRUS_SASLAUTHD_SOCKET=/var/lib/sasl2/mux:" \
+ Makefile
+ myconf="${myconf} -lsasl2"
+ fi
+ if use tcpd; then
+ sed -i "s:# \(USE_TCP_WRAPPERS=yes\):\1:" Makefile
+ myconf="${myconf} -lwrap"
+ fi
+ if use lmtp; then
+ sed -i "s:# \(TRANSPORT_LMTP=yes\):\1:" Makefile
+ fi
+ if use ipv6; then
+ echo "HAVE_IPV6=YES" >> Makefile
+ #To fix bug 41196
+ echo "IPV6_USE_INET_PTON=yes" >> Makefile
+ fi
+
+ if [ -n "$myconf" ] ; then
+ echo "EXTRALIBS=${myconf} ${LDFLAGS}" >> Makefile
+ fi
+
+ cd ${S}
+ if use ssl; then
+ sed -i \
+ -e "s:# \(SUPPORT_TLS=yes\):\1:" \
+ -e "s:# \(TLS_LIBS=-lssl -lcrypto\):\1:" Local/Makefile
+ fi
+
+ LOOKUP_INCLUDE=
+ LOOKUP_LIBS=
+
+ if use ldap; then
+ sed -i \
+ -e "s:# \(LOOKUP_LDAP=yes\):\1:" \
+ -e "s:# \(LDAP_LIB_TYPE=OPENLDAP2\):\1:" Local/Makefile
+ LOOKUP_INCLUDE="-I/usr/include/ldap"
+ LOOKUP_LIBS="-L/usr/lib -lldap -llber"
+ fi
+
+ if use mysql; then
+ sed -i "s:# LOOKUP_MYSQL=yes:LOOKUP_MYSQL=yes:" Local/Makefile
+ LOOKUP_INCLUDE="$LOOKUP_INCLUDE -I/usr/include/mysql"
+ LOOKUP_LIBS="$LOOKUP_LIBS -L/usr/lib -lmysqlclient"
+ fi
+
+ if use postgres; then
+ sed -i "s:# LOOKUP_PGSQL=yes:LOOKUP_PGSQL=yes:" Local/Makefile
+ LOOKUP_INCLUDE="$LOOKUP_INCLUDE -I/usr/include/postgresql"
+ LOOKUP_LIBS="$LOOKUP_LIBS -lpq"
+ fi
+
+ if [ -n "$LOOKUP_INCLUDE" ]; then
+ sed -i "s:# LOOKUP_INCLUDE=-I /usr/local/ldap/include -I /usr/local/mysql/include -I /usr/local/pgsql/include:LOOKUP_INCLUDE=$LOOKUP_INCLUDE:" \
+ Local/Makefile
+ fi
+
+ if [ -n "$LOOKUP_LIBS" ]; then
+ sed -i "s:# LOOKUP_LIBS=-L/usr/local/lib -lldap -llber -lmysqlclient -lpq -lgds:LOOKUP_LIBS=$LOOKUP_LIBS:" \
+ Local/Makefile
+ fi
+
+
+ cat Makefile | sed -e 's/^buildname=.*/buildname=exim-gentoo/g' > Makefile.gentoo && mv -f Makefile.gentoo Makefile
+
+ sed -i "s:# LOOKUP_DSEARCH=yes:LOOKUP_DSEARCH=yes:" Local/Makefile
+ if use wildlsearch; then
+ sed -i \
+ -e "s:# LOOKUP_WILDLSEARCH=yes:LOOKUP_WILDLSEARCH=yes:" \
+ -e "s:# LOOKUP_NWILDLSEARCH=yes:LOOKUP_NWILDLSEARCH=yes:" Local/Makefile
+ fi
+
+ if use dnsdb; then
+ sed -i "s:# LOOKUP_DNSDB=yes:LOOKUP_DNSDB=yes:" Local/Makefile
+ fi
+ sed -i "s:# LOOKUP_CDB=yes:LOOKUP_CDB=yes:" Local/Makefile
+
+ # Use the "native" interface to the DBM library
+ echo "USE_DB=yes" >> ${S}/Local/Makefile
+}
+
+src_compile() {
+ make || die "make failed"
+}
+
+
+src_install () {
+ cd ${S}/build-exim-gentoo
+ exeinto /usr/sbin
+ doexe exim
+ fperms 4755 /usr/sbin/exim
+
+ dodir /usr/bin /usr/sbin /usr/lib
+ dosym ../sbin/exim /usr/bin/mailq
+ dosym ../sbin/exim /usr/bin/newaliases
+ if \[ ! -e /usr/bin/mail \] && \[ ! -e /bin/mail \]; then
+ einfo "Installing symbolic link /usr/bin/mail -> /usr/sbin/exim"
+ einfo "If you install mailx please *REMOVE* that link, that way"
+ einfo "scripts will use the mailx-binary instead of the exim-binary."
+ dosym ../sbin/exim /usr/bin/mail
+ else
+ einfo "NOT installing symbolic link /usr/bin/mail -> /usr/sbin/exim,"
+ einfo "because you already have a mail-binary."
+ fi
+ dosym exim /usr/sbin/rsmtp
+ dosym exim /usr/sbin/rmail
+ dosym exim /usr/sbin/sendmail
+ dosym ../sbin/exim /usr/lib/sendmail
+
+ exeinto /usr/sbin
+ for i in exicyclog exim_dbmbuild exim_dumpdb exim_fixdb exim_lock \
+ exim_tidydb exinext exiwhat exigrep eximstats exiqsumm \
+ convert4r3 convert4r4
+ do
+ doexe $i
+ done
+
+ dodoc ${S}/doc/*
+ doman ${S}/doc/exim.8
+
+ # conf files
+ insinto /etc/exim
+ newins ${S}/src/configure.default.orig exim.conf.dist
+ if use exiscan-acl; then
+ newins ${S}/src/configure.default exim.conf.exiscan-acl
+ fi
+ doins ${FILESDIR}/system_filter.exim
+ doins ${FILESDIR}/auth_conf.sub
+ if use exiscan; then
+ newins ${S}/src/configure.default exim.conf.exiscan
+ doins ${FILESDIR}/exiscan.conf
+ fi
+
+ # INSTALL a pam.d file for SMTP AUTH that works with gentoo's pam
+ insinto /etc/pam.d
+ newins ${FILESDIR}/pam.d-exim exim
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/exim.rc6 exim
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/exim.confd exim
+
+ DIROPTIONS="--mode=0750 --owner=mail --group=mail"
+ dodir /var/log/${PN}
+}
+
+
+pkg_postinst() {
+ einfo "/etc/exim/system_filter.exim is a sample system_filter."
+ einfo "/etc/exim/auth_conf.sub contains the configuration sub for using smtp auth."
+ einfo "Please create /etc/exim/exim.conf from /etc/exim/exim.conf.dist."
+}
+
+
diff --git a/net-mail/exim/files/digest-exim-4.33 b/net-mail/exim/files/digest-exim-4.33
new file mode 100644
index 000000000000..9b87feb03933
--- /dev/null
+++ b/net-mail/exim/files/digest-exim-4.33
@@ -0,0 +1,2 @@
+MD5 8514c800172e4ab4e9cb90553605e1f2 exim-4.33.tar.bz2 1327741
+MD5 5e9d3be31121ea5ece12d872a368717c exiscan-acl-4.33-20.patch 395525