summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-06-05 18:09:10 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-06-05 18:09:10 +0000
commite0ce6037e32e9a33aeae05de558e697780631b60 (patch)
tree839c9f4a626effe87082f5276f895be8433dce7a
parentcleanup, x86, version bump (diff)
downloadgentoo-2-e0ce6037e32e9a33aeae05de558e697780631b60.tar.gz
gentoo-2-e0ce6037e32e9a33aeae05de558e697780631b60.tar.bz2
gentoo-2-e0ce6037e32e9a33aeae05de558e697780631b60.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--media-video/rtmpdump/ChangeLog8
-rw-r--r--media-video/rtmpdump/rtmpdump-2.2e.ebuild59
2 files changed, 66 insertions, 1 deletions
diff --git a/media-video/rtmpdump/ChangeLog b/media-video/rtmpdump/ChangeLog
index 8d48f0ae5517..3e8c592e6565 100644
--- a/media-video/rtmpdump/ChangeLog
+++ b/media-video/rtmpdump/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/rtmpdump
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/rtmpdump/ChangeLog,v 1.1 2010/06/05 11:07:22 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/rtmpdump/ChangeLog,v 1.2 2010/06/05 18:09:10 hwoarang Exp $
+
+*rtmpdump-2.2e (05 Jun 2010)
+
+ 05 Jun 2010; Markos Chandras <hwoarang@gentoo.org> +rtmpdump-2.2e.ebuild:
+ Version bump thanks to Maxime de Roucy (maxime1986)
+ <maxime.deroucy@gmail.com>
*rtmpdump-2.2d (05 Jun 2010)
diff --git a/media-video/rtmpdump/rtmpdump-2.2e.ebuild b/media-video/rtmpdump/rtmpdump-2.2e.ebuild
new file mode 100644
index 000000000000..85adcdd6a2f2
--- /dev/null
+++ b/media-video/rtmpdump/rtmpdump-2.2e.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/rtmpdump/rtmpdump-2.2e.ebuild,v 1.1 2010/06/05 18:09:10 hwoarang Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Open source command-line RTMP client intended to stream audio or video flash content"
+HOMEPAGE="http://rtmpdump.mplayerhq.hu/"
+SRC_URI="http://rtmpdump.mplayerhq.hu/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnutls polarssl ssl"
+
+DEPEND="ssl? (
+ gnutls? ( net-libs/gnutls )
+ polarssl? ( !gnutls? ( net-libs/polarssl ) )
+ !gnutls? ( !polarssl? ( dev-libs/openssl ) )
+ )
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ! use ssl && ( use gnutls || use polarssl ) ; then
+ ewarn "USE='gnutls polarssl' are ignored without USE='ssl'."
+ ewarn "Please review the local USE flags for this package."
+ fi
+}
+
+src_prepare() {
+ # fix Makefile ( bug #298535 and bug #318353 )
+ sed -i 's/\$(MAKEFLAGS)//g' Makefile \
+ || die "failed to fix Makefile"
+}
+
+src_compile() {
+ local crypto=""
+ if use ssl ; then
+ if use gnutls ; then
+ crypto="GNUTLS"
+ elif use polarssl ; then
+ crypto="POLARSSL"
+ else
+ crypto="OPENSSL"
+ fi
+ fi
+
+ emake CC=$(tc-getCC) LD=$(tc-getLD) \
+ OPT="${CFLAGS}" XLDFLAGS="${LDFLAGS}" CRYPTO="${crypto}" SYS=posix || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${DESTTREE}" mandir="${DOCDESTTREE}" install \
+ || die "emake install failed"
+ dodoc README ChangeLog rtmpdump.1.html rtmpgw.8.html || die "dodoc failed"
+}