summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2009-03-31 07:59:19 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2009-03-31 07:59:19 +0000
commitdf72eb2ebde61999fdc6ef7bcdecdd83f361a0eb (patch)
treed2057ca9d8f7bfe6915352bc7e74f7f389b70291
parentUse QA_WX_LOAD rather than QA_EXECSTACK #264348 by Mr. Bones. (diff)
downloadgentoo-2-df72eb2ebde61999fdc6ef7bcdecdd83f361a0eb.tar.gz
gentoo-2-df72eb2ebde61999fdc6ef7bcdecdd83f361a0eb.tar.bz2
gentoo-2-df72eb2ebde61999fdc6ef7bcdecdd83f361a0eb.zip
Fix files/awk/fixlafiles.awk-no_gcc_la for POSIX shell compliant.
Output functions taken from files/awk/fixlafiles.awk. Authorized by vapier wrt #264309. (Portage version: 2.2_rc28/cvs/Linux x86_64)
-rw-r--r--sys-devel/gcc/ChangeLog8
-rw-r--r--sys-devel/gcc/files/awk/fixlafiles.awk-no_gcc_la14
2 files changed, 14 insertions, 8 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 211895d82ada..227c197bd091 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.692 2009/03/30 04:19:38 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.693 2009/03/31 07:59:18 drizzt Exp $
+
+ 31 Mar 2009; Timothy Redaelli <drizzt@gentoo.org>
+ files/awk/fixlafiles.awk-no_gcc_la:
+ Fix files/awk/fixlafiles.awk-no_gcc_la for POSIX shell compliant. Output
+ functions taken from files/awk/fixlafiles.awk. Authorized by vapier wrt
+ #264309.
30 Mar 2009; Jeremy Olexa <darkside@gentoo.org> gcc-4.3.2-r3.ebuild:
amd64 stable, bug 264121
diff --git a/sys-devel/gcc/files/awk/fixlafiles.awk-no_gcc_la b/sys-devel/gcc/files/awk/fixlafiles.awk-no_gcc_la
index fb4778c40b5b..855b23d44cb5 100644
--- a/sys-devel/gcc/files/awk/fixlafiles.awk-no_gcc_la
+++ b/sys-devel/gcc/files/awk/fixlafiles.awk-no_gcc_la
@@ -1,27 +1,27 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/files/awk/fixlafiles.awk-no_gcc_la,v 1.2 2006/05/15 00:17:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/files/awk/fixlafiles.awk-no_gcc_la,v 1.3 2009/03/31 07:59:19 drizzt Exp $
#
# Helper functions
#
function printn(string) {
- system("echo -n \"" string "\"")
+ printf("%s", string)
}
function einfo(string) {
- system("echo -e \" \\e[32;01m*\\e[0m " string "\"")
+ printf(" \033[32;01m*\033[0m %s\n", string)
}
function einfon(string) {
- system("echo -ne \" \\e[32;01m*\\e[0m " string "\"")
+ printf(" \033[32;01m*\033[0m %s", string)
}
function ewarn(string) {
- system("echo -e \" \\e[33;01m*\\e[0m " string "\"")
+ printf(" \033[33;01m*\033[0m %s\n", string)
}
function ewarnn(string) {
- system("echo -ne \" \\e[33;01m*\\e[0m " string "\"")
+ printf(" \033[33;01m*\033[0m %s", string)
}
function eerror(string) {
- system("echo -e \" \\e[31;01m*\\e[0m " string "\"")
+ printf(" \033[31;01m*\033[0m %s\n", string)
}
#