summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2007-12-20 13:40:53 +0000
committerCaleb Tennis <caleb@gentoo.org>2007-12-20 13:40:53 +0000
commitd55343af1d9850bb457c5d58cda107bba8febded (patch)
tree1451f02ed49cfbf3c1f6e6266c2edbbedf26c638
parentSparc stable --- security Bug #202770 --- working for me. (diff)
downloadgentoo-2-d55343af1d9850bb457c5d58cda107bba8febded.tar.gz
gentoo-2-d55343af1d9850bb457c5d58cda107bba8febded.tar.bz2
gentoo-2-d55343af1d9850bb457c5d58cda107bba8febded.zip
Make compilation faster
(Portage version: 2.1.3.16)
-rw-r--r--x11-libs/qt-qt3support/files/configure.patch12
-rw-r--r--x11-libs/qt-qt3support/qt-qt3support-4.4.0_rc1.ebuild5
2 files changed, 16 insertions, 1 deletions
diff --git a/x11-libs/qt-qt3support/files/configure.patch b/x11-libs/qt-qt3support/files/configure.patch
new file mode 100644
index 000000000000..2e07f6b0cc74
--- /dev/null
+++ b/x11-libs/qt-qt3support/files/configure.patch
@@ -0,0 +1,12 @@
+--- configure.orig 2007-12-20 08:22:04.000000000 -0500
++++ configure 2007-12-20 08:22:08.000000000 -0500
+@@ -3615,7 +3615,7 @@
+ }
+
+ # build qmake
+-if true; then ###[ '!' -f "$outpath/bin/qmake" ];
++if false; then ###[ '!' -f "$outpath/bin/qmake" ];
+ echo "Creating qmake. Please wait..."
+
+ OLD_QCONFIG_H=
+
diff --git a/x11-libs/qt-qt3support/qt-qt3support-4.4.0_rc1.ebuild b/x11-libs/qt-qt3support/qt-qt3support-4.4.0_rc1.ebuild
index 213727162b17..899e433fa5e6 100644
--- a/x11-libs/qt-qt3support/qt-qt3support-4.4.0_rc1.ebuild
+++ b/x11-libs/qt-qt3support/qt-qt3support-4.4.0_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-qt3support/qt-qt3support-4.4.0_rc1.ebuild,v 1.1 2007/12/20 13:01:44 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-qt3support/qt-qt3support-4.4.0_rc1.ebuild,v 1.2 2007/12/20 13:40:53 caleb Exp $
inherit eutils flag-o-matic toolchain-funcs multilib
@@ -54,6 +54,9 @@ src_unpack() {
append-flags -fno-stack-protector
fi
+ # Override the creation of qmake and copy over the one from the system. This speeds up compilation time a lot.
+ epatch "${FILESDIR}"/configure.patch
+ cp ${QTBINDIR}/qmake "${S}"/bin/qmake
}
src_compile() {