summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-03-11 20:10:02 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-03-11 20:10:02 +0000
commitd01b16bdef411f31e7e617816301bbed8c46b69a (patch)
tree5b7eb762f6d175a977b01e95ac7be3a6470a068b
parentAdd ~mips keyword, unbundled in newer ghostscript-gpl wrt #401853 (diff)
downloadgentoo-2-d01b16bdef411f31e7e617816301bbed8c46b69a.tar.gz
gentoo-2-d01b16bdef411f31e7e617816301bbed8c46b69a.tar.bz2
gentoo-2-d01b16bdef411f31e7e617816301bbed8c46b69a.zip
Add patch to fix bold fonts, bug #407751.
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
-rw-r--r--x11-libs/libXft/ChangeLog8
-rw-r--r--x11-libs/libXft/files/libXft-2.3.0-bold-fonts.patch43
-rw-r--r--x11-libs/libXft/libXft-2.3.0-r1.ebuild24
3 files changed, 74 insertions, 1 deletions
diff --git a/x11-libs/libXft/ChangeLog b/x11-libs/libXft/ChangeLog
index 83e488d93f2e..7ef4283dc0df 100644
--- a/x11-libs/libXft/ChangeLog
+++ b/x11-libs/libXft/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/libXft
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXft/ChangeLog,v 1.76 2012/03/08 23:58:55 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXft/ChangeLog,v 1.77 2012/03/11 20:10:02 chithanh Exp $
+
+*libXft-2.3.0-r1 (11 Mar 2012)
+
+ 11 Mar 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +files/libXft-2.3.0-bold-fonts.patch, +libXft-2.3.0-r1.ebuild:
+ Add patch to fix bold fonts, bug #407751.
*libXft-2.3.0 (08 Mar 2012)
diff --git a/x11-libs/libXft/files/libXft-2.3.0-bold-fonts.patch b/x11-libs/libXft/files/libXft-2.3.0-bold-fonts.patch
new file mode 100644
index 000000000000..3a715527169d
--- /dev/null
+++ b/x11-libs/libXft/files/libXft-2.3.0-bold-fonts.patch
@@ -0,0 +1,43 @@
+From 84b8b5b46773f9b686d57f28092824b86bffed9d Mon Sep 17 00:00:00 2001
+From: Mikael Magnusson <mikachu@gmail.com>
+Date: Sun, 11 Mar 2012 01:41:55 +0000
+Subject: Fixup for 550b2f76401c2 which broke bold fonts
+
+The commit removed the line
+AC_CHECK_FUNCS(FT_Get_Next_Char FT_Get_BDF_Property FT_Get_PS_Font_Info FT_Has_PS_Glyph_Names FT_GlyphSlot_Embolden)
+but failed to remove the #if lines that this commit removes, resulting
+in that code never being executed.
+
+Fixes: https://bugs.freedesktop.org/attachment.cgi?id=58280
+
+Reviewed-by: Jeremy Huddleston <jeremyhu@apple.com>
+---
+diff --git a/src/xftglyphs.c b/src/xftglyphs.c
+index 4a3b9d6..2f3dc5a 100644
+--- a/src/xftglyphs.c
++++ b/src/xftglyphs.c
+@@ -24,9 +24,7 @@
+ #include <freetype/ftoutln.h>
+ #include <freetype/ftlcdfil.h>
+
+-#if HAVE_FT_GLYPHSLOT_EMBOLDEN
+ #include <freetype/ftsynth.h>
+-#endif
+
+ /*
+ * Validate the memory info for a font
+@@ -434,12 +432,10 @@ XftFontLoadGlyphs (Display *dpy,
+
+ glyphslot = face->glyph;
+
+-#if HAVE_FT_GLYPHSLOT_EMBOLDEN
+ /*
+ * Embolden if required
+ */
+ if (font->info.embolden) FT_GlyphSlot_Embolden(glyphslot);
+-#endif
+
+ /*
+ * Compute glyph metrics from FreeType information
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/x11-libs/libXft/libXft-2.3.0-r1.ebuild b/x11-libs/libXft/libXft-2.3.0-r1.ebuild
new file mode 100644
index 000000000000..b9bccb5d1c7f
--- /dev/null
+++ b/x11-libs/libXft/libXft-2.3.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXft/libXft-2.3.0-r1.ebuild,v 1.1 2012/03/11 20:10:02 chithanh Exp $
+
+EAPI=4
+inherit xorg-2 flag-o-matic
+
+DESCRIPTION="X.Org Xft library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE=""
+
+RDEPEND=">=x11-libs/libXrender-0.8.2
+ x11-libs/libX11
+ x11-libs/libXext
+ media-libs/freetype
+ media-libs/fontconfig
+ x11-proto/xproto
+ virtual/ttf-fonts"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-bold-fonts.patch
+)